Package Details: xplico v1.1.2-3

Git Clone URL: https://aur.archlinux.org/xplico.git (read-only)
Package Base: xplico
Description: Internet Traffic Decoder. Network Forensic Analysis Tool (NFAT)
Upstream URL: http://www.xplico.org/
Licenses: GPL
Submitter: M0Rf30
Maintainer: M0Rf30
Last Packager: M0Rf30
Votes: 9
Popularity: 0.000000
First Submitted: 2011-03-05 23:43
Last Updated: 2016-03-22 19:32

Dependencies (22)

Required by (1)

Sources (1)

Latest Comments

plitter commented on 2016-03-16 14:30

I'm getting this error message while compiling.
/usr/include/features.h:331:4: error: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
# warning _FORTIFY_SOURCE requires compiling with optimization (-O)
^
cc1: all warnings being treated as errors
Makefile:573: recipe for target 'arraylist.lo' failed
make[3]: *** [arraylist.lo] Error 1
make[3]: Leaving directory '/home/plitter/.build/xplico/src/xplico/third-party/json-c'
Makefile:637: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/home/plitter/.build/xplico/src/xplico/third-party/json-c'
Makefile:437: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/home/plitter/.build/xplico/src/xplico/third-party/json-c'
Makefile:139: recipe for target 'thirdparty' failed
make: *** [thirdparty] Error 2
==> ERROR: A failure occurred in build().
Aborting...

vendforce commented on 2016-02-11 19:37

Installing xplico package(s)...
:: xplico package(s) failed to install. Check .SRCINFO for mismatching data with PKGBUILD.
:: failed to build xplico package(s)

Mikaye commented on 2014-07-25 09:25

Can't compile :
make[2]: *** No rule to make target '/usr/lib/libndpi.a', needed by 'dis_tcp_grb.so'.

diff here http://www.pasteall.org/53061/diff

xaocon commented on 2013-11-22 17:51

I couldn't get the web interface to work. Any suggestions?
http://paste.escapethebot.net/144

M0Rf30 commented on 2013-11-07 18:04

now web interface works

Anonymous comment on 2011-11-20 06:08

Fatal error: Call to a member function query() on a non-object in /opt/xplico/xi/app/plugins/datasources/models/datasources/dbo/dbo_sqlite3.php on line 209
same for me :(

Anonymous comment on 2011-11-18 14:06

Since it is required in den linking process of xplico you should add the libmysqlclient package to the depends.

M0Rf30 commented on 2011-11-10 12:47

Fatal error: Call to a member function query() on a non-object in /opt/xplico/xi/app/plugins/datasources/models/datasources/dbo/dbo_sqlite3.php on line 209

dewyatt commented on 2011-10-14 02:08

I think I've mostly figured this out. For the web interface, you need to:
0) Install this package, edit your httpd.conf and php.ini as instructed. (I saw no entry for pear in php.ini, just sqlite but it seems okay anyways).
1) Install php-apache
2) Get PHP working in Apache as detailed here: https://wiki.archlinux.org/index.php/LAMP#PHP
3) Set your date.timezone in php.ini
4) Change line in /etc/httpd/conf/extra/httpd-xplico.conf from:
php_admin_value open_basedir /opt/xplico/xi:/opt/xplico/xi/app/webroot/
to:
php_admin_value open_basedir /opt/xplico/xi:/opt/xplico/xi/app/webroot/:/tmp:/opt/xplico:/var/run/dema.pid

/tmp is needed for PHP sessions (session_start will fail otherwise).
the other entry is to check if dema is running
5) Somehow install python3.1 (as /usr/bin/python3.1) and possibly httplib2 for 3.1. Xplico (unfortunately) uses some compiled python that requires 3.1.
6) Add to /etc/rc.local:
#Python 3.1 bytecode
echo ':Python3.1:M::\x4f\x0c\x0d\x0a::/usr/bin/python3.1:' > /proc/sys/fs/binfmt_misc/register
This allows you to execute python 3.1 bytecode directly like ./session_mng.pyc which is required because xplico calls scripts that way.
Check that binfmt_misc is enabled with "cat /proc/sys/fs/binfmt_misc/status".
7) Connect to 127.0.0.1:9876 and test it out

I did "chmod -R 777 /opt/xplico" to rule out permission issues, not sure if the defaults are ok or not.
You may want to set debug to 1 in /opt/xplico/xi/app/config/core.php if you have any problems.

M0Rf30 commented on 2011-10-12 13:38

I couldn't fix this error. Perhaps the daemon script is made in a wrong way

All comments