Package Details: xrdp-git 1:0.9.5.r0.g256fa119-1

Git Clone URL: https://aur.archlinux.org/xrdp-git.git (read-only)
Package Base: xrdp-git
Description: An open source remote desktop protocol (RDP) server - GIT version
Upstream URL: https://github.com/neutrinolabs/xrdp
Licenses: Apache
Conflicts: xrdp
Provides: xrdp=0.9.1
Submitter: realturner
Maintainer: bidulock
Last Packager: bidulock
Votes: 29
Popularity: 0.000001
First Submitted: 2011-02-19 10:07
Last Updated: 2018-03-13 14:41

Required by (3)

Sources (2)

Pinned Comments

bidulock commented on 2017-01-05 08:59

Upstream only tags on "master" branch and "master" branch is only updated on release. Using the "master" branch (the one with the tags) makes this package identical to the "xrdp" package: therefore, rather pointless. There is an "xrdp-devel-git" package that uses the "devel" branch and is more of a "-git" package than one which is identical to the non-git package. Those wishing to complain about tags, use this package (or "xrdp" as they are identical). Those wishing to have the latest -git commits, use the "xrdp-devel-git" package.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

JonnyJD commented on 2013-06-10 14:16

I added an updated PKGBUILD to my repository: https://github.com/JonnyJD/PKGBUILDs/blob/master/xrdp-git/PKGBUILD

This sets the conflict with xrdp, includes the changes by nocain and makes the /usr/sbin move.

This package will hopefully be updated again by realturner.

kmacleod commented on 2013-06-03 18:49

Flagged this as out-of-date for the move to unified /usr/bin.
The current package installs files in /usr/sbin.

kmacleod commented on 2013-06-03 18:09

Flagged this as out-of-date for the move to unified /usr/bin.
The current package installs files in /usr/sbin.

Anonymous comment on 2013-02-22 06:39

Here is an updated PKGBUILD file http://pastebin.com/ApYMA7A6 I tweaked it to take care of the AM_CONFIG_HEADER compile issue and added the systemd files xrdp.service and xrdp-sesman.service

quadpl_03 commented on 2013-02-19 18:44

AM_CONFIG_HEADER needs to be replaced with AC_CONFIG_HEADERS in configure.ac:
sed -i 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac

https://wiki.archlinux.org/index.php/Xrdp.

Anonymous comment on 2013-01-30 17:36

I get same compilation problem

bluerider commented on 2013-01-16 03:14

I can't seem to compile this. See below for error :

/usr/bin/autoconf
/usr/bin/automake
/usr/bin/libtool
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force
configure.ac:5: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:5: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

ImNtReal commented on 2012-11-28 15:37

This should conflict with xrdp.

Anonymous comment on 2012-10-15 19:23

Anyone else have problems launching awesome from the startwm script? It worked before update.

realturner commented on 2012-09-29 23:15

update makedepends as requested.

@techryda, kmacleod:
Nice work, thanks for informing :)
However, looks like systemd is not the default init system yet so I didn't add its support this time.
Maybe putting this in Systemd wiki page would be better?

@Ito:
That will be nice. I thinks we can mention this in Xrdp wiki page.