Package Details: xrdp 0.9.15-1

Git Clone URL: https://aur.archlinux.org/xrdp.git (read-only, click to copy)
Package Base: xrdp
Description: An open source remote desktop protocol (RDP) server
Upstream URL: https://github.com/neutrinolabs/xrdp
Licenses: Apache
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 114
Popularity: 1.31
First Submitted: 2008-01-15 15:02
Last Updated: 2021-02-25 00:09

Pinned Comments

bidulock commented on 2020-10-05 01:33

0.9.14 won't build. Use xrdp-git until fixed.

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 Next › Last »

russo79 commented on 2013-06-05 21:54

Hi tzok

Nice to see someone taking over this package.
Some suggestions to your package:

1. You should move the code that patches xrdp source into a prepare() function. It is now the new standard. I would also do the sed operation in it.

prepare() {
cd "${pkgname}-v${pkgver}"
patch -p1 -i $srcdir/fix_for_automake-1.13.patch
# Fix path in xrdp.sh file
sed -i 's|/usr/local/sbin|/usr/bin|' instfiles/xrdp.sh
}

2. You should edit the service file so that they point to /usr/bin instead of /usr/sbin. Even if /usr/sbin exists, it is now a symlink that will probably be removed some day

xrdp-sesman.service:
ExecStart=/usr/bin/xrdp-sesman $SESMAN_OPTIONS
ExecStop=/usr/bin/xrdp-sesman $SESMAN_OPTIONS --kill

xrdp.service:
ExecStart=/usr/bin/xrdp $XRDP_OPTIONS
ExecStop=/usr/bin/xrdp $XRDP_OPTIONS --kill

tzok commented on 2013-06-05 18:35

Added version with patch and adjusted to the new filesystem scheme

alex-eri commented on 2013-05-12 22:17

pls add patch to pkgbuild

alex-eri commented on 2013-05-12 22:14

configure.ac:5: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.

russo79 commented on 2013-01-16 08:40

bluerider, patch https://sourceforge.net/tracker/?func=detail&aid=3601075&group_id=112022&atid=665248 has already been submited upstream.

bluerider commented on 2013-01-16 03:25

The error can be fixed by changing "AM_CONFIG_HEADER" to "AC_CONFIG_HEADERS" in configure.ac.
This error should be reported upstream.

bluerider commented on 2013-01-16 03:15

I can't seem to compile this :

/usr/bin/autoconf
/usr/bin/automake
/usr/bin/libtool
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force
configure.ac:5: error: 'AM_CONFIG_HEADER': this macro is obsolete.
You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.ac:5: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal: error: echo failed with exit status: 1
autoreconf: aclocal failed with exit status: 1

th-fr commented on 2013-01-12 12:48

Yes, it works. Sry for the misunderstanding and thank you for the fix.

th-fr commented on 2013-01-12 12:47

Yes it works, sry for the misunderstanding.

russo79 commented on 2013-01-12 12:33

@th-fr

Oh, another thing. If you used the download link from pastebin the files may have a CR/LF line end instead of a LF only.
I suggest you to do a copy/paste of the contents of the files and save them with your favorite editor.
This may solve your problem.