Package Details: xrootd 4.8.4-1

Git Clone URL: https://aur.archlinux.org/xrootd.git (read-only)
Package Base: xrootd
Description: Software framework for fast, low latency, scalable and fault tolerant data access.
Upstream URL: http://xrootd.org/
Licenses: LGPL3
Provides: xrootd, xrootd-abi0
Submitter: kaspi
Maintainer: kgizdov
Last Packager: kgizdov
Votes: 5
Popularity: 0.020785
First Submitted: 2012-08-09 10:56
Last Updated: 2018-08-09 23:39

Latest Comments

1 2 Next › Last »

kgizdov commented on 2018-05-13 17:41

@petronny -Werror is chosen by the devs, so it would be against Arch's policy to override it. I've updated the package version and applied a patch while the issue on GitHub gets addressed - https://github.com/xrootd/xrootd/issues/702.

petronny commented on 2018-05-13 05:12

I get

[ 25%] Building CXX object src/CMakeFiles/XrdCrypto.dir/XrdCrypto/XrdCryptoAux.cc.o
[ 25%] Building CXX object src/CMakeFiles/XrdClient.dir/XrdClient/XrdClientAbs.cc.o
[ 25%] Building CXX object src/CMakeFiles/XrdXml.dir/XrdXml/XrdXmlReader.cc.o
Scanning dependencies of target XrdServer
/build/xrootd/src/xrootd-4.8.2/src/XrdApps/XrdCpFile.cc: In constructor 'XrdCpFile::XrdCpFile(const char*, int&)':
/build/xrootd/src/xrootd-4.8.2/src/XrdApps/XrdCpFile.cc:91:20: error: 'char* strncpy(char*, const char*, size_t)' output truncated copying between 4 and 5 bytes from a string of length 7 [-Werror=stringop-truncation]
            strncpy(ProtName, pTab[i].pHdr, pTab[i].pHsz-3);
            ~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[ 25%] Linking CXX shared module libXrdCksCalczcrc32-4.so
[ 25%] Building CXX object src/CMakeFiles/XrdServer.dir/XrdXrootd/XrdXrootdAdmin.cc.o
cc1plus: all warnings being treated as errors
make[2]: *** [src/CMakeFiles/XrdAppUtils.dir/build.make:76: src/CMakeFiles/XrdAppUtils.dir/XrdApps/XrdCpFile.cc.o] Error 1

Please suppress this warning (it's treated as an error).

kgizdov commented on 2017-12-06 11:01

thank for that, @alexpearce, I've updated the dependencies and included a more general way of requiring python version. Please confirm it works for you.

alexpearce commented on 2017-12-05 13:37

If one has Python 2 installed in addition to the system Python (Python 3), the installer will pick up the Python 2 libraries and install the pyxrootd bindings for Python 2.

To override this, you can pass -DXRD_PYTHON_REQ_VERSION=3.6 to the cmake call.

kaspi commented on 2017-03-17 18:08

Disowning this package in favour of kgizdov who wishes to take over.

kaspi commented on 2017-01-20 12:03

Updated to 4.5.0.

kaspi commented on 2016-09-05 17:38

Improved following the suggestion by kgizdov.

kgizdov commented on 2016-09-02 10:40

There's a bug in the build. It configures the incorrect folder for libs. Instead of moving lib64 to lib, one should pass -DCMAKE_INSTALL_LIBDIR:PATH=lib as a flag. This is a deeper issue as other program such as ROOT link to the incorrect place. This can be confirmed with Arch's namcap as well.

Also, the License should be LGPL3.

kaspi commented on 2016-08-15 11:24

Updated to 4.4.0.

kaspi commented on 2016-07-04 08:53

Updated to 4.3.0.