Package Details: xvst 2.5.1-1

Git Clone URL: https://aur.archlinux.org/xvst.git (read-only)
Package Base: xvst
Description: GUI tool for downloading videos from sites like YouTube, GoogleVideo etc.
Upstream URL: http://xviservicethief.sourceforge.net
Licenses: GPL3
Submitter: kamahl
Maintainer: larryhaja
Last Packager: larryhaja
Votes: 83
Popularity: 0.000167
First Submitted: 2008-02-20 10:39
Last Updated: 2015-06-11 21:39

Required by (0)

Sources (9)

  • beeg.patch
  • chilloutzone.patch
  • disable_update.patch
  • keezmovies.patch
  • myvideo.patch
  • sunporno.patch
  • wat.tv.patch
  • xvst-2.5.1.tar.gz
  • xvst.desktop

Latest Comments

alles32 commented on 2016-02-16 20:58

hi,
there is missing
#include <QDataStream>
in file src/qtsingleapplication/src/qtlocalpeer.cpp

catalin.hritcu commented on 2015-12-06 12:48

Getting an error when installing:

src/qtsingleapplication/src/qtlocalpeer.cpp: In member function ‘bool QtLocalPeer::sendMessage(const QString&, int)’:
src/qtsingleapplication/src/qtlocalpeer.cpp:159:19: error: variable ‘QDataStream ds’ has initializer but incomplete type
QDataStream ds(&socket);
^
src/qtsingleapplication/src/qtlocalpeer.cpp: In member function ‘void QtLocalPeer::receiveConnection()’:
src/qtsingleapplication/src/qtlocalpeer.cpp:179:26: error: variable ‘QDataStream ds’ has initializer but incomplete type
QDataStream ds(socket);
^
make[1]: *** [build/o/unix/qtlocalpeer.o] Error 1
make: *** [release] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Whole log here:
https://gist.github.com/catalin-hritcu/2853b7e1d7c51241e660

ValHue commented on 2014-09-17 08:10

Please upgrade to the new version 2.5.2 there since May, although not listed on their website, but here it is:

http://sourceforge.net/projects/xviservicethief/

I-sty commented on 2013-03-25 16:27

Hi,
I cant download any videos from YT.
I installed succesfully package without any problems, but I always get a error reporting dialog for any YT URLs.

http://www.youtube.com/watch?v=JjgbD0KRCAU#start=0:00;end=4:08;autoreplay=false;showoptions=false

I-sty commented on 2013-03-25 16:27

http://www.youtube.com/watch?v=JjgbD0KRCAU#start=0:00;end=4:08;autoreplay=false;showoptions=false

http://www.youtube.com/watch?v=JjgbD0KRCAU#start=0:00;end=4:08;autoreplay=false;showoptions=false

I-sty commented on 2013-03-25 16:26

Hi,
I cant download any videos from YT.
I installed succesfully package without any problems, but I always get a error reporting dialog for any YT URLs.

M4rQu1Nh0S commented on 2013-03-08 05:54

Here, the my version PKGBUILD:
http://pastebin.com/874VYxAd

here with my PKGBUILD the package has been compiled successfully!

sangyye commented on 2013-03-01 13:07

Make an update of the PKGBUILD to get xvst work against qt4

http://pastebin.com/ALr8DYMG

Kosava commented on 2013-01-10 03:03

Does someone know how to solve problem with updating plugins ?

larryhaja commented on 2012-07-02 04:53

@masser: seems newer gcc requires an additional #include in one of the *.cpp files. It is fixed now. Also, added qtwebkit and icu as dependencies.

masser commented on 2012-06-29 06:36

I try to install, but there is an error building (Archlinux i686)
===
src/qtsingleapplication/src/qtlocalpeer.cpp:103:54: ошибка: «::getuid» не был декларирован
src/qtsingleapplication/src/qtlocalpeer.cpp:103:54: замечание: suggested alternative:
In file included from src/qtsingleapplication/src/qtlockedfile_unix.cpp:49:0,
from src/qtsingleapplication/src/qtlocalpeer.cpp:67:
/usr/include/unistd.h:698:16: замечание: «QtLP_Private::getuid»
make[1]: *** [build/o/unix/qtlocalpeer.o] Ошибка 1
make[1]: Выход из каталога `/tmp/yaourt-tmp-sergey/aur-xvst/src'
make: *** [release] Ошибка 2
==> ОШИБКА: Произошел сбой в build().
Преждевременный выход...
==> ERROR: Makepkg was unable to build xvst.
==> Restart building xvst ? [y/N]
===

larryhaja commented on 2011-11-14 01:46

So, it has been over a year since there has been a new release of xvst and some of the plugins are out of date. In order to rectify this I added a svn checkout to the script that downloads the current version of all the plugins (and only the plugins/languages). This is only temporary until a new version comes out.

Anonymous comment on 2011-11-03 23:11

Still not sure about xUpdater, but took care of the broken YouTube plugin (why I was looking at xUpdater in the first place) by pulling the new one from xvst's code repository myself:
http://xviservicethief.svn.sourceforge.net/viewvc/xviservicethief/trunk/resources/services/youtube/youtube.js?revision=973&view=markup

Peeking at what Gentoo is doing and how that compares with our ebuild, when the YouTube plugin broke, they updated the ebuild, adding in a line that patches the youtube plugin from the one that comes with xvst 2.4.1 to the latest version of the plugin (what I pulled from xvst's svn). here is the patch they use, and from there you can poke around and see the ebuild and the difference between 2.4.1 ebuild and 2.4.1-r1 ebuild.
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/media-video/xvideoservicethief/files/xvideoservicethief-2.4.1-youtube-api.patch?hideattic=0&diff_format=s&revision=1.1&view=markup

I think at least we probably ought to update the package to patch in the latest YouTube plugin so that it works out-of-the-box

Anonymous comment on 2011-11-03 16:57

I had an old xUpdater in my home directory (~/.xVideoServiceThief/bin/xUpdater or something like that... not at my machine right now). Then I uninstalled the program and removed the config directory from my home directory. After reinstalling, it did put config stuff and plugins back in the config directory, but no more xUpdater in there. I assume it's probably something as simple as xUpdater being compiled but just not added to the package, but I haven't had a chance to sit down and take a peek at it yet.

grimsbain commented on 2011-11-03 14:53

This isn't really a fix but I found at least one way around the problem. I copied the up to date versions of the plugins from my windows install over to the arch install (/usr/share/xvst/plugins) since they are always the same regardless of what OS they are on.

grimsbain commented on 2011-11-03 14:32

@Bregol: I'm having the same problem as you. It installs and runs fine(well the plugins that still work) but when it go to download the new plugins it just closes and doesn't apply them since xUpdater is missing.

grimsbain commented on 2011-11-03 00:07

Not sure what would have gone wrong with your install Bregol. I just installed this today and it ran and updated just fine.

Anonymous comment on 2011-10-30 21:12

Is it missing Xupdater or did I mess up my install? I'm trying to get them plugins updated.

Anonymous comment on 2011-03-26 22:21

Thank you. Very nice application..

larryhaja commented on 2010-09-06 15:32

Updates:
* Updated to version 2.4.1
* Added flvstreamer to optdepends
* Inlcuded documentation

larryhaja commented on 2010-08-09 03:59

Took over ownership. Updated PKGBUILD

Updates:
* Use custom C(XX)FLAGS
* Install language files
* Install plugins
* Moved ffmpeg from optdepends to depends
* Removed xvst.png file and used one from downloaded source

td123 commented on 2010-04-19 01:46

added ffmpeg to optdepends

larryhaja commented on 2010-04-18 22:47

xvst needs ffmpeg for video conversion. ffmpeg should be added to depends.

tchajed commented on 2010-04-01 01:43

New version (2.3.5) PKGBUILD:
http://aur.pastebin.com/VzMUbwvr