Package Details: xylib 1.4-3

Git Clone URL: https://aur.archlinux.org/xylib.git (read-only)
Package Base: xylib
Description: Portable C++ library for reading files that contain x-y data from powder diffraction, spectroscopy or other experimental methods.
Upstream URL: http://xylib.sourceforge.net/
Licenses: GPL
Submitter: td123
Maintainer: donpicoro
Last Packager: donpicoro
Votes: 8
Popularity: 0.000039
First Submitted: 2012-02-17 02:14
Last Updated: 2015-06-14 17:41

Latest Comments

donpicoro commented on 2015-05-23 10:36

Hi @VDP76

I understand your point but unfortunately that goes against the packaging standards:
https://wiki.archlinux.org/index.php/PKGBUILD#makedepends

Cheers,

VDP76 commented on 2015-05-23 10:31

Hi, xylib is a great tool, thanks for packaging it!
I know this might sound trivial but I would suggest to add 'gcc' as a "makedepends" in the PKGBUILD file. After all it is required to compile the program and some systems might not have it installed at a give time, e.g. if you get rid of orphan packages.
Cheers

masutu commented on 2015-04-03 20:00

Hi, i'm the package maintainer of fityk. I disabled the building of xyconvert in fityk 1.2.9-2, files do not conflict anymore.

threeofsix commented on 2015-04-02 21:55

Well, I mean that fityk lists xylib as a dependency but both packages (as of xylib 1.4) want to install the file /usr/bin/xyconvert. Not that they should be listed as conflicting, sorry.

threeofsix commented on 2015-04-02 21:54

Well, I mean that fityk lists xylib as a dependency but both packages want to install the file /usr/bin/xyconvert. Not that they should be listed as conflicting, sorry.

threeofsix commented on 2015-04-01 09:38

The latest version is conflicting with fityk.

error: failed to commit transaction (conflicting files)
xylib: /usr/bin/xyconvert exists in filesystem