Package Details: yacas 1.9.1-1

Git Clone URL: https://aur.archlinux.org/yacas.git (read-only, click to copy)
Package Base: yacas
Description: Yet another computer algebra system
Upstream URL: http://www.yacas.org/
Licenses: GPL2
Groups: mathematics
Conflicts: yagy
Submitter: haawda
Maintainer: chelqo
Last Packager: chelqo
Votes: 16
Popularity: 0.000002
First Submitted: 2007-11-29 21:19
Last Updated: 2020-08-29 22:05

Latest Comments

1 2 Next › Last »

HiJack88 commented on 2021-05-26 19:32

Hello everybody and thanks for providing the package.

I keep getting an build error as given below. I'm using the latest updates on Arch Linux. Can anybody help?

Cheers.

==> Starting build()... ==> ### cmake -- The CXX compiler identification is GNU 11.1.0 -- The C compiler identification is GNU 11.1.0 -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Check for working CXX compiler: /usr/bin/c++ - skipped -- Detecting CXX compile features -- Detecting CXX compile features - done -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working C compiler: /usr/bin/cc - skipped -- Detecting C compile features -- Detecting C compile features - done -- Found Sphinx: /usr/bin/sphinx-build
-- Found UnixCommands: /usr/bin/bash
-- Configuring done -- Generating done -- Build files have been written to: /home/user/.cache/yay/yacas/src/yacas-1.9.1/build ==> ### make [ 1%] Building HTML documentation with Sphinx WARNING: html_static_path entry '_static' does not exist

Extension error: You must configure the bibtex_bibfiles setting make[2]: [docs/CMakeFiles/yacas_docs.dir/build.make:71: docs/CMakeFiles/yacas_docs] Error 2 make[1]: [CMakeFiles/Makefile2:999: docs/CMakeFiles/yacas_docs.dir/all] Eooro 2 make: *** [Makefile:146: all] Error 2 ==> ERROR: An error occurred in build(). Aborting...

chelqo commented on 2019-11-18 21:36

That is correct @bokaila, qt5-svg and other dependencies were missing in this new version of yacas, are already corrected. I delayed in correcting them because with the latest update of Sphinx* the compilations gave error, with all the updates of today I can see that the PKGBUILD works well.

bokailya commented on 2019-11-15 05:01

Get build error without qt5-svg, should be in dependencies?

SolarAquarion commented on 2019-11-04 19:40

1.8.0 is out

chelqo commented on 2019-07-17 12:32

So far I have not been able to compile the new version, there are many cmake errors that I can not solve.

chelqo commented on 2017-05-31 12:45

Appreciate the collaboration of Grzesiek, Yacas programmer, in the making of PKGBUILD

chelqo commented on 2017-04-14 22:31

You're right. Is an involuntary error.
In version 1.4.2 cmake was already in the makedepends()

Yacas currently advanced to version 1.6.1, has undergone major changes in which I continue working.

bokailya commented on 2017-04-09 12:44

I think cmake should be in make deps.

chelqo commented on 2014-12-03 17:59

Yacas is already in the version number 1.3.6
I still do not update the PKGBUILD by small bug

chelqo commented on 2012-05-07 00:59

http://dl.dropbox.com/u/1468283/yacas-1.3.2-1.src.tar.gz