Package Details: yakyak-git v1.2.0.r916.g5a3ccfe-2

Git Clone URL: https://aur.archlinux.org/yakyak-git.git (read-only)
Package Base: yakyak-git
Description: Desktop client for Google Hangouts
Upstream URL: https://github.com/yakyak/yakyak
Licenses: MIT
Conflicts: yakyak
Provides: yakyak
Submitter: mkzero
Maintainer: mpento
Last Packager: mpento
Votes: 7
Popularity: 0.309932
First Submitted: 2015-09-09 15:11
Last Updated: 2018-08-15 16:01

Latest Comments

1 2 Next › Last »

mpento commented on 2018-10-02 17:43

@RobertFischer: Looking into this now.

RobertFischer commented on 2018-10-02 14:49

@mpento -- I built just now and am getting the same issue as @artemklevtsov.

  • which coffee => /home/robert/.npm/bin/coffee
  • coffee --version => CoffeeScript version 2.3.2
  • node --version => v10.11.0
  • npm --version => 6.4.1
  • gulp --version => CLI version 3.9.1
  • node-gyp --version => v3.8.0

There's a huge number of build errors from validation.cc and its included files (including header files within V8), and then it finally ends with this message:

make: *** [validation.target.mk:103: Release/obj.target/validation/src/validation.o] Error 1
make: Leaving directory '/tmp/makepkg/yakyak-git/src/yakyak/node_modules/utf-8-validate/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/node-gyp/lib/build.js:262:23)
gyp ERR! stack     at ChildProcess.emit (events.js:182:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:240:12)
gyp ERR! System Linux 4.18.10-arch1-1-ARCH
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /tmp/makepkg/yakyak-git/src/yakyak/node_modules/utf-8-validate
gyp ERR! node -v v10.11.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok 
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 (node_modules/bufferutil):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: bufferutil@1.1.0 install: `node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: utf-8-validate@1.1.0 (node_modules/utf-8-validate):
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: utf-8-validate@1.1.0 install: `node-gyp rebuild`
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: Exit status 1

audited 3748 packages in 5.448s
found 84 vulnerabilities (16 low, 44 moderate, 23 high, 1 critical)
  run `npm audit fix` to fix them, or `npm audit` for details

> yakyak@1.5.1 gulp /tmp/makepkg/yakyak-git/src/yakyak
> gulp

[10:44:11] Failed to load external module coffeescript/register
[10:44:11] Requiring external module coffee-script/register
gulp[27875]: ../src/node_contextify.cc:628:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x55e6af39ebc1 node::Abort() [gulp]
 2: 0x55e6af39ecbb  [gulp]
 3: 0x55e6af3d4b6b node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp]
 4: 0x55e6af601def  [gulp]
 5: 0x55e6af6024df  [gulp]
 6: 0x19c48c15c01d 
/opt/aur/yakyak-git/PKGBUILD: line 44: 27864 Aborted                 (core dumped) npm run gulp

Let me know if there's anything that I can do to help debug this issue.

mpento commented on 2018-08-15 16:13

Updated to latest (r916) and bumped pkgrel

mpento commented on 2018-07-09 11:50

@artemklevtsov: I cannot reproduce this issue, but, I have seen it in the past.

What is the output of the following from inside src/yakyak:

npm ls coffeescript

You should see something like this:

~/Downloads/yakyak-git/src/yakyak -> npm ls coffeescript
yakyak@1.5.1 /home/drwho/Downloads/yakyak-git/src/yakyak
└─┬ gulp-coffee@3.0.2
  └── coffeescript@2.3.1

If not, try:

npm install coffeescript

And then run gulp again and see if it works.

artemklevtsov commented on 2018-07-07 13:22

Can't build:

> yakyak@1.5.1 gulp /tmp/trizen-unikum/yakyak-git/src/yakyak
> gulp

[20:21:21] Failed to load external module coffeescript/register
[20:21:21] Requiring external module coffee-script/register
gulp[18561]: ../src/node_contextify.cc:631:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x55c713a013e1 node::Abort() [gulp]
 2: 0x55c713a014eb  [gulp]
 3: 0x55c713a32864 node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp]
 4: 0x55c713c2f44f  [gulp]
 5: 0x55c713c2fb4f  [gulp]
 6: 0x3c20a47041bd

mpento commented on 2018-04-10 01:20

@viperpaulo: changed versioning to mirror what appears to be the proper format based on other "-git" packages here in the aur.

Please note that the new version string may cause issues with currently installed versions, I found it best to just remove my installed package and run yaourt fresh. This kept my settings just fine, and worked without problems.

Also fixed an issue with how gulp.js was being run that caused build failures.

lharding commented on 2017-04-11 21:23

I'll take up the package if noone else wants it, as I use yakyak regularly.

mkzero commented on 2017-03-09 17:44

@viperpaulo I'm not quite sure how to manage that properly, the docs for are a little unclear on what to do specifically there. I haven't been using yakyak for quite a while, so I'm not really testing it either. If you got the time and resources, I'd be happy to see you(or anyone else for that matter) to maintain this package.

viperpaulo commented on 2017-03-03 10:26

Hi!
Thanks for this package :)
Is it possible to upload a new PKGBUILD with a version given by the pkgver() function? Because the version 1-4 of the package is conflicting with AUR helpers (especially yaourt) which consider version 1-4 newer than the version given by pkgver(), v1.2.0.r657.gf2cfa6c-1 for example. And it's a bit annoying ;p

Thanks in advance!

PS: Also .SRCINFO and PKGBUILD doesn't seem to have the same value for the pkgrel...

hosfordryan commented on 2017-02-27 15:02

I'm trying to install yakyak and whenever it tries to build I get the error:

node: error while loading shared libraries: libicui18n.so.58: cannot open shared object file: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build yakyak-git.

What can I do about this? Thanks.