Package Details: yakyak 1.5.4-0

Git Clone URL: https://aur.archlinux.org/yakyak.git (read-only)
Package Base: yakyak
Description: Desktop client for Google Hangouts
Upstream URL: https://github.com/yakyak/yakyak
Licenses: MIT
Submitter: kuenx
Maintainer: mistachie777 (RobertFischer, vincedyne, snowiow)
Last Packager: mistachie777
Votes: 46
Popularity: 0.227929
First Submitted: 2015-06-23 17:25
Last Updated: 2018-12-11 01:10

Dependencies (4)

Required by (0)

Sources (3)

Pinned Comments

kuenx commented on 2016-12-02 14:03

BEFORE FLAGGING OUT-OF-DATE:
Please don't flag this package as out-of-date if the new release is a pre-release. YakYak creates pre-releases for testing with the same release version as the final release will have, which would cause problems with the package SHA sums and break the package if I published them. The pre-releases have the "pre-release" badge on GitHub. Wait for the final release before flagging.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

RobertFischer commented on 2018-10-23 14:03

Is this still being maintained, or is it an orphan? I'm happy to contribute to do some heavy lifting to get up to 1.5.1, which is the most recent version. https://github.com/yakyak/yakyak/releases/tag/v1.5.1 If someone is willing to add me as a maintainer, I'd love to move it forward.

Looks like @mistachie777 already has a working PKGBUILD file, so it shouldn't take much to get the version updated.

mistachie777 commented on 2018-08-25 20:25

Working PKGBUILD for v1.5.1:

https://pastebin.com/n9AvzGSQ

Simply updating the version number of the PKGBUILD will fail with compilation errors, and the build instructions on the YakYak GitHub page also fail to compile with Node 10. See https://github.com/gulpjs/gulp/issues/2162 for the explanation and solution.

artemklevtsov commented on 2018-07-06 10:20

@kuenx v1.5.1 is out. Do you plan update this package?

Cake commented on 2018-06-02 03:26

I think v1.5.0 is just released as it does not have a 'pre-release' tag ...

reefland commented on 2018-05-23 12:59

Stuck in connection loop (known issue) see: https://github.com/yakyak/yakyak/issues/918

reconnecting 0
resolving proxy <http://plus.google.com>
resolving proxy <https://plus.google.com>
resolved proxy DIRECT
resolved proxy DIRECT
connect_failed SyntaxError: Unexpected token <
    at Object.bind.out 
(/usr/share/yakyak/app/node_modules/hangupsjs/lib/init.js:62:23)
    at /usr/share/yakyak/app/node_modules/hangupsjs/lib/init.js:63:26
    at _fulfilled (/usr/share/yakyak/app/node_modules/q/q.js:854:54)
    at self.promiseDispatch.done
(/usr/share/yakyak/app/node_modules/q/q.js:883:30)
    at Promise.promise.promiseDispatch
(/usr/share/yakyak/app/node_modules/q/q.js:816:13)
    at /usr/share/yakyak/app/node_modules/q/q.js:877:14
    at runSingle (/usr/share/yakyak/app/node_modules/q/q.js:137:13)
    at flush (/usr/share/yakyak/app/node_modules/q/q.js:125:13)
    at _combinedTickCallback (internal/process/next_tick.js:131:7)
    at process._tickCallback (internal/process/next_tick.js:180:9)

Manually edit file: /usr/share/yakyak/app/node_modules/hangupsjs/lib/init.js

And make the one line change as documented in the URL above.

kuenx commented on 2018-03-26 14:05

PLEASE READ THE PINNED POST! DO NOT FLAG AS OUT-OF-DATE IF IT'S A PRE-RELEASE. Version 1.5 is not released yet. It's a PRE-release, even though it's already over 2 months old. The current stable version is 1.4.3. If I publish the pre-releases as regular releases the package will break because the developers re-publish the final release under the same version tag. The hashes of the files change and we have a broken package. If you want new releases sooner you should stress the developers to finalize releases faster or convince them to use different version tags for the pre-releases.

codedmart commented on 2018-03-23 13:09

Is anyone else having issue with icons on the app? I only see text so rather then the three bars for the menu I see menu in big text? Or rather then the + in the add a new conversation circle I see ad in big text? Am I missing something?

gkmcd commented on 2018-03-04 08:53

fails to build with npm errors:

==> Starting build()...
npm WARN deprecated coffee-script@1.12.7: CoffeeScript on NPM has moved to "coffeescript" (no hyphen)
npm WARN deprecated gulp-util@3.0.8: gulp-util is deprecated - replace it, following the guidelines at <https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5>
npm WARN deprecated gulp-util@2.2.20: gulp-util is deprecated - replace it, following the guidelines at <https://medium.com/gulpjs/gulp-util-ca3b1f9f9ac5>
npm WARN deprecated jade@0.26.3: Jade has been renamed to pug, please install the latest version of pug instead of jade
npm WARN deprecated to-iso-string@0.0.2: to-iso-string has been deprecated, use @segment/to-iso-string instead.
npm WARN deprecated formatio@1.1.1: This package is unmaintained. Use @sinonjs/formatio instead
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated tough-cookie@0.12.1: ReDoS vulnerability parsing Set-Cookie <https://nodesecurity.io/advisories/130>
npm WARN deprecated graceful-fs@3.0.11: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm ERR! code ERR_STREAM_WRITE_AFTER_END
npm ERR! write after end
npm ERR! code ERR_STREAM_WRITE_AFTER_END
npm ERR! write after end
npm ERR! code ERR_STREAM_WRITE_AFTER_END
npm ERR! write after end
npm ERR! A complete log of this run can be found in:
npm ERR!     /home/greg/.npm/_logs/2018-03-04T08_49_45_978Z-debug.log
==> ERROR: A failure occurred in build().
Aborting...
:: failed to build yakyak package(s)

I'm not familiar with npm and google didn't turn up much...

shen commented on 2017-02-16 21:40

1.4.2 has been released 8 days ago; please update

kuenx commented on 2017-01-02 15:10

@thenextdon13: I've updated the dependencies. Should work now, hopefully.