Package Details: yamagi-quake2 7.43-1

Git Clone URL: https://aur.archlinux.org/yamagi-quake2.git (read-only, click to copy)
Package Base: yamagi-quake2
Description: Enhanced Quake II engine optimized for modern systems
Upstream URL: http://www.yamagi.org/quake2/
Keywords: first-person-shooter FPS
Licenses: GPL2, custom: Info-ZIP
Submitter: FredBezies
Maintainer: carstene1ns
Last Packager: carstene1ns
Votes: 49
Popularity: 0.000892
First Submitted: 2009-06-27 09:00
Last Updated: 2020-07-23 16:23

Latest Comments

1 2 3 4 Next › Last »

carstene1ns commented on 2020-09-03 17:44

Sure, will add it with the next update.

dleslie commented on 2020-09-02 19:30

Seconding @Opvolger: aarch64 works great on the Pinebook Pro; please add it.

Opvolger commented on 2020-07-29 20:49

can you add aarch64?

arch=('i686' 'x86_64' 'aarch64')

yquake2 for pinebook pro :)

carstene1ns commented on 2020-07-23 16:48

mjr4077au: Upstream should maybe decide properly which method they want to support in the long term. If you look at the history of my yamagi-quake2* packages, versions before 7.XX (2017) have used the Makefile. I was told back then to migrate to CMake because they wanted to deprecate the Makefile. Now it is the other way around. Other distributions use the CMake method as well since it was added. Personally I do not care which method is used...

mjr4077au commented on 2020-06-11 06:48

Upstream recommend just using the makefile and not the CMakeLists.txt file as they don't test it or build with it themselves. The reasons being are in the link in the comment I mentioned before.

Basically, delete the Cmake lines from the build() in the PKGBUILD and replace with make WITH_SYSTEMWIDE=yes

lazycrypt commented on 2020-06-11 06:43

While waiting for the package to be updated and fixed, how should the PKGBUILD be modified for it to work?

mjr4077au commented on 2020-05-11 09:47

Hi there,

For this package and all of Yamagi's Quake II repositories, upstream has indicated that the CMakeLists.txt usage is considered unsupported. It would be recommeneded to transition your PKGBUILDs to using the makefile only.

Compiling recently broke due to changes in game that were not reflected in the CMakeLists.txt. Author's notes here also: https://github.com/yquake2/rogue/pull/72#issuecomment-626593462

Kind Regards, Mitch.

Anonymous comment on 2017-10-07 00:35

Here you can find some games you might be interested in:
http://s.go.ro/clh7ajtp

Retro_Gamer commented on 2015-11-30 00:12

quake2-5.32.tar.xz fails to extract due to corrupted input data from "/aur-yamagi-quake2/src/quake2-5.32/stuff/osx/quake2-appbundle.zip"?

That zip file is indeed corrupt and will not open. Its been corrupt last few releases actually quake2-5.30.tar.xz is the last known good non-corrupted quake2-appbundle.zip.

I was able to "fix" it by opening quake2-5.30.tar.xz and pulling the needed files:

/quake2-5.30/stuff/quake2-start.sh
/quake2-5.30/stuff/yq2.cfg
/quake2-5.30/stuff/osx/quake2-appbundle.zip

Then put them into quake2-5.32.tar.xz at the same location.

I wasn't sure if it was needed, but I built it from the terminal with,"makepkg --skipinteg" and all works fine.

carstene1ns commented on 2015-04-18 21:09

No problem, flag removed.