Package Details: yamllint 1.11.1-2

Git Clone URL: https://aur.archlinux.org/yamllint.git (read-only)
Package Base: yamllint
Description: A linter for YAML files.
Upstream URL: https://github.com/adrienverge/yamllint
Keywords: linter yaml
Licenses: GPLv3
Submitter: lilydjwg
Maintainer: lilydjwg (lilac)
Last Packager: lilac
Votes: 9
Popularity: 1.058020
First Submitted: 2016-06-24 09:33
Last Updated: 2018-08-06 19:33

Latest Comments

lilydjwg commented on 2017-08-04 01:03

psychoteadrink: it's fixed. However you'll wait python-pathspec to update if you use the AUR version.

psychoteadrink commented on 2017-08-03 11:49

Traceback (most recent call last):
File "/usr/bin/yamllint", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3038, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3022, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3051, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 657, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 971, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 857, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pathspec>=0.5.3' distribution was not found and is required by yamllint

polyzen commented on 2017-02-28 03:26

I don't recall having seen it before.

It's removed, on my side.

lilydjwg commented on 2017-02-28 03:20

polyzen: because I added it to my template. Some packages need a UTF-8 locale.
Does it cause any problem for you?

polyzen commented on 2017-02-27 20:50

Why has `export LANG=en_US.UTF-8` been added?