Package Details: yandex-browser-beta 22.5.0.1879_1-3

Git Clone URL: https://aur.archlinux.org/yandex-browser-beta.git (read-only, click to copy)
Package Base: yandex-browser-beta
Description: The web browser from Yandex. Yandex Browser is a browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier.
Upstream URL: https://browser.yandex.com
Keywords: browser chromium web yandex
Licenses: custom:yandex-browser
Conflicts: yandex-browser-beta
Provides: yandex-browser-beta
Submitter: MasterSOFT24
Maintainer: MasterSOFT24
Last Packager: MasterSOFT24
Votes: 84
Popularity: 0.29
First Submitted: 2014-10-30 12:35 (UTC)
Last Updated: 2022-08-08 15:24 (UTC)

Dependencies (14)

Sources (1)

Latest Comments

labaman commented on 2022-04-22 06:33 (UTC)

Beta version does not conflict with the stable version and can be installed at the same time. No need to add yandex-browser to conflicts.

MasterSOFT24 commented on 2022-03-24 17:12 (UTC)

url field added

programmador commented on 2022-03-23 19:46 (UTC)

Seems like it's ok to add url= ponting to browser.yandex.com while keeping source= set to repo.yandex.ru

FabioLolix commented on 2022-03-23 18:09 (UTC)

What is the problem filling the url= field?

MasterSOFT24 commented on 2022-03-21 14:43 (UTC)

provides and conflicts were added but source but source url I can't change because of the mutual restrictions of RU and UA

FabioLolix commented on 2022-03-20 17:46 (UTC)

Hello,

labaman commented on 2022-03-16 15:14 (UTC)

Обновите, новая сборка вышла yandex-browser-beta_22.1.3.907-1

trb.exe commented on 2022-02-06 07:55 (UTC)

Очень опасная штука это Яндекс браузер.

saber716rus commented on 2021-12-23 06:38 (UTC)

Тебе кодек внутри браузера ffmpeg обновить. Введи команду sudo /opt/Yandex/browser-beta/update-ffmpeg.

pkgbuild commented on 2021-12-22 21:46 (UTC)

Товарищи, по какой ещё причине не запускаются видео в браузере? Установил все возможные кодексы - без толку(

surok221 commented on 2021-12-19 12:57 (UTC)

Да, ошибся, 21.11

saber716rus commented on 2021-12-19 10:20 (UTC)

@surok221 Может это для форточки? Потому, что для линукса ещё только yandex-browser-beta-21.11.3.954-1.x86_64.rpm

surok221 commented on 2021-12-18 18:32 (UTC) (edited on 2021-12-18 18:33 (UTC) by surok221)

Браузер был обновлен до 22.1.0 на оф сайте

KnottyManatee55 commented on 2021-10-09 07:03 (UTC)

Для корректной работы скрипта установки кодеков update-ffmpeg необходим jq.

pierro78 commented on 2021-09-02 22:39 (UTC)

new .deb build released ... I had to update .deb build number and md5sum in PKGBUILD

moghaazi commented on 2021-08-03 13:45 (UTC)

@saber716rus I'm also using wayland and sway, try type this in the terminal yandex-browser-beta --disable-features=AbtFeature it will fix the problem for now, until they fix it

saber716rus commented on 2021-07-31 13:12 (UTC) (edited on 2021-07-31 13:12 (UTC) by saber716rus)

kekek пиши тындексу, может пофиксят проблему.

kekek commented on 2021-07-31 07:43 (UTC)

Никто не запускал ЯБ под wayland? Пытаюсь запустить в sway с помощью команды yandex-browser-beta --enable-features=UseOzonePlatform --ozone-platform=wayland --force-device-scale-factor=1.4 Браузер запускается, но по правой кнопке мышки не появляется меню, только экран мелькает.

MasterSOFT24 commented on 2021-07-31 06:33 (UTC)

Сорри за отсутствие - был в отпуске

moghaazi commented on 2021-07-30 09:53 (UTC)

If the browser doesn't want to launch after the last updating type this line in the terminal $ yandex-browser-beta --disable-features=AbtFeature

programmador commented on 2021-07-18 19:08 (UTC)

Smth has upgraded and now browser blaims "network service crashed" https://bbs.archlinux.org/viewtopic.php?id=267995 I couldn't find out what package causes that. Tried downrading webkit2gtk, nss, harfbuzz... No success.

moghaazi commented on 2021-07-11 14:44 (UTC) (edited on 2021-07-11 14:45 (UTC) by moghaazi)

The browser not open after the update version 21.5.3.753_1-1

saber716rus commented on 2021-06-23 23:02 (UTC)

Добавь зависимость либу jq. Тогда не нужно вручную костылить.

saber716rus commented on 2021-06-19 11:55 (UTC) (edited on 2021-06-19 11:55 (UTC) by saber716rus)

@grigruss кто хочет установить новую версию, при установке правьте pkgbuild _pkgname=browser-beta pkgname=yandex-${_pkgname} pkgver=21.5.3.753 _pkgver=21.5.3.753 pkgrel=1

epoch=1

pkgdesc="The web browser from Yandex. Yandex Browser is a browser that combines a minimal design with sophisticated technology to make the web faster, safer, and easier." arch=("x86_64") license=("custom:yandex-browser") categories=("network")

options=(!strip)

depends=("flac" "gconf" "gtk2" "harfbuzz-icu" "libxss" "nss" "opus" "snappy" "ttf-font" "xdg-utils" "libxkbfile" "jq") optdepends=( "speech-dispatcher" "ttf-liberation: fix fonts for some PDFs" "yandex-libffmpeg" )

source=("${pkgname}-${pkgver}.deb::http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/yandex-browser-beta_${_pkgver}-${_pgkrel}_amd64.deb") md5sums=("c4ffe705b66cc880f6c03de48003a4cf")

grigruss commented on 2021-06-19 11:32 (UTC)

@hohol92 пакет собирался до вчерашнего дня. На данный момент, Яндекс выпустил новую версию 21.5.3.753-1, потому и не собирается. Старые пакеты Яндекс удаляет из общего доступа.

Таблетка: Установить с моей сборки (ссылка ниже) или ждать, пока @MasterSOFT24 пересоберёт новую версию. Разницы нет, работает одинаково.

https://git.tuxnix.ru/nixscript/yandex-browser-beta

MasterSOFT24 commented on 2021-05-30 15:10 (UTC)

Я думаю, вам нужно установить пакет jq

hohol92 commented on 2021-05-30 12:20 (UTC)

Помогите ошибка (1/1) installing yandex-browser-beta [######################] 100% /opt/yandex/browser-beta/update-ffmpeg: line 39: jq: command not found FFMPEG codecs installation failed: there are no download urls for the current browser version: 89.0.4389 error: command failed to execute correctly

grigruss commented on 2021-05-17 04:59 (UTC)

New version: 21.3.3.1195-1 https://git.tuxnix.ru/nixscript/yandex-browser-beta

Miromed commented on 2021-03-12 00:23 (UTC)

Опять обновилась версия и сборка пакета не доступна yandex-browser-beta_21.2.1.94-1_amd64.deb

atxnor commented on 2021-01-26 04:22 (UTC)

/opt/yandex/browser-beta/update-ffmpeg

Пора бы уже включить это в post-install

grigruss commented on 2021-01-20 15:10 (UTC)

20.11.3.268-1 тестирую. Пока проблем не вижу.

kekek commented on 2021-01-10 09:52 (UTC)

Насчёт Twitch ничего не могу сказать. Но у меня сложилось впечатление, что между версиями Chrome 85 и 86 поменяли ABI в библиотеке libffmpeg. После того, как откатился назад на версию ЯБ 20.9.3 у меня перестали показываться ролики. Помогла установка opera-ffmpeg-codecs версии 85, с более новыми версиями отказывается работать.

AwadamaFever commented on 2021-01-10 09:39 (UTC)

А Twitch работает у кого? Я попробовал и с yandex-libffmpeg, и со встроенным скриптом - не показывает, пишет ошибку #4000.

HamsterSpb commented on 2020-12-21 14:42 (UTC)

В составе Яндекс.Браузера есть скрипт, который скачивает кодеки. Достаточно запустить после обновления /opt/yandex/browser-beta/update-ffmpeg

Идеально было бы добавить вызов скрипта в пакет.

grigruss commented on 2020-12-19 15:18 (UTC)

Яндекс зачем-то откатил версию до 20.9.3.189-1. Возможно обнаружили ошибку, но 20.11.3.188-1 у меня нормально работает...

grigruss commented on 2020-12-16 05:29 (UTC)

@kekek Отлично, сейчас попробую.

kekek commented on 2020-12-16 05:24 (UTC)

Я у себя удалил /opt/yandex/browser-beta/lib/libffmpeg.so и положил вместо него символьную ссылку на yandex-libffmpeg. Видео показывает.

grigruss commented on 2020-12-15 14:40 (UTC)

Вышла новая версия 20.11.3.188, но она с yandex-libffmpeg не работает.

grigruss commented on 2020-11-19 04:50 (UTC) (edited on 2020-11-19 04:50 (UTC) by grigruss)

yandex-libffmpeg

Видео работает отлично на всех сайтах, которые использую.

Пользуюсь пакетом уже три недели, никаких проблем не обнаружил, хотя специально пытался.

vp_arth commented on 2020-11-18 20:28 (UTC)

yandex-libffmpeg
First Submitted: 2020-10-29 18:45

Свежий пакетик. Поставил, вроде youtube завёлся. Будем надеяться, что всё остальное тоже. =)

MasterSOFT24 commented on 2020-11-18 19:56 (UTC)

Там ниже говорили, что yandex-libffmpeg вроде решает проблемы...

vp_arth commented on 2020-11-18 19:37 (UTC)

Жаль, но проблема с воспроизведением видео так и не стабилизировалась.
Пришлось «временно» перейти на vivaldi, похоже это надолго)

quolpr commented on 2020-11-18 19:34 (UTC)

А что лучше ставить - yandex-browser-ffmpeg-codecs-opera или yandex-libffmpeg? И в чём разница?

Stezko commented on 2020-11-06 05:57 (UTC)

@MasterSOFT24 yandex-browser-codecs-ffmpeg-extra-bin, yandex-browser-ffmpeg-codecs, kdebase-kdialog, первого и второго больше нет в ауре, а 3тий не работает вовсе, yandex-libffmpeg я сделал вместо yandex-browser-ffmpeg-codecs
А насчет добавление сопровождающих, просто проблема у новичков и они установить не могут)
Поэтому и прошу сделать Co-Maintainer

grigruss commented on 2020-11-06 05:54 (UTC) (edited on 2020-11-06 05:54 (UTC) by grigruss)

@MasterSOFT24 У меня yandex-libffmpeg работает без проблем.

$ sudo pacman -Q yandex-browser-codecs-ffmpeg-extra-bin yandex-browser-ffmpeg-codecs yandex-libffmpeg kdebase-kdialog

ошибка: пакет 'yandex-browser-codecs-ffmpeg-extra-bin' не найден

ошибка: пакет 'yandex-browser-ffmpeg-codecs' не найден

yandex-libffmpeg 0.47.2-2

ошибка: пакет 'kdebase-kdialog' не найден

MasterSOFT24 commented on 2020-11-06 05:47 (UTC)

@Stezko, а что не так с оперативностью? Уже были случаи, когда вслед за обновлением, через пару дней выходило исправление. Так что задержка в несколько дней, не думаю, что критична. Обыкновенно, проверяю обновления раз в неделю. Или когда выходят новые версии оперы и вивальди. И по поводу уделения из опционала, ты проверял работоспособность после уделения yandex-browser-codecs-ffmpeg-extra-bin, yandex-browser-ffmpeg-codecs, kdebase-kdialog и добавления yandex-libffmpeg?

grigruss commented on 2020-11-06 04:48 (UTC)

@Stezko У меня при включении компа идёт проверка обновлений, а комп включаю почти каждый день. Сразу собираю пакет, написал скрипт для этого, и кидаю в свой гитсервер. Ссылку постоянно здесь указываю. https://git.tuxnix.ru/nixscript/yandex-browser-beta Так что, если @MasterSOFT24 не обновляет, можно поставить с моего сервера.

Stezko commented on 2020-11-04 19:59 (UTC) (edited on 2020-11-04 19:59 (UTC) by Stezko)

@MasterSOFT24 Ответь на почту, или тут
Предлагаю добавить сопровождающих для оперативного обновления

grigruss commented on 2020-11-02 11:21 (UTC)

@atxnor, new version: https://git.tuxnix.ru/nixscript/yandex-browser-beta

atxnor commented on 2020-11-01 04:08 (UTC)

yandex-browser-beta_20.8.3.361-1_amd64.deb not found.

actual file is yandex-browser-beta_20.9.3.189-1_amd64.deb

please update pkgbuild

Stezko commented on 2020-10-29 13:00 (UTC)

Удали из опционала yandex-browser-codecs-ffmpeg-extra-bin, yandex-browser-ffmpeg-codecs, kdebase-kdialog И можешь добавить yandex-libffmpeg, сделали специально для яндекса

lesf0 commented on 2020-10-23 08:42 (UTC)

It seems like codecs from opera does not work with yandex-browser anymore. However, they've added a script /opt/yandex/browser-beta/update-ffmpeg, which seems to install correct version of codecs automatically. It may be a good idea to add this script to either PKGBUILD or post-install script.

daesher commented on 2020-10-22 12:17 (UTC) (edited on 2020-10-22 12:26 (UTC) by daesher)

Seems like the bug of page reloading due to glibc updating have returned.

UPD: bug is due to opera codec using.

cusxy commented on 2020-10-21 21:35 (UTC) (edited on 2020-10-21 21:36 (UTC) by cusxy)

Автору спасибо! Всё работает, но нужно подправить версию браузера в исходниках. Актуальную версию нашёл тут: https://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/.

MasterSOFT24 commented on 2020-08-29 18:38 (UTC)

I don't know

sparsarc commented on 2020-08-29 15:41 (UTC)

Just a query, does yandex uses the vaapi patch for chromium?

atxnor commented on 2020-06-09 13:02 (UTC)

Тоже Манжаро 20

Короче снес и поставил по новой =) все гуд.

grigruss commented on 2020-06-09 11:28 (UTC)

Подтверждаю. Всё собирается нормально. Подобные проблемы у меня возникали при плохом качестве связи. Пакеты скачивались с ошибкой.

MasterSOFT24 commented on 2020-06-09 11:25 (UTC) (edited on 2020-06-09 11:27 (UTC) by MasterSOFT24)

Еще раз перепроверил, только что - все нормально собралось. Manjaro Linux

atxnor commented on 2020-06-08 16:22 (UTC)

Подготовка...
Клонирование сборочных файлов yandex-browser-beta...
Проверка зависимостей для yandex-browser-beta...
Синхронизация баз данных пакетов...
Разрешение зависимостей...
Проверка на взаимные конфликты...

Сборка yandex-browser-beta...
==> Сборка пакета yandex-browser-beta 20.4.3.268_1-2 (Вт 09 июн 2020 00:17:24)
==> Проверка зависимостей для запуска...
==> Проверка зависимостей для сборки...
==> Получение исходных файлов...
  -> Найден yandex-browser-beta-20.4.3.268_1.deb
==> Проверка файлов source с использованием md5sums...
    yandex-browser-beta-20.4.3.268_1.deb ... СБОЙ
==> ОШИБКА: Исходные файлы не прошли проверку целостности!
Не удалось собрать yandex-browser-beta

grigruss commented on 2020-06-03 15:25 (UTC)

20.4.3.268-1 -> https://git.tuxnix.ru/nixscript/yandex-browser-beta

pierro78 commented on 2020-05-30 23:58 (UTC)

modification of PKGBUILD for 20.4.3.268-1 seems to be easy : just version and md5sum and I seem to be good now typing with 20.4.3.268-1 ;)

pierro78 commented on 2020-05-30 23:21 (UTC)

20.3.2.282_1 no longer available on http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/ : replaced by 20.4.3.268-1

grigruss commented on 2020-04-10 16:13 (UTC)

Version 20.3.2.282-1 https://git.tuxnix.ru/nixscript/yandex-browser-beta

Infinite.New1 commented on 2020-03-08 01:24 (UTC)

No bug for 2 hours now with the latest package. My most important piece of software on a daily basis is back on track!

grigruss commented on 2020-03-07 07:18 (UTC)

glibc 2.31-1 YB installed succesfull. Manjaro linux.

daesher commented on 2020-03-07 05:39 (UTC)

I can confirm this. Current AUR version doesn't conflict with the current glibc.

grigruss commented on 2020-03-06 15:37 (UTC)

Version: 20.2.3.320 Have no problem! https://git.tuxnix.ru/nixscript/yandex-browser-beta

sistematico commented on 2020-03-04 15:23 (UTC)

PKGBUILD: http://ix.io/2dns

gconf: pacman -U https://archive.archlinux.org/packages/g/gconf/gconf-3.2.6%2B11%2Bg07808097-5-x86_64.pkg.tar.xz

grigruss commented on 2020-03-04 09:09 (UTC) (edited on 2020-03-04 09:09 (UTC) by grigruss)

If cache in /var/cache/pacman/pkg is cleaned and packages not found

glibc and lib32-glibc: https://nixscript.ru/dl/glibc.tar.xz

binutils, gcc and gcc-libs: https://nixscript.ru/dl/binutils_gcc.tar.xz

daesher commented on 2020-03-04 08:41 (UTC) (edited on 2020-03-04 08:42 (UTC) by daesher)

Binutils and gcc (with gcc-libs) should also be downgraded.

grigruss commented on 2020-03-04 08:33 (UTC)

At first, You can check the /var/cache/pacman/pkg, for version 2.30-3. If have it, You must downgrade two packages: glibc and lib32-glibc If packages not found, You can download it from link https://nixscript.ru/dl/glibc.tar.xz

alexws54tk commented on 2020-03-04 08:23 (UTC)

@grigruss

How I do downgrade glibc to 2.30 from repo?

Making themself by hands from sources is unsupported.

shizeeg commented on 2020-03-04 07:52 (UTC)

PKGBUILD for Yandex 20.2.3.259

https://gist.github.com/shizeeg/f34f41ee63c23e9d9980cc54c8a91fcd

You're welcome.

grigruss commented on 2020-03-04 07:07 (UTC)

Do you read messages? :-) This version have problem with glibc 2.31.

alexws54tk commented on 2020-03-04 07:01 (UTC)

New version 20.2.3.259 available. pkgver=20.2.3.25_1 _pkgver=19.12.3.332_1 md5sums=("26a756aac92f73cd77e232a7ff34f032")

grigruss commented on 2020-03-01 21:18 (UTC)

Yes. I was downgrade glibc to 2.30 and have no problem.

Infinite.New1 commented on 2020-03-01 21:07 (UTC) (edited on 2020-03-01 23:01 (UTC) by Infinite.New1)

I'm experiencing the "This tab was reloaded due to an error on the page" message with the "OK" button next to it all the time since the Manjaro GNOME 19.0 Kyria. Must be the "glibc 2.31", will downgrade it and see.

Like daesher said, there's a new version of Yandex but since it's based on Chromium 79, it will probably be no better. Here's a link if you want to test it : http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/yandex-browser-beta_20.2.3.259-1_amd64.deb.

grigruss commented on 2020-02-29 14:04 (UTC)

Ou! Thank You! I have glibc 2.31 now. And now I know what to do...

daesher commented on 2020-02-29 13:48 (UTC) (edited on 2020-02-29 13:50 (UTC) by daesher)

Problem presents in the clean arch. Problem source is the new glibc (2.31). Result of this problem - breaking of browsers based on Cromium<80. Chromium (or chrome) of 80 version works good. Downgrading glibc and dependencies results in no problem of all version of browsers.

grigruss commented on 2020-02-29 13:34 (UTC)

May be. Yes, version 20.2 is 79.0.3945.259. And I have a problem with error on any pages, but I think it is problem from manjaro updates, becouse I was have this problem before update the Yndex browser.

daesher commented on 2020-02-29 11:24 (UTC)

20.2 - it is still based on chromium-79. I don't think that the problem would be solved by it.

grigruss commented on 2020-02-29 06:47 (UTC)

You can get new version (20.2.3.259-1) from this link: https://git.tuxnix.ru/nixscript/yandex-browser-beta

daesher commented on 2020-02-27 20:45 (UTC) (edited on 2020-02-27 20:46 (UTC) by daesher)

Looks like any chromium-based browser of chromium version <80 has this bug. Yandex for linux is still 78. Chromium from pkg doesn't have this bug.

MasterSOFT24 commented on 2020-02-23 12:29 (UTC)

Vivaldi breaks too. I'm thought this common problem for all chromium-based browsers.

daesher commented on 2020-02-23 10:51 (UTC)

Yes, downgrading glibc, binutils, gcc-libs, gcc and their lib32- analogues has solved this problem. But this way is of no good.

MasterSOFT24 commented on 2020-02-22 11:26 (UTC)

Unfortunately, it's true. Seem like a bug caused by a newer incompatible glibc version. It's the price of "bleeding edge" philosophy.

More info could be funded in google on "seccomp-bpf failure in syscall 0230" request

daesher commented on 2020-02-22 11:02 (UTC)

Very buggy on current OS. May be, something is broken in dependencies, it works stable on Ubuntu. Even old version from Ubuntu is very buggy on Arch. Bugs are: quite huge page is suddenly reloaded, it is very usual.

grigruss commented on 2020-01-09 05:47 (UTC)

You can get new version from this link: https://git.tuxnix.ru/nixscript/yandex-browser-beta

alexws54tk commented on 2020-01-09 05:42 (UTC) (edited on 2020-01-09 05:44 (UTC) by alexws54tk)

New version 19.12.3.332 available.

pkgver=19.12.3.332_1

_pkgver=19.12.3.332_1

md5sums=("f8f4be3913abaf37d2eb45530ebe177c")

grigruss commented on 2019-11-19 16:53 (UTC)

https://git.tuxnix.ru/nixscript/yandex-browser-beta

grigruss commented on 2019-10-22 12:09 (UTC) (edited on 2019-10-22 12:10 (UTC) by grigruss)

pkgver=19.9.3.358_1

_pkgver=19.9.3.358-1

md5sums=("c8c5947944d95b2f1a9a41b76236c74a")

lesf0 commented on 2019-09-13 04:55 (UTC)

Missing dependencies gtk3 and at-spi2-atk

SolarAquarion commented on 2019-07-10 01:35 (UTC)

this would be the upstream url no? https://browser.yandex.com/

alexws54tk commented on 2019-05-14 15:49 (UTC)

New version 19.4.2.698 awailable.

alexws54tk commented on 2019-03-22 14:17 (UTC)

New version 19.3.1.777 awailable.

kekek commented on 2019-01-28 16:00 (UTC)

I installed aur/opera-beta-ffmpeg-codecs and fixed simlink /opt/yandex/browser-beta/libffmpeg.so

Aleksandr commented on 2019-01-28 15:57 (UTC)

Аааааа, что сделали опять с кодеком h.264, после этого обновления он отказался работать

timrod commented on 2018-12-18 07:20 (UTC)

Each time it starts, it asks if it is the default browser, although it is already installed by the default application. Manjaro 18 KDE

spiritabsolute commented on 2018-09-29 07:54 (UTC) (edited on 2018-09-29 07:57 (UTC) by spiritabsolute)

ERROR: Failure while downloading http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/yandex-browser-beta_18.9.1.825-1_amd64.deb

You need edit pkgbuild

asm0dey commented on 2018-09-25 14:50 (UTC)

Please upgrade to 18.9.1.825

pawa.allo commented on 2018-08-17 14:50 (UTC)

https://pastebin.com/grrQdVYN New version 18.7.0.2767-1

linuxista commented on 2018-08-12 20:50 (UTC)

Seems like password manager has been really screwed up last few weeks. Won't save passwords. Forgot ones it once new. No passwords show in password window in settings. Password window in settings won't even register manually added passwords.

pawa.allo commented on 2018-07-12 15:15 (UTC)

https://pastebin.com/Yd5WcD6t new build

pawa.allo commented on 2018-06-27 11:00 (UTC)

https://pastebin.com/6GbbjRUx In this version implemented password manager

niya3 commented on 2018-06-27 06:10 (UTC)

Please update PKGBUILD using for https://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/yandex-browser-beta_18.6.0.2253-1_amd64.deb

commented on 2018-06-26 19:37 (UTC)

Hello folks! Sorry for the updating delay yandex-browser-ffmpeg-codecs package. Can anyone check it with this browser?

grigruss commented on 2018-06-15 21:37 (UTC)

https://aur.archlinux.org/packages/yandex-browser-ffmpeg-codecs-opera realy fix it

MasterSOFT24 commented on 2018-06-12 02:44 (UTC)

Updated. In the new 18.4.0.2373_1 version youtube video doesn't works again but using of yandex-browser-ffmpeg-codecs-opera fix it.

pawa.allo commented on 2018-06-07 14:13 (UTC) (edited on 2018-06-08 10:34 (UTC) by pawa.allo)

http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/yandex-browser-beta_18.4.0.2373-1_amd64.deb are released UPD: https://pastebin.com/Q9Z0e3hB

vp_arth commented on 2018-05-21 12:27 (UTC)

What about status of this?

At least we have an option to remove yandex-browser-codecs-ffmpeg-extra-bin for now.

MasterSOFT24 commented on 2018-04-21 02:36 (UTC)

Yes, maybe extra-codecs could be helpful but it doesn't build. I'm writing to maintainer about this. Wait for new version while.

linuxista commented on 2018-04-20 21:33 (UTC)

Seems like video playing is impaired again since 18.3.1.1122_1-2 update on April 20. Youtube is glitchy and Liveleak doesn't play at all.

zhangkaizhao commented on 2018-04-08 15:16 (UTC)

Hello. gtk3 is needed for current version 18.1.1.952_1:

$ yandex-browser-beta 
/usr/bin/yandex-browser-beta: error while loading shared libraries: libgtk-3.so.0: cannot open shared object file: No such file or directory

lexikon commented on 2018-03-02 21:41 (UTC)

Last release has broken video wallpaper in browser(

linuxista commented on 2018-02-26 18:59 (UTC)

Updated to yandex-browser-beta-18.1.1.952_1.deb, and removed yandex-browser-codecs-ffmpeg-extra-bin. Everything working great, including all video streaming. Thanks for all the work, MasterSoft24, et. al.

MasterSOFT24 commented on 2018-02-26 02:46 (UTC)

Ok. I'm moved a yandex-browser-codecs-ffmpeg-extra-bin to the opt depends

PocketSam commented on 2018-02-24 16:23 (UTC)

Yes, it solved the problem with browser. Now everything works fine! So here is a solution:

pacman -Rdd yandex-browser-codecs-ffmpeg-extra-bin

PocketSam commented on 2018-02-24 16:16 (UTC)

Yandex techsupport told me to remove ffmpeg package. pacman -Rdd yandex-browser-codecs-ffmpeg-extra-bin

@MasterSOFT24, can you please remove it from yandex-browser dependency? Thanks.

linuxista commented on 2018-02-23 19:31 (UTC) (edited on 2018-02-23 19:31 (UTC) by linuxista)

Thanks, PocketSam. I'll just leave everything installed for now and hope this all gets fixed next time around. Interestingly, Yandex-broswer-beta on Fedora has been stable this whole time, so it doesn't seem to be a question of upstream bugs. Not sure what's going on. Yandex-browser-beta from AUR was really solid all the way up to these last two updates.

PocketSam commented on 2018-02-23 17:04 (UTC)

@linuxista you can remove yandex-browser-codecs-ffmpeg-extra-bin with: pacman -Rc yandex-browser-codecs-ffmpeg-extra-bin

But it will remove Yandex Browser also. And you won't be able to reinstall it as yandex-browser-codecs-ffmpeg-extra-bin is a dependency for yandex-browser-beta but it's package fails to build for now.

linuxista commented on 2018-02-23 07:48 (UTC)

Also can't type in url/address bar field.

linuxista commented on 2018-02-23 07:41 (UTC)

Still won't play videos, and can't remove yandex-browser-codecs-ffmpeg-extra-bin b/c the ffmpeg-extra-bin is a dependency of itself.

error: failed to prepare transaction (could not satisfy dependencies) :: yandex-browser-beta: removing yandex-browser-codecs-ffmpeg-extra-bin breaks dependency 'yandex-browser-codecs-ffmpeg-extra-bin'

MasterSOFT24 commented on 2018-02-23 03:27 (UTC)

But error still remains

MasterSOFT24 commented on 2018-02-23 03:18 (UTC)

Well... New version was released today... Updated

PocketSam commented on 2018-02-22 15:56 (UTC)

I've received a reply from Yandex techsupport. They said there were NO GNU/Linux release for 18.1.1. And about an hour ago they sent me another letter with a link to https://browser.yandex.ru/beta . They mentioned Linux version would be ready soon. And it's finally here.

PocketSam commented on 2018-02-22 15:53 (UTC)

Doesn't this link lead to 18.1.1 version? https://browser.yandex.ru/download/?banerid=6400000000%3A5a8ee7113815900024b156bf&zih=1&beta=1&os=linux&x64=1&package=deb&full=1

MasterSOFT24 commented on 2018-02-21 10:54 (UTC)

I'm don't. I cannot get new version. possibly yandex distributes a new releases with some kind of a/b testing. I'm have no other explanation of this

vp_arth commented on 2018-02-21 10:47 (UTC) (edited on 2018-02-21 11:26 (UTC) by vp_arth)

Can anybody updgrade this package to 18.1.1?

Agafron commented on 2018-02-12 20:26 (UTC)

need remove yandex-browser-codecs-ffmpeg-extra-bin and delete from PKGBUILD depend yandex-browser-codecs-ffmpeg-extra-bin add this package in conflicts for version 17.11.1.1120

garynych commented on 2018-02-11 22:16 (UTC)

sudo rm /opt/yandex/browser-beta/libffmpeg.so

and all work

linuxista commented on 2018-02-11 07:16 (UTC) (edited on 2018-02-11 07:17 (UTC) by linuxista)

Browser working now after update of yandex-browser-codecs-ffmpeg-extra-bin 64.0.3282.140-1, but still won't play liveleak or youtube (or any video I presume). Says, "Tab reloaded because of error on page."

ArchXUser commented on 2018-02-09 13:10 (UTC) (edited on 2018-02-09 13:12 (UTC) by ArchXUser)

This is true, browser have new version with fix fall pages. But in repo is not having new version now. If download deb package with main page, we get new version.

MasterSOFT24 commented on 2018-02-09 03:30 (UTC)

to @SurPaul: Why did you flagged package as out-of-dated? New version is unavailable yet.

MasterSOFT24 commented on 2018-02-08 12:47 (UTC)

So, after full system upgrade I get errors too. For fix just remove yandex-browser-codecs-ffmpeg-extra-bin or downgrade it to previous version.

linuxista commented on 2018-02-08 06:36 (UTC)

Can confirm yandex-browser-beta-17.11.1.1120_1-1 update totally broken.

lexikon commented on 2018-02-06 07:45 (UTC)

Guys, it's fail...

lexikon commented on 2018-02-06 07:32 (UTC)

all broken...page is reloaded always in gmail and many another sites

MasterSOFT24 commented on 2018-02-06 05:51 (UTC)

Can't confirm. Youtube and mail.ru works fine.

daesher commented on 2018-02-06 05:34 (UTC)

Almost broken now - youtube and mail.ru pages are reloading because of "error", some other sites shows broken popups about subscription. Temporary solution: copy /opt/yandex from deb-based linux. 17.11.1.1120 from mint works fine.

MasterSOFT24 commented on 2018-02-05 03:18 (UTC)

Updated

viler80 commented on 2018-02-04 19:29 (UTC)

yandex-browser-beta-17.11.1.1120_1 https://pastebin.com/nN3rgU5t

linuxista commented on 2017-12-14 15:53 (UTC)

Reinstalled yandex-browser-beta, which pulled in the ffmpeg-codecs-bin as a hard dependency, which is fine. I had the non-binary yandex-ffmpegp-codecs installed originally, which might have been part of the problem. In any case, everything works. Thanks very much. Yandex-browser is my primary browser.

snqlby commented on 2017-12-14 11:04 (UTC)

@linuxista fixed

linuxista commented on 2017-12-14 09:30 (UTC) (edited on 2017-12-14 09:31 (UTC) by linuxista)

I'm getting a weird message. Uninstalled ffmpeg codecs to try to resolve it. Then uninstalled yandex-browser. Now I can't reinstall either one.

pacaur -S yandex-browser-beta yandex-browser-codecs-ffmpeg-extra-bin

:: Packages yandex-browser-beta yandex-browser-codecs-ffmpeg-extra-bin not found in repositories, trying AUR...

:: resolving dependencies...

tsort: -: input contains a loop:

tsort: yandex-browser-beta

tsort: yandex-browser-codecs-ffmpeg-extra-bin

tsort: -: input contains a loop:

tsort: yandex-browser-beta

tsort: yandex-browser-codecs-ffmpeg-extra-bin

:: dependency cycle detected

MasterSOFT24 commented on 2017-11-20 00:15 (UTC)

try follow git clone http://github.com/snqlby/yandex-browser-codecs-ffmpeg-extra-bin.git cd yandex-browser-codecs-ffmpeg-extra-bin makepkg -s makepkg -i receipe from comments of yandex-browser-ffmpeg-codecs

diamalex commented on 2017-11-19 06:46 (UTC)

do not play some videos on YouTube and other sites, for example here is a video from YouTube https://www.youtube.com/watch?v=WRVhHdmsGoE installed and enabled the latest pepper-flash 27.0.0.187-1 help please

MasterSOFT24 commented on 2017-09-01 12:44 (UTC) (edited on 2017-09-01 12:47 (UTC) by MasterSOFT24)

It seems like ffmpeg error. I've update browser right now and got a: $ yandex-browser-beta /opt/yandex/browser-beta/nacl_helper: error while loading shared libraries: libffmpeg.so: cannot open shared object file: No such file or directory [1:1:0901/193858.268974:ERROR:nacl_fork_delegate_linux.cc(316)] Bad NaCl helper startup ack (0 bytes) [18261:18261:0901/193858.865958:ERROR:clids_storage.cc(185)] Clid clid1010 not found! But browser works fine ls -al /opt/yandex/browser-beta/yandex* -rwxr-xr-x 1 root root 128117536 сен 1 19:32 /opt/yandex/browser-beta/yandex_browser lrwxrwxrwx 1 root root 44 сен 1 19:32 /opt/yandex/browser-beta/yandex-browser -> /opt/yandex/browser-beta/yandex-browser-beta -rwxr-xr-x 1 root root 2486 сен 1 19:32 /opt/yandex/browser-beta/yandex-browser-beta -rwsr-xr-x 1 root root 14672 сен 1 19:32 /opt/yandex/browser-beta/yandex_browser-sandbox

alexws54tk commented on 2017-09-01 10:15 (UTC)

This now crashed on start. % yandex-browser-beta Found ffmpeg: /opt/yandex/browser-beta/libffmpeg.so avcodec: 3756644 avformat: 3752551 avutil: 3616613 Ffmpeg version is OK! Let's use it. The setuid sandbox is not running as root. Common causes: * An unprivileged process using ptrace on it, like a debugger. * A parent process set prctl(PR_SET_NO_NEW_PRIVS, ...) Failed to move to new namespace: PID namespaces supported, Network namespace supported, but failed: errno = Operation not permitted % ls -al /opt/yandex/browser-beta/yandex* -rwxr-xr-x 1 root root 123M авг 30 21:43 /opt/yandex/browser-beta/yandex_browser lrwxrwxrwx 1 root root 44 сен 1 16:14 /opt/yandex/browser-beta/yandex-browser -> /opt/yandex/browser-beta/yandex-browser-beta -rwxr-xr-x 1 root root 2,5K авг 23 13:54 /opt/yandex/browser-beta/yandex-browser-beta -rwsr-xr-x 1 root root 15K сен 1 15:05 /opt/yandex/browser-beta/yandex_browser-sandbox

MasterSOFT24 commented on 2017-08-30 06:42 (UTC)

Updated

MaNNa commented on 2017-08-30 06:36 (UTC)

For those, like me, that want to see what it looks like: Upstream URL: https://browser.yandex.ru/desktop/main/

MasterSOFT24 commented on 2017-08-16 14:20 (UTC)

I'm thinking it's a various CDN. My CDN URl is https://cache-novosibbln04.cdn.yandex.net. I'm hope that new version will appears soon on all resources.

ArchXUser commented on 2017-08-16 14:06 (UTC)

It's strange. You need to contact Yandex support. Here is a link to the new version of the Yandex browser. https://yadi.sk/d/u7xTw3m53M4qYH

MasterSOFT24 commented on 2017-08-16 08:40 (UTC)

hmm... Version: 17.6.1.835-1

ArchXUser commented on 2017-08-16 04:08 (UTC)

https://browser.yandex.ru/download/?banerid=6400000000%3A5993bd5197015e001e31d86a&zih=1&beta=1&os=linux&x64=1&package=deb&full=1

MasterSOFT24 commented on 2017-08-15 12:53 (UTC)

I'm don't find this new version. On http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/ have old version. Please give me a link

alexws54tk commented on 2017-08-14 06:15 (UTC) (edited on 2017-08-14 06:33 (UTC) by alexws54tk)

New version available 17.7.1.716-1 10-Aug-2017 16:50 md5sums = 45b5a8106144b7b290d9c8d78d5760a0 sha256sums = f3f6f5233c16f9bf4943f7d70ef94c6a71488f028fc52aae7ffdd1f58b64fd6e

MasterSOFT24 commented on 2017-07-05 13:26 (UTC)

Updated

LinuxVieLoisir commented on 2017-07-05 13:23 (UTC)

There is a packet problem because the pkgbuild has not been updated, so I had to modify it so that it is functional on arch. Very cordially

grigruss commented on 2017-05-26 09:42 (UTC)

Вопрос безопасности. Мелочь иногда спасает, мало ли...

MasterSOFT24 commented on 2017-05-26 09:39 (UTC)

Даже не знаю... Практической пользы от него не вижу, но можно и поставить... А что скажет общественность?

K900 commented on 2017-05-25 07:51 (UTC)

Может sha256sums все-таки поставить для AUR? Это я для себя ставил SKIP, потому что знал, что гружу по проверенному каналу.

MasterSOFT24 commented on 2017-05-24 16:05 (UTC)

Обновил PKGBUILD - должна решиться проблема с CDN, ну и спасибо К900 за чистку (правда остались вопросы с зависимостями, но это решим по ходу дела)

MasterSOFT24 commented on 2017-05-24 15:31 (UTC) (edited on 2017-05-24 15:33 (UTC) by MasterSOFT24)

to @K900 - для чего нужен speech-dispatcher? Его, вроде, нет в зависимостях в оригинальном пакете... Пока уберу его из зависимостей

MasterSOFT24 commented on 2017-05-24 13:05 (UTC)

to @K900 Конечно применю )) to @tuta_nota сегодня-завтра на новом pkgbuild попробую сделать источником адрес, как говорит @zargbell

tuta_nota commented on 2017-05-24 12:57 (UTC)

Как решить проблему с CDN? Подскажите плз!!!

K900 commented on 2017-05-24 09:09 (UTC)

Немного почистил PKGBUILD: https://gist.github.com/K900/bafadf932f9123d4d1e5e19699e9dd11 Правильно ставится иконка + не нужно руками делать chmod 4755. @MasterSOFT24 примешь изменения?

xotkot commented on 2017-05-23 20:14 (UTC) (edited on 2017-05-23 20:17 (UTC) by xotkot)

Для Украины доступ к http://browser.yandex.ru/download/?beta=1&os=linux&x64=1&package=deb&full=1 заблокирован, но можно вместо него использовать другой: http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/yandex-browser-beta_17.4.1.776-1_amd64.deb откуда пока без проблем скачивается

MasterSOFT24 commented on 2017-05-23 02:07 (UTC)

Это, судя по всему, адрес московского CDN. У меня это https://cache-novosibbln02.cdn.yandex.net/download.cdn.yandex.net/browser/yandex/ru/beta/Yandex.deb?browser=MSIE/32/11.0&hash=46ede191245afb4ee79dcefaaaeff02a&download_date=1495505024&.exe и тоже работает. Так что, как я и говорил, это проблемы с CDN яндекса.

commented on 2017-05-22 23:21 (UTC)

Выловил редирект и заменил ссылку в источнике на него. Вроде работает. https://cache-mskdataline03.cdn.yandex.net/download.cdn.yandex.net/browser/yandex/ru/beta/Yandex.deb?browser=YandexBrowser/64/17.4.1.776&hash=5f9ab371adda3cb41afd3ef865757f80&download_date=1495494686&.exe

KVF commented on 2017-05-22 16:09 (UTC) (edited on 2017-05-22 16:11 (UTC) by KVF)

==> Validating source files with md5sums... yandex-browser-beta-17.4.1.776_1.deb ... FAILED ==> ERROR: One or more files did not pass the validity check! ==> ERROR: Makepkg was unable to build yandex-browser-beta. ==> Проверка файлов source с использованием md5sums... yandex-browser-beta-17.4.1.776_1.deb ... СБОЙ ==> ОШИБКА: Исходные файлы не прошли проверку целостности! ==> ОШИБКА: Makepkg не смог собрать yandex-browser-beta.

dvk commented on 2017-05-22 14:54 (UTC)

==> Validating source files with md5sums... yandex-browser-beta-17.4.1.776_1.deb ... FAILED ==> ERROR: One or more files did not pass the validity check! ==> ERROR: Makepkg was unable to build yandex-browser-beta.

MasterSOFT24 commented on 2017-05-22 03:51 (UTC) (edited on 2017-05-22 03:51 (UTC) by MasterSOFT24)

Странно. Я обновился сразу же после того как обновил pkgbuild. Все нормально обновилось. Только что перепроверил - все нормально собирается. В прошлый релиз все было аналогично. Так что проблема не в pkgbuild. Возможно косяки с CDN - они не тот файл отдают.

lexikon commented on 2017-05-21 19:01 (UTC)

Fix please aur package! .deb file is wrong and cannot check md5sum of file!!!

tuta_nota commented on 2017-05-19 19:38 (UTC)

==> Validating source files with md5sums... yandex-browser-beta-17.3.1.873_1.deb ... FAILED ==> ERROR: One or more files did not pass the validity check! :: failed to verify yandex-browser-beta integrity

dd-han commented on 2017-04-22 08:57 (UTC)

@tomvish I meet same problem. And I found that yandex server give wrong file (Windows exe) when yaourt downloading. So I install as regular until failed.Then I maunally download file by Gnome-Browser, rename to "yandex-browser-beta-17.3.1.873_1.deb" and replace file in "/tmp/yaourt-tmp-`whoami`/aur-yandex-browser-beta/src" and retry it works

tomvish commented on 2017-04-17 10:06 (UTC)

Всё работает, благодарю за отличный браузер !

tomvish commented on 2017-04-08 14:56 (UTC)

Неделю назад собирался и ставился прекрасно, сейчас что-то с суммой : ==> Retrieving sources... -> Found yandex-browser-beta-17.3.1.814_1.deb ==> Validating source files with md5sums... yandex-browser-beta-17.3.1.814_1.deb ... FAILED ==> ERROR: One or more files did not pass the validity check! :: failed to verify yandex-browser-beta integrity спасибо.

makentohin commented on 2017-03-26 14:48 (UTC)

libffmpeg.so не работает: /opt/yandex/browser-beta/nacl_helper: error while loading shared libraries: libffmpeg.so: cannot open shared object file: No such file or directory при попытке воспроизвести видео mp4: [623:623:0326/194259.066491:ERROR:render_media_log.cc(25)] MediaEvent: PIPELINE_ERROR decoder: not supported Способ https://yandex.com/support/browser-beta/troubleshooting/functional.xml не помогает, браузер отказывается запускаться с чужой библиотекой.

tehnium commented on 2017-03-17 08:49 (UTC)

"Spasiba" :) for this but md5sums need update Thanks

Sality commented on 2017-02-20 15:07 (UTC) (edited on 2017-02-20 15:08 (UTC) by Sality)

Мастер, спасибо за поддержку браузера в ауре. Приятно на него смотреть. Будет куда перейти полностью, когда мозилла вырубит старые аддоны и перейдет на WebExtensions окончательно. Морда яндекса лучшая (ИМХО) среди chromium-based браузеров. Еще очень нравиться Дзен. Полностью перешел с мозиллы пока только на андроиде. Еще раз благодарствую. Голоснул за пакет )

MasterSOFT24 commented on 2017-01-04 16:49 (UTC)

Yes it seems true. Ffmpeg package was updated 28.12.2016 and this update possibly something broke.

Ineu commented on 2017-01-04 09:44 (UTC)

libffmpeg.so seems to be broken in 17.1: /opt/yandex/browser-beta/nacl_helper: error while loading shared libraries: libffmpeg.so: cannot open shared object file: No such file or directory Related to https://yandex.com/support/browser-beta/troubleshooting/functional.xml

lexikon commented on 2016-12-26 14:57 (UTC)

Update to 17.11 https://yandex.ru/blog/yandexbrowser/novaya-beta-17-1-1

MasterSOFT24 commented on 2016-11-10 14:50 (UTC)

updated

lexikon commented on 2016-11-10 13:35 (UTC)

Обновите плиз https://yandex.ru/blog/yandexbrowser/beta-16-11

MasterSOFT24 commented on 2016-10-29 02:49 (UTC)

This build have a changes in PKGBUILD. See below

Vistaus commented on 2016-10-28 10:31 (UTC)

I see that the new beta has a new version number 16.10.1.545 vs the 16.10.0 I've installed from AUR a couple of days ago. What's new in this build? 'Cause the Yandex blog doesn't mention any new beta/build for Linux.

NWhisper commented on 2016-10-27 19:06 (UTC)

Теперь pacaur устанавливает пакет отлично =) Спасибо! Хорошего настроения и удачных сборок )))

MasterSOFT24 commented on 2016-10-27 17:35 (UTC)

to NWhisper: обновил. Спасибо за совет))

NWhisper commented on 2016-10-27 06:43 (UTC) (edited on 2016-10-27 16:31 (UTC) by NWhisper)

Сохранять файл с именем "?beta=1&os=linux&x64=1&package=deb&full=1" - плохая и потенциально ведущая к ошибкам идея. Проблема с pacaur лишнее тому подтверждение. Нужно добавить в значение параметра source в файле PKGBUILD имя для автоматического переименования сохраняемого файла. Например, так: source=("yandex-browser-beta-$pkgver.deb::http://browser.yandex.ru/download/?beta=1&os=linux&x64=1&package=deb&full=1")

MasterSOFT24 commented on 2016-10-27 06:31 (UTC)

Update with yaourt is OK. Maybe it is pacaur trait...

NWhisper commented on 2016-10-27 06:31 (UTC) (edited on 2016-10-27 06:32 (UTC) by NWhisper)

To work pacaur, change in PKGBUILD: source=("http://browser.yandex.ru/download/?beta=1&os=linux&x64=1&package=deb&full=1") to: source=("yandex-browser-beta-$pkgver.deb::http://browser.yandex.ru/download/?beta=1&os=linux&x64=1&package=deb&full=1")

NWhisper commented on 2016-10-27 06:24 (UTC) (edited on 2016-10-27 06:25 (UTC) by NWhisper)

$ pacaur -S yandex-browser-beta :: Package(s) yandex-browser-beta not found in repositories, trying AUR... :: resolving dependencies... :: looking for inter-conflicts... AUR Packages (1) yandex-browser-beta-16.10.1.545_1-2 :: Proceed with installation? [Y/n] :: Retrieving package(s)... :: yandex-browser-beta build files are up-to-date -- skipping :: Checking yandex-browser-beta integrity... ==> Making package: yandex-browser-beta 16.10.1.545_1-2 (Thu Oct 27 09:23:30 MSK 2016) ==> Retrieving sources... -> Found ?beta=1&os=linux&x64=1&package=deb&full=1 ==> Validating source files with md5sums... ?beta=1&os=linux&x64=1&package=deb&full=1 ... FAILED ==> ERROR: One or more files did not pass the validity check! :: failed to verify yandex-browser-beta integrity

MasterSOFT24 commented on 2016-10-27 05:03 (UTC)

New version released! Fixed.

archcid commented on 2016-10-27 05:01 (UTC)

Проверка файлов source с использованием md5sums... ?beta=1&os=linux&x64=1&package=deb&full=1 ... СБОЙ ==> ОШИБКА: Исходные файлы не прошли проверку целостности! ==> ОШИБКА: Makepkg не смог собрать yandex-browser-beta.

MasterSOFT24 commented on 2016-10-11 00:35 (UTC)

Отдельно разблокировать кейринг надо только если стоит автовход в сессию, емнип

grigruss commented on 2016-10-10 17:42 (UTC) (edited on 2016-10-10 18:31 (UTC) by grigruss)

Проблема с gnome-keyring. При запуске яндекс запрашивает доступ к ключам и паролям, а кейринг не пускает, запрашивает пароль. Ввожу пароль, но подхват ключей и паролей не происходит. Яндекс сохраняет информацию о сброшенных сессиях. В firefox и chromium проблем нет... непонятно... P.S.: Всё. Разобрался. Установил Seahorse, разблокировал ключи/пароли, после этого (первый раз в текущей сессии) вошёл в браузер - всё отлично. Сессии сохранены, пароли вводить не просит. Перезагрузился, кейринг не разблокировал сразу браузер запустил, вышло окно ввода пароля в кейринг, ввожу, а браузер сбросил все сессии. Короче работает только если сначала войти в кейринг, а потом входить в браузер. Написал в ТП Яндекс, жду лекарство, если оно есть...

grigruss commented on 2016-10-10 08:19 (UTC) (edited on 2016-10-10 08:22 (UTC) by grigruss)

@alexws54tk нет, не спрашивал. Я докопаюсь. Уверен, что сам смогу, главное время найти. Самому интереснее :-) За ссылку на блог спасибо!

alexws54tk commented on 2016-10-10 08:15 (UTC) (edited on 2016-10-10 08:17 (UTC) by alexws54tk)

@grigruss, такое поведение с перелогиниванием случилось как пару версий назад. Тоже бесит. Но, возможно, это так задумано. Тимура в блоге (https://yandex.ru/blog/yandexbrowser) не спрашивал на эту тему?

grigruss commented on 2016-10-10 05:38 (UTC)

Нашёл в дистрибутиве RosaLinux. ~/.config/yandex-browser-beta/Default/Cookies Благодарю за наводку! Буду копать...

MasterSOFT24 commented on 2016-10-10 03:32 (UTC)

cookie сохраняются, вроде, в ~/.config/yandex-browser-beta. Там лежат файлы sqlite и вот в них оно и должно храниться. Проблема может быть, либо в qslite либо в правах на запись

grigruss commented on 2016-10-09 16:09 (UTC) (edited on 2016-10-09 16:47 (UTC) by grigruss)

I have a problem with cookie in Gnome3. I must login to any sites after reboot. можно же по русски :-) Проблема в Гноме, запускается, работает отлично. Но только в одной сессии. После перезагрузки снова приходится входить во все сервисы и сайты. То ли не синхронизируется, то ли не сохраняет в домашнюю папку. На Archlinux два дня как пересел, возможно я где-то не то сделал.

grigruss commented on 2016-10-09 16:03 (UTC) (edited on 2016-10-09 16:08 (UTC) by grigruss)

For start yandex_browser, You must make next symlink: ln -s /opt/yandex/browser-beta/lib/libffmpeg.so /usr/lib/libffmpeg.so For add in to application menu: ln -s /opt/yandex/browser-beta/yandex_browser /usr/bin/yandex-browser and create /usr/share/applications/yandex-browser.desktop with Exec=/usr/bin/yandex-browser ================================== I have problem with saving cookies. I must relogin in any services and pages, after browser closed and computer reboot. In Gnome3

alexws54tk commented on 2016-10-06 06:31 (UTC)

@MasterSOFT24, new version 16.10.0.2260-1 released at 05-Oct-2016. Need to change md5sum!

jro commented on 2016-08-12 15:22 (UTC)

When I launch yandex-browser, cpu usage spikes, and both gnome-keyring-daemon and yandex_browser use a lot of CPU time, and the browser becomes irresponsive. I haven't seen this behaviour in earlier versions.

MasterSOFT24 commented on 2016-05-19 02:15 (UTC)

With yaourt all works ok. Maybe it is pacaur feature... Do try disable integrity check in PKGBUILD

konduryan commented on 2016-05-17 06:02 (UTC)

Doesn't work with pacaur! :: Checking yandex-browser-beta integrity... ==> Making package: yandex-browser-beta 16.6.0.6383_1-2 (Tue May 17 09:00:28 MSK 2016) ==> Retrieving sources... -> Found ?beta=1&os=linux&x64=1&package=deb&full=1 ==> Validating source files with md5sums... ?beta=1&os=linux&x64=1&package=deb&full=1 ... FAILED ==> ERROR: One or more files did not pass the validity check! :: failed to verify yandex-browser-beta integrity

GG0sha commented on 2016-03-30 22:32 (UTC)

New version 16.4.0.6115-1

pethead commented on 2016-03-05 03:05 (UTC)

yaourt every run showed ERROR file owned by 'libudev.so.0' and 'yandex-browser-beta'

toropisco commented on 2016-03-03 12:26 (UTC)

Just delete the test for libudev.so.0. First, such library has been obsolete for a couple of years --systemd-udev is libudev.so.1-- and, second, Yandex Browwer doesn't need it as it has its own static copy linked in.

pethead commented on 2016-03-03 06:02 (UTC) (edited on 2016-03-03 06:03 (UTC) by pethead)

if [ ! -a "/usr/lib/libudev.so.0" ] must be if [ ! -e "/usr/lib/libudev.so.0" ]

toropisco commented on 2016-02-23 11:37 (UTC)

Thanks!

MasterSOFT24 commented on 2016-02-21 02:32 (UTC)

Ok, i'm fix dependency list as you offer. Thanks for cooperation

toropisco commented on 2016-02-20 17:47 (UTC)

And what about running namcap yourself? You are calling a bunch of packages provided by the base group, a no-no according to https://wiki.archlinux.org/index.php/Arch_packaging_standards#Package_etiquette as well as depending on secondary dependencies that are already pulled in by others in the depends array. And you still depend on wget! Again, run namcap in the installation package created by your PKGBUILD and investigate yourself. If you have no time to clean up this package, I can give you a hand. Add me as co-maintainer. If you think you have no time to maintain it, add me as co-maintainer and then remove yourself fron the list. Cheers. vorbote

toropisco commented on 2016-02-14 13:08 (UTC)

*sigh" This link works <https://git.io/vgydJ> (gist.io seems to be broken).

toropisco commented on 2016-02-14 13:01 (UTC)

Hi, I have updated this PKGBUILD at <http://gist.io/d382992a4e857d40c2db>. I have run namcap and trimmed the dependencies already included in the base and base-devel groups that may never be mentioned in a PKGBUILD. Cheers.

toropisco commented on 2016-02-14 12:50 (UTC) (edited on 2016-02-14 13:09 (UTC) by toropisco)

Hi, I have created a cleaned up PKGBUILD to which I added the nice hack on the unmaintained yandex-brower PKGBUILD that updates $pkgver automatically. I removed dependencies such as xz because they are part of the base and/or base-devel groups, and those are never included. Others, such as wget were needed years ago, but at least since version 4 (maybe 3, if my memory goes that far) pacman and makepkg have used libcurl directly. All using namcap and the latest pyalpm. You can find the gist here: <https://git.io/vgy5Y>

alexws54tk commented on 2016-01-26 09:15 (UTC)

Автор, есть предложение сменить 'source' на: «http://repo.yandex.ru/yandex-browser/deb/pool/main/y/yandex-browser-beta/yandex-browser-beta_16.2.0.1818-1_amd64.deb», например как это сделано тут: «http://data.gpo.zugaina.org/mva/www-client/yandex-browser-beta/yandex-browser-beta-16.2.0.1818_p1.ebuild».

TRilon commented on 2016-01-10 14:31 (UTC)

Пожалуйста продолжайте поддержку и портирование браузера для нас, браузер очень удобный

lkzcover commented on 2015-10-13 18:33 (UTC)

PKGBUILD needs to be updated md5sums=('73aa6596f3def6a009e516c4ec513a07')

commented on 2015-09-19 19:05 (UTC)

seems like you can move wget into makedepends

stozi commented on 2015-07-26 20:14 (UTC)

Is it just me or from 15.7 is this stuck in the classic version, missing the option to switch to the new interface?

lkzcover commented on 2015-04-25 11:55 (UTC)

PKGBUILD needs to be updated md5sums=('c4c330be794511657d80ced62cf6e103') and, maybe because I'm not good at PKGBUILD tar --xz -xf data.tar.xz

avkonarev commented on 2015-03-26 10:26 (UTC)

error: failed to commit transaction (conflicting files) yandex-browser-beta: /usr/lib/libudev.so.0 exists in filesystem Errors occurred, no packages were upgraded.

narical commented on 2015-03-24 21:53 (UTC)

New checksum: 338fcddbe9703135dd2cbd0abae76e6b PKGBUILD needs to be updated

MasterSOFT24 commented on 2015-03-03 02:56 (UTC)

да. пока яндекс только под х64 выкладывает

pethead commented on 2015-03-02 09:39 (UTC)

А под платформу i686 похоже не соберется? На x64 все ок.

pethead commented on 2015-03-02 09:35 (UTC)

Thanks. I've already uncommented it. Strange it has been commented by default after Arch installing.

MasterSOFT24 commented on 2015-03-02 07:40 (UTC)

Try to connect multilib repo in /etc/pacman.conf

pethead commented on 2015-03-02 07:12 (UTC)

Linux evo 3.18.6-1-ARCH #1 SMP PREEMPT Sat Feb 7 08:44:05 CET 2015 x86_64 GNU/Linux error: target not found: lib32-glibc ==> ERROR: 'pacman' failed to install missing dependencies. ==> ERROR: Makepkg was unable to build ld-lsb.

MasterSOFT24 commented on 2015-01-30 11:35 (UTC)

Yes it is may be possible. Try to remove symlink to libudev.so.0 and reinstall again. Or try to use --force option for overwrite existing file.

brk0_0 commented on 2015-01-29 13:23 (UTC)

I successfully produced a package, but the installation failed: error: failed to commit transaction (conflicting files) yandex-browser-beta: /usr/lib/libudev.so.0 exists in filesystem Errors occurred, no packages were upgraded. I have popcorntime-bin installed, I believe that it's the problem.

Vistaus commented on 2014-12-24 11:04 (UTC)

@daesher: Dude, you rock! That did make it work! Can I buy you a beer or something? :D

daesher commented on 2014-12-24 04:08 (UTC)

The only way I found to take a PepperFlash is editing /opt/yandex/browser-beta/yandex-browser-beta. It is adding --ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so before "$@"in last line.

Vistaus commented on 2014-12-22 11:08 (UTC)

Oh never mind, thought I set the permissions to the SUID sandbox right but turns out I didn't. Works fine again now :) Except that Flash Player still isn't recognized by Yandex :(

Vistaus commented on 2014-12-22 11:04 (UTC)

Not such a great update :( Yandex crashes now, even after reinstalling :( vistaus@heimenssp3:~$ yandex-browser-beta [13837:13837:1222/120234:FATAL:setuid_sandbox_client.cc(283)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /opt/yandex/browser-beta/yandex_browser-sandbox is owned by root and has mode 4755. --2014-12-22 12:02:34-- http://crash-reports.browser.yandex.net/submit Resolving crash-reports.browser.yandex.net (crash-reports.browser.yandex.net)... 213.180.193.242 Connecting to crash-reports.browser.yandex.net (crash-reports.browser.yandex.net)|213.180.193.242|:80... connected. HTTP request sent, awaiting response... 200 OK Length: unspecified Saving to: ‘/dev/fd/3’ 0K Crash dump id: bp-fb060b91-2e41-4d60-b977-85f112141222 3.22M=0s Aborted (core dumped) vistaus@heimenssp3:~$

MasterSOFT24 commented on 2014-12-22 05:58 (UTC)

updated

GG0sha commented on 2014-12-22 05:38 (UTC)

Current version source 14.12.2125.9146 beta

Vistaus commented on 2014-12-16 16:51 (UTC)

Tried that but it still didn't pick it up :( Thanks for looking into it, hopefully you can get this solved :)

MasterSOFT24 commented on 2014-12-16 15:00 (UTC)

i think you need make symlink libflashplayer.so to /opt/yandex/browser-beta. at the weekend i'll try solve this

Vistaus commented on 2014-12-16 14:12 (UTC)

browser://flash also says "Flash plugin not installed".

Vistaus commented on 2014-12-16 11:26 (UTC)

I have chromium-pepper-flash installed but Yandex doesn't pick it up :(

MasterSOFT24 commented on 2014-12-16 08:00 (UTC)

chromium-pepper-flash.

Vistaus commented on 2014-12-03 20:21 (UTC)

Is there a reason why Flash Player doesn't work? Softpedia says that Yandex Browser for Linux supports Pepper Flash Player but Yandex doesn't pick it up after installing this PKGBUILD.

MasterSOFT24 commented on 2014-11-19 09:36 (UTC)

updated

von commented on 2014-11-19 08:23 (UTC)

> The latest package is uninstallable due to a md5 mismatch, please fix this. Because latest version is 14.12.2125.8016-1. Flagged out of date.

hardyh commented on 2014-11-18 12:20 (UTC)

The latest package is uninstallable due to a md5 mismatch, please fix this.

leoneii commented on 2014-11-03 18:55 (UTC)

Спасибо, люди добрые, оперативно .билд состряпали))

MasterSOFT24 commented on 2014-11-02 06:59 (UTC)

14.10.2062.11851_1 this is version from control file from deb package

von commented on 2014-11-02 03:00 (UTC)

Yandex: 37.0.2062.11851 (5fda963) beta Package Details: yandex-browser-beta 14.10.2062.11851_1-3 also what's up with the version? O_o

MasterSOFT24 commented on 2014-10-31 08:39 (UTC)

All issues desribed below are fixed

von commented on 2014-10-31 07:08 (UTC)

optional dependency in deps is bad You can do without separate mvs/cps on every line and you don't have to move everything to data directory (mkdir data, move everything to data): cp -r opt usr "$pkgdir" tar xf can handle the extraction too, you don't even have to specify which archive format you are using: tar -xf data.tar.lzma installing etc contents is not needed since it's not ubuntu / debian, we don't even have apt. The only thing that cron script seems to do is update the repository.

alarm commented on 2014-10-30 19:33 (UTC)

alfill@ yep, I use KDE. So, I think that maintainer can remove this package from dependencies.

alfill commented on 2014-10-30 18:19 (UTC)

> libappindicator - library to allow applications to export a menu into the Unity Menu bar, a dependency of unity - not needed if your DE is different

alarm commented on 2014-10-30 15:35 (UTC)

==> Install or build missing dependencies for yandex-browser-beta: error: target not found: libappindicator

MasterSOFT24 commented on 2014-10-30 14:42 (UTC)

fixed

brix commented on 2014-10-30 14:16 (UTC)

The "Upstream URL" entry has an extra "http://" prepended.