Package Details: yarn 0.21.3-1

Git Clone URL: https://aur.archlinux.org/yarn.git (read-only)
Package Base: yarn
Description: Fast, reliable, and secure dependency management.
Upstream URL: http://yarnpkg.com
Licenses: BSD
Submitter: jankoppe
Maintainer: jankoppe
Last Packager: jankoppe
Votes: 89
Popularity: 22.045055
First Submitted: 2016-10-11 17:58
Last Updated: 2017-02-28 10:44

Latest Comments

12eason commented on 2017-03-17 20:16

@iRet I suspect the reason for that is that this yarn is in direct conflict with apache hadoop's yarn.

iRet commented on 2017-02-28 18:46

@jankoppe thank you!

jankoppe commented on 2017-02-28 10:45

@iRet Oh, I did not see that. I've added this, so it should work now, thank you!

iRet commented on 2017-02-28 10:26

I was wondering whether you can create both yarn and yarnpkg symlinks please.
Some software new Rails release in particular uses yarnpkg instead of yarn.
And it seems like official deb packages creates both symlinks as well.

jankoppe commented on 2016-12-08 19:07

@noderat Oh, seems that you're right. By the time I packaged 0.18.0 it was only flagged as latest release. I'm sorry.

Given the frequency of yarn releases, I will probably let this one be as it is and watch out for this in future releases. I am already thinking about creating a yarn-git package which will build the latest development version from scratch, but not sure when I will find time to do this.

noderat commented on 2016-12-08 19:03

It looks like 0.18 is actually a pre-release version. Can we either keep this to full releases and/or split into two PKGBUILDs with one for stable and another for pre-release builds?

jankoppe commented on 2016-11-07 05:11

@tfl5034

This is/was a known upstream bug, see issue:
https://github.com/yarnpkg/yarn/issues/630

A fix has already been supplied here:
https://github.com/yarnpkg/yarn/pull/1654

There has been no new release yet which contains this fix, so sadly you will either have to a) wait for a new relase and in the meantime use npm to install packages globally, or b) install yarn from the latest development branch in git and take your chances with bugs.

tfl5034 commented on 2016-11-07 04:42

I can't globally install packages with yarn.

Either I precede the command with 'sudo' in which the package is installed in the /root directory and then symlinked to /usr/bin which means that I can't execute it without preceding the command with 'sudo'.

Or if I try installing globally without sudo, it won't be able to successfully symlink the package to the /usr/bin directory due to permissions.

jankoppe commented on 2016-10-15 07:20

Please do not flag for 0.15.1. This was a stub release, only intended to bump the npm version. It did not change anything for the code, thereforce 0.15.0 is essentially equal to 0.15.1. However, upstream did not release a dist version for 0.15.1, which does make sense. As I'm using the dist version in this PKGBUILD, i cannot just "upgrade" to 0.15.1.

jankoppe commented on 2016-10-13 07:04

@Xaviju

This must have been a temporary error on GitHubs side, or problems with your internet connection. The download works just fine here.

All comments