Package Details: yed 3.15.0.2-1

Git Clone URL: https://aur.archlinux.org/yed.git (read-only)
Package Base: yed
Description: Very powerful graph editor written in java
Upstream URL: http://www.yworks.com/en/products_yed_about.html
Licenses: custom
Submitter: fatmike
Maintainer: Bevan
Last Packager: Bevan
Votes: 196
Popularity: 2.528908
First Submitted: 2009-03-08 11:56
Last Updated: 2016-03-28 19:30

Latest Comments

justin8 commented on 2016-03-29 10:57

No, but it gets tiring getting notifications for people posting things about a version bump when there is a button for that to notify the packager and not everyone who wants updates about a package. Pretty sure if we removed the comments about the package being updated and the comments about the comments there would be nothing on this page.

amar commented on 2016-03-29 10:43

They might not know that; I certainly didn't! I think you're making a bigger deal out of this than it is. It's not like this package is super popular and has one comment per page. And those that are, are maintained more actively so comments like that aren't made to begin with. I see your point but don't really agree. To me this counts as an issue + solution. Even our little discussion has some value imo.

justin8 commented on 2016-03-29 00:05

They can also bump the version and run updpkgsums to do it automatically. It just makes it harder for people to see relevant issues and solutions in AUR packages when people post comments like that

amar commented on 2016-03-28 21:52

That comment wasn't to pester for updates, but to save others the hassle of getting the checksum since they could just copy and paste it into PKGBUILD from here.

justin8 commented on 2016-03-27 12:38

Click flag out of date. Don't spam AUR comments for that.

amar commented on 2016-03-27 12:37

3.15.0.2 is c60e4868f267303ee8b6fc2587beb4cc846f32bd8a6a557b77e01f0d8039aa4d

Bevan commented on 2016-03-15 19:52

Sorry, will update this as soon as possible (which unfortunately is not right now).

kralyk commented on 2016-03-15 15:08

New pkgver is 3.15.0.1
and the sha256sum is 8adf89b61acbc3447e81e2d9f281928594b837a5d1ac34563ee22298fdfe0228

Lindenk commented on 2015-08-12 19:26

The checksum no longer passes.

swamptech commented on 2015-05-08 22:12

New version: 3.14.2
https://www.yworks.com/products/yed/demo/yEd-3.14.2.zip

sha256sum: d08e43a17dd078fda66419715fc45d7fe62fd361bf14a705b1b1037c2eb34ec4

wiegraffolles commented on 2015-03-27 08:45

3.14.1 is out. http://www.yworks.com/en/downloads.html#yEd

Bevan commented on 2015-01-06 16:43

Thanks, I changed the URL. I did not raise pkrel though because the resulting package is exactly the same.

pizzapill commented on 2015-01-06 08:59

New URL is: http://live.yworks.com/yed-downloads/yEd-3.14.zip

alexpe87 commented on 2014-12-27 14:24

3.14 is out! ;-)

https://www.yworks.com/products/yed/demo/yEd-3.14.zip
md5sum: 5bc26280632eac3929907b5cf6853919

alexpe87 commented on 2014-12-27 14:23

3.14 is out! ;-)

https://www.yworks.com/products/yed/demo/yEd-3.14.zip

orschiro commented on 2014-11-22 17:24

@Bevan

Welcome. I was annoyed by that bug as well.

Thanks for quickly updating the package!

Robert

Bevan commented on 2014-11-22 17:11

Good catch, orschiro. Seems like quite a bit of research was needed to find out what caused the problem. It also solves the behaviour in gnome that the icon is shown twice in the dock if the application is set as a favorite. Thanks for the fix! :)

orschiro commented on 2014-11-22 15:45

@Bevan

Could you please add the following line to yed.desktop?

+ StartupWMClass=B-A-A-B

This will fix an issue with multiple icons displayed in plank dock bar.

More information:

http://kb.openstudioproject.com/content/fix-double-google-chrome-icon-docky-and-plank

https://github.com/numixproject/numix-icon-theme-circle/issues/865

Thank you for your maintenance!

Robert

orschiro commented on 2014-10-08 06:38

Is someone using a custom icon theme and can confirm that the custom icon is displayed for all apps except for yed?

My issue is related to using Numix Icon theme and described here.

https://github.com/numixproject/numix-icon-theme-circle/issues/865#issuecomment-58161636

I would appreciate any hints!

i18nde commented on 2014-09-25 07:29

Yes, that it is. Thanks a lot. ;)

Bevan commented on 2014-09-24 16:46

Do you use the archlinux-fr repository? They have a prebuilt yed package in there but still in version 3.12.2. Here yaourt complains about this on every update, so this may be a reason.

orschiro commented on 2014-09-24 15:59

@i18nde

Does the same happen if you build it manually?

i18nde commented on 2014-09-24 13:15

It will not update via yaourt to yEd-3.13, although it it written here, still remains at version 3.12.2. Any ideas?
Thanks.

denis_g commented on 2014-08-25 08:08

PKGBUILD for yEd 3.13: https://gist.github.com/anonymous/0be82b67f2a23186028b

Karadoc commented on 2014-06-02 09:28

Seems package has been upgraded but PGP signature is invalid.

Bevan commented on 2012-11-07 20:22

@ystein: It seems like they have split up their software into two jar files without increasing their version number. I've just corrected the PKGBUILD.
Thank you for reporting.

Anonymous comment on 2012-11-07 20:21

I've found two bugs in the PKGBUILD
1) The checksum for yEd-3.9.2.zip is incorrect, it should be ed4a1328b73d643a1a9f805c9e789793.
2) There are two jars within the archive yEd-3.9.2.zip: yed.jar and vectorgraphics.jar. Both have to be copied to /usr/share/yed (currently, only yed.jar is copied to that location)

Anonymous comment on 2012-11-07 19:41

The checksum for yEd-3.9.2.zip is incorrect, it should be ed4a1328b73d643a1a9f805c9e789793.

Bevan commented on 2012-09-24 09:35

@laser_b: Thanks for your comment. I will test if it works for me (because jotomo stated differently in June) and if it does I'll change it here.

laser_b commented on 2012-09-24 09:23

I think the Exec command in the desktop file should be modified. Currently it is not possible to doubleclick on a graphml file to open it with yed (at least not in nautilus). But current version of yed seems to support opening more than one file via argument.
Therefore it should read "Exec=yed %f" instead of just "Exec=yed".

Fallback commented on 2012-07-18 16:59

@Bevan that was the problem thank you anyways :)

yed is working

Bevan commented on 2012-07-17 19:44

@Fallback: This seems to be a local problem. Error 23 means "Write error. Curl couldn't write data to a local filesystem or similar." Maybe your /tmp directory is on a full partition?

Fallback commented on 2012-07-17 19:23

Have a problem downloading yed

curl: (23) Failed writing body (785 != 1420)

Bevan commented on 2012-06-16 12:23

@jotomo: Thank you very much for that. I applied your changes to the package.

jotomo commented on 2012-06-16 12:15

I've put a diff here http://pastebin.com/r2sHSHqZ

jotomo commented on 2012-06-16 11:36

I ran into some trouble configuring Eclipse to open files with yed, so here's what I did to make it work.
1) The desktop file has the content of the yed script duplicated. Generally, the Exec=... portion of the desktop file calls/delegates to a script/binary under /usr/bin. I'd suggest apapting this pattern as this removes the duplication.
2) In the yed script: the @* part is only partially right, it should read "$@" (including the double quotes, see the bash manpage section PARAMETERS->Special Parameters on * and @).
Note that yed does not support opening more than one file via argument.

exterm commented on 2012-05-30 17:03

thanks for updating bevan.

If you need help or run out of free time I would also be interested to maintain this package.

exterm commented on 2012-05-30 17:03

thanks for updating bevar.

If you need help or run out of free time I would also be interested to maintain this package.

aliasbody commented on 2012-05-08 13:07

PKGBUILD for 3.9.2 version --> http://pastebin.com/ZtadRLgB

PLum commented on 2012-03-28 06:44

new version update - please
6e1ff77ee783c33eaaad80f3ca75af51 yEd-3.9.1.zip

hcjl commented on 2012-02-10 13:57

New version does not work for me. I have jre7-openjdk-headless installed, but I tried it with openjdk6, too . I do not receive any output message, when I start yed it in a terminal. Do you have any ideas how to solve this issue?
Thx & Rgds
hcjl

hcjl commented on 2012-02-10 13:53

New version does not work for me. I have jre7-openjdk-headless installed. I do not receive any output message, when I start yed it in a terminal. Do you have any ideas how to solve this issue?

maxdevaine commented on 2012-02-03 08:22

3.9 is out, please update.
Thanks

dax commented on 2011-10-13 13:32

3.8 is out, update

deluminathor commented on 2011-06-30 08:28

Updated, thanks. Next time you can just flag the package as out-of-date and I will update PKGBUILD :)

Anonymous comment on 2011-06-30 08:08

updated PKGBUILD for version 3.7.0.1: http://pastebin.com/VSPi7nwC
3.7 is not available

Gordin commented on 2011-04-19 18:09

updated PKGBUILD for version 3.7: http://pastebin.com/pvBGPsuC

deluminathor commented on 2011-01-10 14:49

Done.

Anonymous comment on 2011-01-10 14:35

pleas modify yed file to
java -jar /usr/share/yed/yed.jar $*
to use parameters from command line

Ice_Phoenix commented on 2010-12-01 10:52

And another update for 3.6.1.1 is needed, mate =)

semi commented on 2010-11-27 10:49

Here's an updated PKGBUILD for yEd version 3.6.1

http://aur.pastebin.com/EC6SZ6ZF

deluminathor commented on 2010-09-18 10:28

Updated :)

Ice_Phoenix commented on 2010-09-18 09:33

yWorks released yet another version (3.6) and deleted 3.5.0.2 from their servers. Needs fixing=)

deluminathor commented on 2010-05-07 18:43

It was because yWorks released newer version but removed the old file what was referenced by the PKGBUILD. I've updated it so it should work now.

kfrance commented on 2010-05-07 15:28

the md5sum for the yEd-3.5.zip is wrong.

deluminathor commented on 2010-04-15 17:41

Fixed those two enhancements and corrected Exec entry in yed.desktop file.

xduugu commented on 2010-04-15 09:00

Could you fix the following error/warning? Thanks.

Desktop file '/usr/share/applications/yed.desktop' should not include extension in Icon key: 'yed.png'

And maybe move the license file to /usr/share/licenses/yed/.

xduugu commented on 2010-04-15 08:58

Could you fix the following error/warning? Thanks.

Desktop file '/usr/share/applications/yed.desktop' should not include extension in Icon key: 'yed.png'