Package Details: yii 1.1.16-1

Git Clone URL: https://aur.archlinux.org/yii.git (read-only)
Package Base: yii
Description: A high-performance component-based PHP framework best for Web 2.0 development.
Upstream URL: http://www.yiiframework.com/
Licenses: BSD
Submitter: pshevtsov
Maintainer: acerix
Last Packager: acerix
Votes: 15
Popularity: 0.000089
First Submitted: 2011-10-01 00:58
Last Updated: 2015-06-29 12:47

Dependencies (8)

Required by (0)

Sources (1)

Latest Comments

acerix commented on 2015-09-14 18:07

Now that Yii 2 is stable, that should be used for any new projects. This package is the latest version of Yii 1. I didn't upgrade to version 2 because it's not backwards compatible and it's recommended to use Composer to install/update Yii 2 so there's no reason for an AUR package.

subdee commented on 2015-01-29 08:57

Yii 1.1.16 is out http://www.yiiframework.com/news/83/yii-1-1-16-is-released/

Sacro commented on 2012-08-09 13:20

Yii should probably be placed under /usr/share/webapps alongside other PHP frameworks.

rzelnik commented on 2012-07-03 06:11

Thanks Peter. I tried to reinstall the package, but it didn't show me any message. I think the warning message should be not only in post_upgrade(), but also in post_install(). Am I right?

pshevtsov commented on 2012-07-02 06:13

Thanks rzelnik! I've updated .install file with the appropriate information.

rzelnik commented on 2012-07-01 20:54

When I tried to run yiic, it showed me this error:

PHP Warning: require_once(): open_basedir restriction in effect. File(/usr/share/yii/framework/yiic.php) is not within the allowed path(s): (/srv/http/:/home/:/tmp/:/usr/share/pear/) in /usr/share/yii/framework/yiic on line 15

... following several similar errors.

Solution: edit /etc/php/php.ini, find open_basedir, add :/usr/share/yii/framework at the end of the line.