Package Details: yodl 4.02.00-1

Git Clone URL: https://aur.archlinux.org/yodl.git (read-only)
Package Base: yodl
Description: Implements a pre-document language and tools to process it.
Upstream URL: https://fbb-git.github.io/yodl/
Licenses: GPL3
Submitter: ilpianista
Maintainer: nl6720
Last Packager: nl6720
Votes: 32
Popularity: 0.058943
First Submitted: 2010-11-13 15:37
Last Updated: 2018-01-24 11:20

Dependencies (2)

Required by (7)

Sources (1)

Latest Comments

nl6720 commented on 2018-01-09 11:01

"Arch Linux ARM" and "archlinux32" are not versions of Arch Linux, they are entirely different distributions. I will not add unsupported architectures to this or any other package.

rtfm3514 commented on 2018-01-08 23:04

Eh, what do you mean "unsupported"? The whole of Arch User Repository is officially "unsupported", you only listing x86_64, doesn't make this package any more of a supported package.

Think about it, we are building from SOURCE, effectively supported architectures are what builds fine and is useful to someone.

Please remember, the Arch User Repository is shared among all versions of Arch Linux, so in particular including Arch Linux ARM (hence my request) and Archlinux32 (new community version for i686), in my opinion both those arch should be listed if they work fine. Requiring --ignorearch is an unnecessary hassle and might have problematic side effects if not carefully applied ONLY to this package.

Regards, rtfm3514

nl6720 commented on 2017-12-11 16:55

Sorry, but that's an unsupported architecture. Use the --ignorearch option of makepkg.

rtfm3514 commented on 2017-12-10 16:58

Hi,

thanks for maintaining this package.

Could you add "armv7h" to the supported architectures, please? The package builds and works fine on my Raspberry Pi 2/3.

Thanks a lot, rtfm3514

yusefmhg commented on 2016-05-24 16:23

Out-of-date
to update, follows the PKGBUILD:

#------------
pkgname=yodl
pkgver=3.08.01
pkgrel=1
pkgdesc="Implements a pre-document language and tools to process it."
arch=('i686' 'x86_64')
url="https://github.com/fbb-git/yodl/"
license=('GPL3')
depends=('bash')
makedepends=('icmake>=8.00.00')
source=("${pkgname}.tar.gz::http://github.com/fbb-git/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=('958497939d9f3d1c6d0e2e74f7592d5a98f9ddb6f95c50c1247e41600d2765b7')

build() {
cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
./build programs
./build macros
./build man
./build manual
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
./build install programs "${pkgdir}"
./build install macros "${pkgdir}"
./build install man "${pkgdir}"
./build install manual "${pkgdir}"
./build install docs "${pkgdir}"
}

yan12125 commented on 2015-08-19 06:07

3.05.01 is release at 2015-05-19. [1]

[1] http://sourceforge.net/p/yodl/code/ci/3.05.01/

yan12125 commented on 2015-03-09 08:22

3.05 is released on 2015/01/04

lowfatcomputing commented on 2013-10-27 17:06

Thanks KaiSforza, package updated.

KaiSforza commented on 2013-10-27 16:24

3.03 is out now.

Remove the '0' from the source=() array and it will work flawlessly.

lowfatcomputing commented on 2013-04-06 22:35

Thanks KaiSforza, package updated.

All comments