Package Details: youtube-dl-gui-git 1.8.4.r22.g23ccbc4-1

Git Clone URL: (read-only, click to copy)
Package Base: youtube-dl-gui-git
Description: Cross platform front-end GUI of the popular youtube-dl written in wxPython
Upstream URL:
Keywords: youtube-dl yt-dlp
Licenses: custom:UNLICENSE
Conflicts: youtube-dl-gui
Provides: youtube-dl-gui
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 93
Popularity: 0.121308
First Submitted: 2014-03-25 10:50 (UTC)
Last Updated: 2023-01-17 15:51 (UTC)

Pinned Comments

willemw commented on 2021-07-03 09:24 (UTC)

Switched to oleksis' fork (Python 3).

@Gr3q: Thanks. The app seems to work fine now.

The app is now called yt-dlg. (Could change that back to the old name youtube-dl-gui). Updated the .desktop file to run yt-dlg.

The app also now includes translations (thanks for @jose1711 for pointed that out in his PKGBUILD file).

(In the PKGBUILD file there is second version of the PKGBUILD in comments. That version follows the upstream build and run steps (pip install).)

Latest Comments

1 2 3 4 5 6 .. 8 Next › Last »

willemw commented on 2023-01-26 10:09 (UTC) (edited on 2023-01-26 10:14 (UTC) by willemw)

@jester: Python 3.10 started in Arch on '26 Nov 2021'. Your python-polib package is older than that (2 Jul 2021). I think you need to rebuild all your Python packages that are still in /usr/lib/python3.9. To find outdated Python packages, run pacman -Qo /usr/lib/python3.9

jester commented on 2023-01-26 09:11 (UTC) (edited on 2023-02-01 13:32 (UTC) by jester)

The update fails to me.

==> Iniciando package()... running build_trans Traceback (most recent call last): File "/tmp/trizen-menta/youtube-dl-gui-git/src/youtube-dl-gui-git/", line 323, in <module> setup( File "/usr/lib/python3.10/site-packages/setuptools/", line 87, in setup return distutils.core.setup(**attrs) File "/usr/lib/python3.10/site-packages/setuptools/_distutils/", line 185, in setup return run_commands(dist) File "/usr/lib/python3.10/site-packages/setuptools/_distutils/", line 201, in run_commands dist.run_commands() File "/usr/lib/python3.10/site-packages/setuptools/_distutils/", line 969, in run_commands self.run_command(cmd) File "/usr/lib/python3.10/site-packages/setuptools/", line 1208, in run_command super().run_command(command) File "/usr/lib/python3.10/site-packages/setuptools/_distutils/", line 988, in run_command File "/tmp/trizen-menta/youtube-dl-gui-git/src/youtube-dl-gui-git/", line 138, in run import polib ModuleNotFoundError: No module named 'polib'

It seems that found the module polib, but if I search polib seems that version of python3 is installed.

aur/python-polib 1.1.1-1 [installed] [23+] [1.14%] [2 Jul 2021] A library to manipulate gettext files

aur/python2-polib 1.1.1-1 [1+] [0.00%] [2 Jul 2021] A library to manipulate gettext files

Armag67 commented on 2023-01-17 12:36 (UTC) (edited on 2023-01-19 18:22 (UTC) by Armag67)


youtube-dl-gui-git 1.8.4.r22.g23ccbc4 installation needs Python packaging < 23.0. I have packaging 23.0 in user mode and 21.3 in system-wide. I had to temporarily disable my user version of packaging for upgrading to this version of youtube-dl-gui-git

Edit: even with packaging = 22.0, traceback:

Traceback (most recent call last):
  File "/var/tmp/pamac-build-h2/youtube-dl-gui-git/src/youtube-dl-gui-git/", line 49, in <module>
    from setuptools import Command, setup
  File "/usr/lib/python3.10/site-packages/setuptools/", line 247, in <module>
  File "/usr/lib/python3.10/site-packages/setuptools/", line 97, in patch_all
  File "/usr/lib/python3.10/site-packages/setuptools/", line 134, in patch_for_msvc_specialized_compiler
    msvc = import_module('setuptools.msvc')
  File "/usr/lib/python3.10/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/usr/lib/python3.10/site-packages/setuptools/", line 24, in <module>
    from packaging.version import LegacyVersion
ImportError: cannot import name 'LegacyVersion' from 'packaging.version' (/home/h2/.local/lib/python3.10/site-packages/packaging/

mjsba63 commented on 2022-12-04 21:56 (UTC)

This is a great package. I am grateful for the continuation of youtube-dl-gui-git in the Manjaro Linux operating system. It works great.

bkb commented on 2022-07-17 11:20 (UTC)

All these wx things are basically broken. Some needs a newer version, some needs the old one. A long chain of dependency made it impossible to even switch from old to new or new to old, without uninstalling nearly the OS

willemw commented on 2021-12-13 17:35 (UTC)

Python upgraded from 3.9 to 3.10. Run pacman -Qo /usr/lib/python3.9 to see which packages are out-of-date.

jose1711 commented on 2021-12-13 17:29 (UTC)

@Locutus64 reinstall python-polib cleanly and it'll work