Package Details: yt-dlg-git 1.2.0.r242.g3ec93dc-1

Git Clone URL: https://aur.archlinux.org/yt-dlg-git.git (read-only, click to copy)
Package Base: yt-dlg-git
Description: A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)
Upstream URL: https://github.com/oleksis/youtube-dl-gui
Licenses: custom:UNLICENSE
Conflicts: youtube-dl-gui, yt-dlg
Provides: yt-dlg
Submitter: Gr3q
Maintainer: Gr3q
Last Packager: Gr3q
Votes: 95
Popularity: 0.74
First Submitted: 2021-07-02 20:12 (UTC)
Last Updated: 2022-03-06 18:27 (UTC)

Required by (0)

Sources (1)

Pinned Comments

willemw commented on 2021-07-03 09:24 (UTC)

Switched to oleksis' fork (Python 3).

@Gr3q: Thanks. The app seems to work fine now.

The app is now called yt-dlg. (Could change that back to the old name youtube-dl-gui). Updated the .desktop file to run yt-dlg.

The app also now includes translations (thanks for @jose1711 for pointed that out in his PKGBUILD file).

(In the PKGBUILD file there is second version of the PKGBUILD in comments. That version follows the upstream build and run steps (pip install).)

Latest Comments

1 2 3 4 5 6 .. 10 Next › Last »

Gr3q commented on 2023-11-12 15:48 (UTC)

@xiota I'll update it once I either my patch get merged in so it can be built properly again or I get tired of waiting and include a patch.

xiota commented on 2023-10-29 22:01 (UTC) (edited on 2023-10-29 22:09 (UTC) by xiota)

License string should be changed to Unlicense to match /usr/share/licenses/common.

The git repository that's cloned (last update Aug 2023) does not match the url (last update Oct 2023).

DeNatural commented on 2023-07-25 18:06 (UTC)

line 138, in run import polib ModuleNotFoundError: No module named 'polib'

solution: yay -S python-polib

begin-theadventu commented on 2023-03-24 23:21 (UTC) (edited on 2023-03-24 23:37 (UTC) by begin-theadventu)

There's a duplicate of this package: https://aur.archlinux.org/packages/yt-dlg-git

I think youtube-dl-gui-git should either be merged with the above and removed or switched to this: https://github.com/StefanLobbenmeier/youtube-dl-gui

Or yt-dlg-git deleted and this package renamed.

willemw commented on 2023-01-26 10:09 (UTC) (edited on 2023-01-26 10:14 (UTC) by willemw)

@jester: Python 3.10 started in Arch on '26 Nov 2021'. Your python-polib package is older than that (2 Jul 2021). I think you need to rebuild all your Python packages that are still in /usr/lib/python3.9. To find outdated Python packages, run pacman -Qo /usr/lib/python3.9

jester commented on 2023-01-26 09:11 (UTC) (edited on 2023-02-01 13:32 (UTC) by jester)

The update fails to me.

==> Iniciando package()... running build_trans Traceback (most recent call last): File "/tmp/trizen-menta/youtube-dl-gui-git/src/youtube-dl-gui-git/setup.py", line 323, in <module> setup( File "/usr/lib/python3.10/site-packages/setuptools/init.py", line 87, in setup return distutils.core.setup(**attrs) File "/usr/lib/python3.10/site-packages/setuptools/_distutils/core.py", line 185, in setup return run_commands(dist) File "/usr/lib/python3.10/site-packages/setuptools/_distutils/core.py", line 201, in run_commands dist.run_commands() File "/usr/lib/python3.10/site-packages/setuptools/_distutils/dist.py", line 969, in run_commands self.run_command(cmd) File "/usr/lib/python3.10/site-packages/setuptools/dist.py", line 1208, in run_command super().run_command(command) File "/usr/lib/python3.10/site-packages/setuptools/_distutils/dist.py", line 988, in run_command cmd_obj.run() File "/tmp/trizen-menta/youtube-dl-gui-git/src/youtube-dl-gui-git/setup.py", line 138, in run import polib ModuleNotFoundError: No module named 'polib'

It seems that found the module polib, but if I search polib seems that version of python3 is installed.

aur/python-polib 1.1.1-1 [installed] [23+] [1.14%] [2 Jul 2021] A library to manipulate gettext files

aur/python2-polib 1.1.1-1 [1+] [0.00%] [2 Jul 2021] A library to manipulate gettext files

Armag67 commented on 2023-01-17 12:36 (UTC) (edited on 2023-01-19 18:22 (UTC) by Armag67)

Hello,

youtube-dl-gui-git 1.8.4.r22.g23ccbc4 installation needs Python packaging < 23.0. I have packaging 23.0 in user mode and 21.3 in system-wide. I had to temporarily disable my user version of packaging for upgrading to this version of youtube-dl-gui-git

Edit: even with packaging = 22.0, traceback:

Traceback (most recent call last):
  File "/var/tmp/pamac-build-h2/youtube-dl-gui-git/src/youtube-dl-gui-git/setup.py", line 49, in <module>
    from setuptools import Command, setup
  File "/usr/lib/python3.10/site-packages/setuptools/__init__.py", line 247, in <module>
    monkey.patch_all()
  File "/usr/lib/python3.10/site-packages/setuptools/monkey.py", line 97, in patch_all
    patch_for_msvc_specialized_compiler()
  File "/usr/lib/python3.10/site-packages/setuptools/monkey.py", line 134, in patch_for_msvc_specialized_compiler
    msvc = import_module('setuptools.msvc')
  File "/usr/lib/python3.10/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/usr/lib/python3.10/site-packages/setuptools/msvc.py", line 24, in <module>
    from packaging.version import LegacyVersion
ImportError: cannot import name 'LegacyVersion' from 'packaging.version' (/home/h2/.local/lib/python3.10/site-packages/packaging/version.py)