Package Details: yt-dlp 2021.10.10-1

Git Clone URL: https://aur.archlinux.org/yt-dlp.git (read-only, click to copy)
Package Base: yt-dlp
Description: A youtube-dl fork with additional features and fixes
Upstream URL: https://github.com/yt-dlp/yt-dlp
Licenses: Unlicense
Submitter: rumpelsepp
Maintainer: rumpelsepp (gmy, Commodorian)
Last Packager: rumpelsepp
Votes: 38
Popularity: 28.21
First Submitted: 2021-09-02 14:08
Last Updated: 2021-10-13 06:54

Latest Comments

1 2 Next › Last »

rumpelsepp commented on 2021-09-30 06:17

@cnekmp: You seem to install pandoc, which is often used for docs. Are you really building this package? There is no invocation of pandoc here.

edit: I am a monkey. There is. Pandoc is a makedependency. So, yes, haskell seems to be needed to build this.

rumpelsepp commented on 2021-09-30 06:15

I switched to github tags, as they include the tagname. It might avoid the cache problems.

@cnekmp: no idea! Will check.

cnekmp commented on 2021-09-28 13:24

Does yt-dlp built on haskell dependant packages?

[user@unknown ~]$ paru yt-dlp
1 aur/yt-dlp 2021.09.25-1 [+14 ~11.41]
    A youtube-dl fork with additional features and fixes
2 aur/yt-dlp-drop-in 1-1 [+6 ~3.96]
    Emulate youtube-dl executables with yt-dlp (youtube-dlp)
3 aur/yt-dlp-git 2021.08.02.r38.gb6a35ad83-1 [+5 ~3.20]
    A youtube-dl fork with additional features and fixes (git)
4 aur/python-yt-dlp-git 2021.07.07.r25.g34917076a-1 [+0 ~0.00]
    Command-line program to download videos from YouTube.com and many other other video platforms.
:: Packages to install (eg: 1 2 3, 1-3):
:: 1
:: Resolving dependencies...
:: Calculating conflicts...
:: Calculating inner conflicts...

Repo (2) python-mutagen-1.45.1-4  python-websockets-9.1-1
Repo Make (128) ghc-libs-8.10.5-1  haskell-network-3.1.2.2-1  haskell-th-compat-0.1.2-19
    haskell-network-uri-2.6.4.1-26  haskell-http-4000.3.16-35  haskell-primitive-0.7.1.0-139
    haskell-vector-0.12.3.0-23  haskell-zlib-0.6.2.3-26  haskell-juicypixels-3.3.5-95
    haskell-sha-1.6.4.4-17  haskell-hashable-1.3.2.0-11  haskell-integer-logarithms-1.0.3.1-4
    haskell-scientific-0.3.7.0-6  haskell-attoparsec-0.14.1-16  haskell-base-compat-0.11.2-5
    haskell-base-compat-batteries-0.11.2-124  haskell-data-fix-0.3.1-32  haskell-dlist-1.0-89
    haskell-base-orphans-0.8.4-111  haskell-tagged-0.8.6.1-3  haskell-distributive-0.6.2.1-93
    haskell-indexed-traversable-0.1.1-4  haskell-transformers-compat-0.6.6-4  haskell-comonad-5.0.8-89
    haskell-th-abstraction-0.4.2.0-3  haskell-bifunctors-5.5.11-10  haskell-assoc-1.0.2-85
    haskell-these-1.1.1.1-86  haskell-strict-0.4.0.1-59  haskell-time-compat-1.9.6-6
    haskell-unordered-containers-0.2.14.0-6  haskell-splitmix-0.1.0.3-119  haskell-random-1.2.0-233
    haskell-uuid-types-1.0.5-10  haskell-aeson-1.5.6.0-32  haskell-cmdargs-0.10.21-2
    haskell-aeson-pretty-0.8.8-170  haskell-base64-bytestring-1.2.0.1-60  haskell-blaze-builder-0.4.2.1-3
    haskell-blaze-markup-0.8.2.8-22  haskell-blaze-html-0.9.1.2-116  haskell-case-insensitive-1.2.1.0-96
    haskell-data-default-class-0.1.2.0-22  haskell-data-default-instances-containers-0.0.1-34
    haskell-data-default-instances-dlist-0.0.1-166  haskell-old-locale-1.0.0.7-28
    haskell-data-default-instances-old-locale-0.0.1-34  haskell-data-default-0.7.1.1-153
    haskell-file-embed-0.0.14.0-2  haskell-erf-2.0.0.0-22  haskell-quickcheck-2.14.2-175
    haskell-syb-0.7.2.1-57  haskell-pandoc-types-1.22-88  haskell-safe-0.3.19-6  haskell-th-lift-0.8.2-8
    haskell-th-lift-instances-0.1.18-58  haskell-unicode-collation-0.1.3-5  haskell-uniplate-1.6.13-63
    haskell-split-0.2.3.4-138  haskell-vector-algorithms-0.8.0.4-58
    haskell-mono-traversable-1.0.15.1-138  haskell-unliftio-core-0.2.0.1-7  haskell-resourcet-1.2.4.2-88
    haskell-conduit-1.3.4.1-25  haskell-async-2.2.3-47  haskell-streaming-commons-0.2.2.1-87
    haskell-typed-process-0.2.6.0-120  haskell-conduit-extra-1.3.5-140  haskell-xml-types-0.3.8-6
    haskell-xml-conduit-1.9.1.1-14  haskell-citeproc-0.4.0.1-2  haskell-unicode-transforms-0.3.7.1-70
    haskell-commonmark-0.2-5  haskell-emojis-0.1-104  haskell-commonmark-extensions-0.2.1.2-4
    haskell-commonmark-pandoc-0.2.1-7  haskell-basement-0.0.12-2  haskell-cereal-0.5.8.1-10
    haskell-socks-0.6.1-118  haskell-hourglass-0.2.12-139  haskell-memory-0.16.0-10
    haskell-asn1-types-0.3.4-96  haskell-asn1-encoding-0.9.6-117  haskell-cryptonite-0.29-10
    haskell-asn1-parse-0.9.5-117  haskell-pem-0.2.4-173  haskell-x509-1.7.5-153
    haskell-x509-store-1.6.7-152  haskell-byteable-0.1.1-23  haskell-x509-validation-1.6.11-152
    haskell-tls-1.5.5-34  haskell-x509-system-1.6.6-220  haskell-connection-0.3.1-130
    haskell-doclayout-0.3.0.2-18  haskell-hsyaml-0.2.1.0-109  haskell-base16-bytestring-1.0.1.0-53
    haskell-errors-2.3.0-60  haskell-text-conversions-0.3.1-74  haskell-doctemplates-0.9-57
    haskell-glob-0.10.1-85  haskell-haddock-library-1.10.0-28  haskell-ipynb-0.1.0.1-210
    haskell-jira-wiki-markup-1.4.0-5  haskell-colour-2.3.5-188  haskell-ansi-terminal-0.11-130
    haskell-utf8-string-1.0.2-43  haskell-skylighting-core-0.10.5.1-22  haskell-skylighting-0.10.5.1-22
    haskell-hslua-1.3.0.1-43  haskell-hslua-module-path-0.1.0.1-28  haskell-temporary-1.3-271
    haskell-hslua-module-system-0.2.2.1-99  haskell-hslua-module-text-0.3.0.1-87  haskell-cookie-0.4.5-10
    haskell-http-types-0.12.3-167  haskell-appar-0.1.8-11  haskell-byteorder-1.0.4-22
    haskell-iproute-1.7.11-20  haskell-mime-types-0.1.0.9-12  haskell-http-client-0.7.8-16
    haskell-http-client-tls-0.3.5.3-428  haskell-xml-1.3.14-28  haskell-texmath-0.12.3-12
    haskell-tagsoup-0.14.8-119  haskell-digest-0.0.1.2-23  haskell-old-time-1.1.0.3-28
    haskell-zip-archive-0.4.1-124  pandoc-2.14.0.2-2
Aur (1) yt-dlp-2021.09.25-1

:: Proceed to review? [Y/n]

malextp commented on 2021-09-27 16:33

to fix que sha256sum check error just delete the previous cache package when yay asks you if want to clean before installation (the previous step from show-diffs)

doku commented on 2021-09-27 08:43

Hello! Is it fixed? I have the same validity check problem. I tried to clean cache but see no difference.

Building yt-dlp...
==> Making package: yt-dlp 2021.09.25-1 (Mon 27 Sep 2021 11:38:43 AM +03)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found yt-dlp.tar.gz
==> Validating source files with sha256sums...
    yt-dlp.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build yt-dlp

I use pamac 10.2.0-1 on manjaro.

rumpelsepp commented on 2021-09-26 06:47

Not in this case I guess. As the build was broken, AUR helpers could not install the recent version.

DuBistKomisch commented on 2021-09-26 05:12

@rumpelsepp FYI you needed to bump the pkgrel with the second commit, otherwise it might not be recognised if the previous commit was already pulled by some AUR helpers

karu1 commented on 2021-09-25 22:49

I made small change, @rumpelsepp

  Using Released tar:
     Cleanig makedepends
     Skip build make

PKGBUILD-c556f4aae776

IBArbitrary commented on 2021-09-25 12:17

Alright, no issues. Now it is resolved.

rumpelsepp commented on 2021-09-25 12:03

The cache Problem was on my side. :D