Package Details: yuzu-early-access 3622-1

Git Clone URL: https://aur.archlinux.org/yuzu-early-access.git (read-only, click to copy)
Package Base: yuzu-early-access
Description: An experimental open-source Nintendo Switch emulator/debugger (early access version)
Upstream URL: https://yuzu-emu.org/
Licenses: GPL2
Conflicts: yuzu
Provides: yuzu
Submitter: heavysink
Maintainer: heavysink (lilac)
Last Packager: lilac
Votes: 24
Popularity: 3.48
First Submitted: 2020-12-09 04:09 (UTC)
Last Updated: 2023-05-31 00:03 (UTC)

Dependencies (44)

Required by (0)

Sources (3)

Pinned Comments

heavysink commented on 2022-07-29 03:48 (UTC) (edited on 2022-07-29 03:49 (UTC) by heavysink)

Currently there is a code bug upstream that prevents compiling in Linux since 2859 with no ETA for fixing. It is not fixed by now. Please do not flag it out of date. Once the code bug is fixed the lilac build bot will automatically compile it and push it in AUR.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

observ33r commented on 2023-01-26 16:15 (UTC)

@Ekim0789 dynarmic package can not be buildded without catch2v3 package! At the end I buildded catch2v3 with "--skippgpcheck" flag!

Ekim0789 commented on 2023-01-26 00:50 (UTC)

@observ33r Builds fine for me, just had to uninstall catch2v3 and install llvm14-libs.

observ33r commented on 2023-01-25 15:10 (UTC)

Yuzu has become real "pain in the ass" to build manually

error: target not found: cpp-jwt
error: target not found: xbyak
error: target not found: cubeb
error: target not found: dynarmic
> error: target not found: catch2>=3.2.1
> error: target not found: zydis>=4
>> error: target not found: zycore-c
error: target not found: discord-rpc
error: target not found: cpp-httplib

..and ultimately cannot be built due to catch2v3 problem.

catch2v3 git repo ... FAILED (unknown public key DE48307B8B0D381A)
==> ERROR: One or more PGP signatures could not be verified!

meirg commented on 2023-01-23 21:00 (UTC)

It seems llvm14-libs is needed now, can you add as a dependency?

nissen22 commented on 2023-01-08 10:19 (UTC) (edited on 2023-01-08 12:28 (UTC) by nissen22)

https://github.com/yuzu-emu/yuzu/issues/9503#issuecomment-1374534011

New UDEV needed for the new built in joycon driver to work. Could it be added to this package?

EDIT: The udev rule messes up Joycond's steam integration, so I wouldn't add it to this package as-is. If someone better at udev rules than me could modify it in such a way that it only gives Yuzu hidraw-access and not Steam that would be great...

hobbeshk commented on 2022-09-28 11:53 (UTC)

Thanks for maintaining this one, it's great to have the EA Yuzu accessible in this way!

I've noticed that the package hasn't updated for a while now (nearly two weeks, I think?). Is there something I should do on my end? Normally it gets picked up and is compiled on a (more than) daily basis.

sukanka commented on 2022-09-28 04:05 (UTC)

@Capricious-frog you need to update (or rebuild) yuzu-ea, see this pr for the latest PKGBUILD

Capricious-frog commented on 2022-09-27 11:12 (UTC) (edited on 2022-09-27 20:27 (UTC) by Capricious-frog)

I get this error when starting yuzu:

yuzu: error while loading shared libraries: libboost_context.so.1.79.0: cannot open shared object file: No such file or directory

I have boost-libs installed. Any idea what's causing this?

Edit: I recompiled yuzu and the error is now gone ¯\(ツ)

saburouta commented on 2022-09-09 02:19 (UTC) (edited on 2022-09-09 02:19 (UTC) by saburouta)

There doesn't seem to be anything wrong with the build. Should the pinned comment go away? (2939)

heavysink commented on 2022-07-29 03:48 (UTC) (edited on 2022-07-29 03:49 (UTC) by heavysink)

Currently there is a code bug upstream that prevents compiling in Linux since 2859 with no ETA for fixing. It is not fixed by now. Please do not flag it out of date. Once the code bug is fixed the lilac build bot will automatically compile it and push it in AUR.