Package Details: zeroc-ice 3.6.2-2

Git Clone URL: (read-only)
Package Base: zeroc-ice
Description: An object-oriented middleware that provides object-oriented Remote Procedure Call functionality
Upstream URL:
Keywords: c++ ice java middleware network rpc slice
Licenses: GPL, custom:ICE license
Submitter: bfrog
Maintainer: externl
Last Packager: externl
Votes: 26
Popularity: 0.572452
First Submitted: 2007-11-25 21:20
Last Updated: 2016-04-13 00:56

Required by (7)

Sources (2)

Latest Comments

externl commented on 2016-04-13 01:00

Ok, so I've moved Ice for PHP into its own repo (zeroc-ice-php56). This will vastly simplify builds.

J5lx commented on 2016-04-12 15:07

@externl I'm also in favor of just dropping/separating the PHP bindings until upstream adds support for PHP 7. They handled the bindings in the official graphviz package in [extra] that way, too:

externl commented on 2016-02-22 16:09

I'm thinking of just removing the php package and later adding new, non-split packages for php.

externl commented on 2016-02-22 15:33

@pythoneer. Not really no, the build is done all at once and it depends on php. It should work if you install php56 from AUR first.

pythoneer commented on 2016-02-22 14:00

is there a way to install it without the php dependency with makepkg?

externl commented on 2016-01-21 14:36

Yea, Arch updated to PHP 7. Ice 3.6 is not compatible with this.

Wabuo commented on 2016-01-21 08:32

Wont build =(

../../config/Make.rules.php:160: recipe for target 'Communicator.o' failed
make[2]: *** [Communicator.o] Error 1
make[2]: Leaving directory '/tmp/makepkg/zeroc-ice/src/ice-3.6.1/php/src/IcePHP'
Makefile:17: recipe for target 'all' failed
make[1]: *** [all] Error 1
make[1]: Leaving directory '/tmp/makepkg/zeroc-ice/src/ice-3.6.1/php/src'
Makefile:34: recipe for target 'all' failed
make: *** [all] Error 1
==> ERROR: A failure occurred in build().

externl commented on 2015-06-05 19:19

I don't think "editor" really makes sense as the category for this pack. Any thoughts?

externl commented on 2015-06-05 17:35

I've updated the PKGBUILD:

The IceGridGUI requires a specific version of the JGoodies files, so I've just included them as sources.

externl commented on 2015-06-05 15:40

@0x47 Are you still interested in maintaining this package? I would be happy to take over.

All comments