Package Details: zeroinstall-injector 2.16-1

Git Clone URL: (read-only, click to copy)
Package Base: zeroinstall-injector
Description: A decentralised cross-distribution software installation system
Upstream URL:
Keywords: 0install cross-platform decentralized package-manager
Licenses: LGPL-2.1
Provides: 0install, zeroinstall
Submitter: None
Maintainer: None
Last Packager: hayao
Votes: 64
Popularity: 0.000000
First Submitted: 2005-11-06 12:53 (UTC)
Last Updated: 2020-04-10 00:41 (UTC)

Dependencies (12)

Required by (0)

Sources (1)

Latest Comments

paulieg commented on 2021-04-30 06:41 (UTC)

FWIW, currently it is better to build from the git repo ( Builds easily. 700MB+ of build dependencies later et voila.

paulieg commented on 2021-04-30 05:46 (UTC)

@talex I had to remove the already installed ocamlbuild (was making the preinstalled-ocambuild check fail). Then I had to manually install and init opam, and use it to install a large number of libraries. After that, it errored out with this and I don't currently know enough to fix it, nor do I care enough to try:

File "src/zeroinstall/dune", line 5, characters 12-166:
5 |             (select from
6 |              (curl curl.lwt ->
7 |              (cohttp cohttp-lwt cohttp-lwt-unix lwt_ssl ->
8 |             )
Error: No solution found for this select form.
make: *** [Makefile:44: all] Error 1
make: *** Waiting for unfinished jobs....
File "src/zeroinstall/dune", line 5, characters 12-166:
5 |             (select from
6 |              (curl curl.lwt ->
7 |              (cohttp cohttp-lwt cohttp-lwt-unix lwt_ssl ->
8 |             )
Error: No solution found for this select form.
make: *** [Makefile:65: test] Error 1
==> ERROR: A failure occurred in build().
Error making: zeroinstall-injector

talex commented on 2020-04-05 10:20 (UTC) (edited on 2020-04-06 10:21 (UTC) by talex)

@ragouel: what error did you get? I just tried installing 2.16 on arch using this Dockerfile, which worked for me:

FROM archlinux
RUN pacman -Sy --noconfirm opam make m4 patch unzip gcc sed awk grep diffutils curl pkg-config which gtk3 git
RUN opam init --disable-sandboxing
RUN opam install -y 0install-gtk
RUN opam exec -- 0install --version


0install (zero-install) 2.16
Copyright (C) 2019 Thomas Leonard
This program comes with ABSOLUTELY NO WARRANTY,
to the extent permitted by law. You may redistribute copies of this program
under the terms of the GNU Lesser General Public License.
For more information about these matters, see the file named COPYING.
Compiled with D-Bus support: true
HTTP client library: libcurl (C)

(BTW, 0install no longer needs extlib)

ragouel commented on 2020-04-05 05:28 (UTC)

I wasn't able to successfully compile zeroinstall-injector, I used dune 2.1 from Community-Testing. Disowning, in case someone else knows how to fix this.

orbifx commented on 2016-09-05 09:58 (UTC)

I had to change my $PATH, to not contain my local .opam binaries (ocamlfind reports my .opam/ as a destdir, which doesn't work with the AUR scripts).

orbifx commented on 2016-09-02 16:06 (UTC)

Installing with yaourt, I get: ``` Packages (1) cppo-1.3.2-1 Total Installed Size: 0.86 MiB (1/1) checking keys in keyring (1/1) checking package integrity (1/1) loading package files (1/1) checking for file conflicts error: failed to commit transaction (conflicting files) cppo: /home/_/.opam/4.03.0/lib/cppo_ocamlbuild/META exists in filesystem cppo: /home/_/.opam/4.03.0/lib/cppo_ocamlbuild/ocamlbuild_cppo.a exists in filesystem cppo: /home/_/.opam/4.03.0/lib/cppo_ocamlbuild/ocamlbuild_cppo.cma exists in filesystem cppo: /home/_/.opam/4.03.0/lib/cppo_ocamlbuild/ocamlbuild_cppo.cmi exists in filesystem cppo: /home/_/.opam/4.03.0/lib/cppo_ocamlbuild/ocamlbuild_cppo.cmxa exists in filesystem cppo: /home/_/.opam/4.03.0/lib/cppo_ocamlbuild/ocamlbuild_cppo.cmxs exists in filesystem Errors occurred, no packages were upgraded. ``` Is it sane trying install over the existing opam installation?

talex commented on 2016-07-03 18:34 (UTC)

@sigmundv: thanks! I've made a Dockerfile to test installing on Arch with AUR, and that now builds for me:

sigmundv commented on 2016-07-01 01:03 (UTC)

I have now updated the ocaml-ssl package, so this should build now.

talex commented on 2016-06-06 21:57 (UTC)

According to, this was fixed in ocaml-ssh 0.5.2, but Arch only has 0.5.1 ( However, the following should let it build: yaourt -S opam unzip opam init --comp=4.02.3 eval `opam config env` opam install 0install (tested in an Arch Linux Docker container)

dtschmitz commented on 2016-06-05 21:16 (UTC)

sorry, I can't get this to build: ideas? Thanks in advance /* /usr/lib/ocaml/ssl/libssl_threads_stubs.a(ssl_stubs.o): In function `ocaml_ssl_create_context': ssl_stubs.c:(.text+0x576): undefined reference to `SSLv3_client_method' ssl_stubs.c:(.text+0x643): undefined reference to `SSLv3_method' ssl_stubs.c:(.text+0x653): undefined reference to `SSLv3_server_method' collect2: error: ld returned 1 exit status File "caml_startup", line 1: Error: Error during linking Command exited with code 2. Compilation unsuccessful after building 486 targets (0 cached) in 00:00:29. Makefile:26: recipe for target 'ocaml' failed make[2]: *** [ocaml] Error 10 make[2]: Leaving directory '/tmp/yaourt-tmp-dts/aur-zeroinstall-injector/src/0install-2.11/ocaml' /tmp/yaourt-tmp-dts/aur-zeroinstall-injector/src/0install-2.11/ recipe for target 'all' failed make[1]: *** [all] Error 2 make[1]: Leaving directory '/tmp/yaourt-tmp-dts/aur-zeroinstall-injector/src/0install-2.11/build' Makefile:53: recipe for target 'all' failed make: *** [all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build zeroinstall-injector. ==> Restart building zeroinstall-injector ? [y/N] ==> --------------------------------------------- ==> */

timdiels commented on 2015-09-28 13:36 (UTC)

Please update to 2.9.1. I changed the version in PKGBUILD, ran updpkgsums, and it compiles and runs fine.

sigmundv commented on 2015-05-19 08:38 (UTC)

Thank you, talex, I'll try that.

talex commented on 2015-05-19 08:01 (UTC)

Looks like AUR's ocaml-sha package is massively out of date: You could try removing the sha package, which will cause 0install to fall back to using openssl's hashing (which is what 2.6 used anyway).

sigmundv commented on 2015-05-19 06:47 (UTC)

Let me know if any of you experience this failure when building version 2.8: File "support/", line 44, characters 35-39: Error: Signature mismatch: ... The value `finalize' is required but not provided File "support/", line 30, characters 4-27: Expected declaration The value `update_string' is required but not provided File "support/", line 29, characters 4-45: Expected declaration The value `init' is required but not provided File "support/", line 28, characters 4-25: Expected declaration The type `ctx' is required but not provided File "support/", line 26, characters 9-12: Expected declaration Command exited with code 2.

sigmundv commented on 2015-05-19 06:40 (UTC)

Version 2.8 doesn't build for me while 2.6 builds without problems (maybe I'm missing some dependency, but I don't think so), so I guess I have to get in touch with the developer before updating this package.

sigmundv commented on 2015-05-13 10:04 (UTC)

Thanks for the information, talex!

talex commented on 2015-05-13 10:02 (UTC)

The lwt.syntax package became optional in Lwt 2.4.4, which now needs to be compiled with --enable-camlp4 in that package.

sigmundv commented on 2015-05-13 07:08 (UTC)

I get that same error myself and am working on solving it. I'll update the PKGBUILD in due course. Ocaml modules are really not easy to maintain.

mickours commented on 2015-05-13 06:57 (UTC)

Compilation still not working with current or next version. I have this error: + ocamlfind ocamldep -syntax camlp4o -package lwt.syntax -package yojson,xmlm,str,lwt,lwt.unix,lwt.react,lwt.preemptive,extlib,curl,ssl,dynlink -modules support/ > support/ ocamlfind: Package `lwt.syntax' not found Command exited with code 2

tareef commented on 2015-05-09 18:41 (UTC)

current version is 2.8, please update

talex commented on 2014-05-27 13:51 (UTC)

@simonsilva: it's because you've got the !staticlibs option set, causing makepkg to delete all your .a files (this is now the default). Ideally, libraries that need to provide .a files would override the option, but many don't.

simonsilva commented on 2014-05-27 13:43 (UTC)

problem with ocaml-lwt is solved with the new version. nevertheless i can't compile it. i receive compiler errors. gcc can't find a few files: - /usr/lib/ocaml/ssl/ssl_threads.a - /usr/lib/ocaml/curl/curl.a: - /usr/lib/ocaml/extlib/extLib.a - /usr/lib/ocaml/react/react.a - /usr/lib/ocaml/xmlm/xmlm.a - /usr/lib/ocaml/oUnit/oUnit.a - /usr/lib/ocaml/oUnit/oUnitAdvanced.a i took a look into the corresponding folders and just found some .cma, .cmi, .cmx, .cmxa, .cmxs and .mli files instead.

talex commented on 2014-05-24 11:12 (UTC)

Looks like the Lwt package should be updated to the latest release. Until that happens, does "opam install 0install" work?

simonsilva commented on 2014-05-24 11:03 (UTC)

ocaml-lwt can not build from aur on amd64. so i can't use zeroinstall ... any suggestions?

talex commented on 2014-02-23 21:35 (UTC)

Note that OCaml libraries are always statically linked. Looks like a change to makepkg to remove static libraries has accidentally broken most of the OCaml packages:

bartbes commented on 2014-02-05 16:09 (UTC)

It tries to link against .a files that don't exist on my system. Am I using old AUR packages (if so, why did they not get a version bump?), or does this package not compile on a clean system?

talex commented on 2013-10-19 11:20 (UTC)

BTW, 2.3.x is the current stable series (and doesn't require OCaml). Whoever adopts this package will probably want to start with that. Building the OCaml version using AUR dependencies is broken (just recently) because the old AUR Lwt package doesn't work with the new OCaml version (4.01). 0install 2.4+ builds fine on Arch with OPAM, though - just follow the instructions in the README.

speps commented on 2013-10-19 00:29 (UTC)

New generation of 0install (2.4+) depends on ocaml. I'm not interested any more in maintaining this. Orphaning.

lots0logs commented on 2013-10-01 05:00 (UTC)

Version is now at 2.4, PKGBUILD needs updating. THANKS!

dustball commented on 2013-04-05 14:55 (UTC)

current version is 2.0, please update

timdiels commented on 2012-09-18 17:34 (UTC)

Current version is 1.11 md5sums=('20eb0497c8df9864e353411a13c41844')

unhammer commented on 2012-04-17 08:58 (UTC)

seems like 1.7 is out

thomas.oster commented on 2011-11-10 08:39 (UTC)

Hi. Zeroinstall doesn't seem to recognize installed packages by pacman. Seems as if one would have to implement an "ArchDistribution" class in the zeroinstall/injector/ file, but I don't understand it completely yet. Can anybody confirm that it does not find installed packages? Try the instructions from and you will find, that it can not find a version for "gnome-shell", although I have it installed.

rafaelff commented on 2011-08-23 00:21 (UTC)

zeroinstall home site have an out-dated message about zeroisntall package in Archlinux. It mentions a problem with python, but my guess it is from around end of 2010. Can you please convince the webadmin to fix it?

speps commented on 2010-12-08 23:57 (UTC)

@vanadium50 Thanks for signaling, updated.

vanadium50 commented on 2010-12-08 18:30 (UTC)

0.51 and 0.51.1 both released 05-Dec-2010 - I don't know the difference.

speps commented on 2010-10-21 03:57 (UTC)

@Xavion Hi, this package needs to be adapted to the great python rebuild, also version 0.50 is out. Here is a working PKGBUILD --> ( python2 + dependences + licenses fixes) Also the missing .install ---> ( desktop database + icon cache updates) Feel free to adopt C ya