Package Details: zeroinstall-injector 2.16-1

Git Clone URL: https://aur.archlinux.org/zeroinstall-injector.git (read-only, click to copy)
Package Base: zeroinstall-injector
Description: A decentralised cross-distribution software installation system
Upstream URL: https://0install.net
Keywords: 0install cross-platform decentralized package-manager
Licenses: LGPL-2.1
Provides: 0install, zeroinstall
Submitter: None
Maintainer: None
Last Packager: hayao
Votes: 64
Popularity: 0.000000
First Submitted: 2005-11-06 12:53
Last Updated: 2020-04-10 00:41

Dependencies (12)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

talex commented on 2014-05-27 13:51

@simonsilva: it's because you've got the !staticlibs option set, causing makepkg to delete all your .a files (this is now the default). Ideally, libraries that need to provide .a files would override the option, but many don't.

simonsilva commented on 2014-05-27 13:43

problem with ocaml-lwt is solved with the new version.
nevertheless i can't compile it. i receive compiler errors. gcc can't find a few files:
- /usr/lib/ocaml/ssl/ssl_threads.a
- /usr/lib/ocaml/curl/curl.a:
- /usr/lib/ocaml/extlib/extLib.a
- /usr/lib/ocaml/react/react.a
- /usr/lib/ocaml/xmlm/xmlm.a
- /usr/lib/ocaml/oUnit/oUnit.a
- /usr/lib/ocaml/oUnit/oUnitAdvanced.a
i took a look into the corresponding folders and just found some .cma, .cmi, .cmx, .cmxa, .cmxs and .mli files instead.

talex commented on 2014-05-24 11:12

Looks like the Lwt package should be updated to the latest release.
Until that happens, does "opam install 0install" work?

simonsilva commented on 2014-05-24 11:03

ocaml-lwt can not build from aur on amd64. so i can't use zeroinstall ... any suggestions?

talex commented on 2014-02-23 21:35

Note that OCaml libraries are always statically linked. Looks like a change to makepkg to remove static libraries has accidentally broken most of the OCaml packages:

https://mailman.archlinux.org/pipermail/arch-dev-public/2013-September/025454.html

bcdarwin commented on 2014-02-05 22:17

It seems like zeroinstall expects to link statically against some of its dependencies. A quick fix is to recompile ocaml-{curl,ssl,react,ounit,extlib,lwt-git,xmlm} with 'staticlibs' added to `options`.

bartbes commented on 2014-02-05 16:09

It tries to link against .a files that don't exist on my system. Am I using old AUR packages (if so, why did they not get a version bump?), or does this package not compile on a clean system?

talex commented on 2013-10-19 11:20

BTW, 2.3.x is the current stable series (and doesn't require OCaml). Whoever adopts this package will probably want to start with that. Building the OCaml version using AUR dependencies is broken (just recently) because the old AUR Lwt package doesn't work with the new OCaml version (4.01). 0install 2.4+ builds fine on Arch with OPAM, though - just follow the instructions in the README.

speps commented on 2013-10-19 00:29

New generation of 0install (2.4+) depends on ocaml. I'm not interested any more in maintaining this. Orphaning.

lots0logs commented on 2013-10-01 05:00

Version is now at 2.4, PKGBUILD needs updating. THANKS!