Package Details: zfs-dkms 2.1.1-1

Git Clone URL: https://aur.archlinux.org/zfs-dkms.git (read-only, click to copy)
Package Base: zfs-dkms
Description: Kernel modules for the Zettabyte File System.
Upstream URL: https://zfsonlinux.org/
Licenses: CDDL
Conflicts: spl-dkms
Provides: SPL-MODULE=2.1.1, ZFS-MODULE=2.1.1, spl-dkms, zfs
Replaces: spl-dkms
Submitter: isiachi
Maintainer: eschwartz (jonathon)
Last Packager: jonathon
Votes: 120
Popularity: 4.66
First Submitted: 2015-08-31 12:01
Last Updated: 2021-10-01 10:41

Required by (18)

Sources (3)

Latest Comments

« First ‹ Previous ... 22 23 24 25 26 27 28 29 30 31 32 ... Next › Last »

skjeggape commented on 2017-07-04 20:56

After latest update my system wont boot, normal recover procedure wont solve the issue.

at boot i get following error: https://goo.gl/photos/AZ4xTEHVJFPpCdg46

This pool uses the following feature(s) not supported by this system:
org.zfsonlinux:userobj_accounting (User/Group object accounting.)
All unsupported features are only required for writing to the pool.
The pool can be imported using '-o readonly=on'.
cannot import 'poolname'
error failed to mount real root etc etc.

isiachi commented on 2017-06-29 23:26

The spl-dkms package contains a patch to build on gcc 7.1.

@gkjarch
You have to install spl-dkms, spl-utils, zfs-dkms, zfs-utils all together or install spl-dkms and spl-utils with the -d option of pacman.

gkjarch commented on 2017-06-25 02:43

1. When upgrading from 0.6.5.9 to 0.6.5.10, the spl-dkms upgrade succefully, but zfs-dkms got an error something like break dependence between spl-dkms 0.6.5.10 and zfs-dkms 0.6.5.9 . Therefore I have to use "pacman -Rns zfs-dkms" and reinstall. I can not get the log.

2. When upgrading linux-lts, dkms can not resolve dependence. Log:
:: Processing package changes...
(1/2) upgrading linux-lts [####################################] 100%
>>> Updating module dependencies. Please wait ...
(2/2) upgrading linux-lts-headers [####################################] 100%
:: Running post-transaction hooks...
(1/3) Install DKMS modules
==> dkms install zfs/0.6.5.10 -k 4.9.34-1-lts
configure: error:
*** Please make sure the kmod spl devel <kernel> package for your
*** distribution is installed then try again. If that fails you
*** can specify the location of the spl objects with the
*** '--with-spl-obj=PATH' option.
Error! Bad return status for module build on kernel: 4.9.34-1-lts (x86_64)
Consult /var/lib/dkms/zfs/0.6.5.10/build/make.log for more information.
==> dkms install vboxguest/5.1.22_OSE -k 4.9.34-1-lts
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.
==> dkms install vboxhost/5.1.22_OSE -k 4.9.34-1-lts
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.
==> dkms install spl/0.6.5.10 -k 4.9.34-1-lts
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.
(2/3) Updating linux-lts initcpios

RubenKelevra commented on 2017-06-25 02:15

@charlesmilette I did the out of date flag to notify him, that there is already a patch available for building SPL and ZFS with GCC7.1 again.

But it seemed to have overlapped with his update push - so thanks! :)

sylveon commented on 2017-06-24 14:20

Poor package maintainer. It's already been flagged out of date.

RubenKelevra commented on 2017-06-24 14:15

A shorter reaction time of the package maintainer would be nice.

Zazzman commented on 2017-06-22 16:31

The solution I'm using?
I edit the PKGBUILDs to use:

https://github.com/tonyhutter/zfs.git
https://github.com/tonyhutter/spl.git

that's the guy who's patching upstream for gcc-7.1 ;)

emacsomancer commented on 2017-06-22 00:07

I've been running with zfs-0.6.5.10/spl-0.6.5.10 on Void Linux, and it seems to work fine with the latest 4.11 kernel. FYI.

jjb2016 commented on 2017-06-20 19:14

The AUR package should be updated for 0.6.5.10 but in the meantime I have been able to successfully build and install spl-dkms & zfs-dkms 0.6.5.10 for linux 4.11.6. You need downgrade gcc to version <= 6.3.1 first. Download the snapshot for spl-dkms & zfs-dkms and edit the pkgver from 0.6.5.9 to 0.6.5.10 in the PKGBUILD files for each.

hawk07 commented on 2017-06-20 18:29

Please upgrade https://github.com/zfsonlinux/spl/releases/tag/spl-0.6.5.10