Package Details: zoiper 3.3-2

Git Clone URL: https://aur.archlinux.org/zoiper.git (read-only)
Package Base: zoiper
Description: An IAX and SIP VoIP softphone
Upstream URL: http://www.zoiper.com/
Licenses: custom
Submitter: ava1ar
Maintainer: Xavion
Last Packager: Xavion
Votes: 48
Popularity: 0.378461
First Submitted: 2009-10-15 10:31
Last Updated: 2017-01-10 23:13

Latest Comments

Xavion commented on 2017-01-25 06:18

Adding a comment like that to the PKGBUILD shouldn't be necessary. Also, not everyone uses 'pacaur': I, for one, have stayed with 'yaourt'.

ohmysql commented on 2017-01-25 05:47

Suggestion:

adding a comment that says 1) Do NOT mark the package out of date if you need to manually download Zoiper. 2) The default configuration for pacaur as of 2017-01-25 is to put it in ~/.cache/pacaur/zoiper

Moving the downloaded file there should work. However do NOT mark this package out of date or otherwise bother me to figure out where your PKGBUILD directory is.

etc.

Xavion commented on 2017-01-10 23:15

Yes, none of that stuff should be necessary anymore. I have amended the PKGBUILD. Thanks for bringing this to my attention.

ilmagno commented on 2017-01-10 02:48

The tarball now has a x86_64 version, can this be updated so that it doesn't require the 32bit libraries on a x86_64 system?

Xavion commented on 2015-11-13 20:25

View the PKGBUILD and you'll see that "lib32-pangox-compat" is already listed in the "depends" array for "x86_64" systems.

fdservices commented on 2015-11-13 16:38

Another dependency: lib32-pangox-compat

Xavion commented on 2015-06-11 20:30

Did you actually read that message before pasting it here and flagging the package out-of-date?

Manually download the tarball into the directory containing the PKGBUILD, then rebuild the package.

darkdirk commented on 2015-06-11 16:57

Fails with: "WARNING: There is no longer a direct download link for the Zoiper tarball. Get it manually from: http://www.zoiper.com/en/voip-softphone/download/zoiper3/for/linux"

balage commented on 2015-02-19 11:48

Okay, I accept it.

Xavion commented on 2015-02-18 19:47

The location of "${startdir}" depends on a number of factors. Teaching people how to find it is beyond the scope of any single PKGBUILD.

Anyway, I feel that "${startdir}" infers the directory containing the PKGBUILD. Also, most confused newbies would simply Google "PKGBUILD startdir".

balage commented on 2015-02-18 08:51

Thanks Xavion, it was not trivial for me.
Neither the fact that where ${startdir} actually is where I need to put the tar.gz file, but eventually I managed to do it.

Is it possible to add some comments to the pgkbuild about these?

Xavion commented on 2015-02-17 20:01

Nope, they're all still available. One of them is in [AUR], while the rest are in [multilib]. The latter repository can be enabled via your "/etc/pacman.conf".

balage commented on 2015-02-17 14:53

It looks like the 32bit dependencies cannot be satisfied anymore as the packages do not exist anymore.

Xavion commented on 2014-09-20 23:47

It's okay, I've upgraded this package to v3.3. I've added a "zoiper-classic" package for those who prefer v2.20.

sparse commented on 2014-09-20 18:07

https://aur.archlinux.org/packages/zoiper-new/

Xavion commented on 2014-07-12 00:02

Due to the way v3.2 is packaged, installing it via the AUR isn't really an option.

CPUnltd commented on 2014-06-01 20:05

Would like to take over this package, but could use a little help getting it updated to 3.2 if there is anyone around willing to help...

Casper commented on 2013-12-24 14:52

sha1sum for zoiper219-linux.tar.gz is worng. And there is 3.2 version available in zoiper.com.

Xavion commented on 2013-08-28 22:03

Given that Zoiper is a 32-bit application, you'll need to install the "lib32-gtk-engine-murrine" package.

JohnnyDeacon commented on 2013-08-28 20:25

Hi, I'm getting this error:
(zoiper:7003): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

I have gnome shell 3.8

Thanks in advance for any help

xRemaLx commented on 2013-03-01 10:46

missed dependency on lib32-pangox-compat

Anonymous comment on 2010-05-19 20:01

It now exits when I try to access the options. It doesn't echo any messages in the console.

Garret commented on 2010-05-19 12:46

@ava1ar: no error messages in the console, as hei_ku

Anonymous comment on 2010-05-19 12:28

It now exits when I try to access the options. It doesn't echo any messages in the console.

ava1ar commented on 2010-05-19 12:22

Garret, any error messages in console after crash? I am suspecting some missed dependencies because it is working on my machine.

Garret commented on 2010-05-19 12:15

I have Archlinux x86_64 and I can run the app but when I click on the preferences the program instantly exits.

Anonymous comment on 2010-05-08 14:58

Now it doesn't throw an error, but it doesn't start. It quits without showing anything nor throwing any errors

ava1ar commented on 2010-05-07 21:14

Fixed, this was due to missed dependency on lib32-alsa-lib. Please try updated version.

Anonymous comment on 2010-05-07 21:00

When running in x86_64, it throws an error
zoiper: error while loading shared libraries: libasound.so.2: wrong ELF class: ELFCLASS64

ava1ar commented on 2010-04-18 11:54

No problem :) You may want to use update notification in zoiper for being notified about new version. Then you can out-of-date package if I missed the update.

Anonymous comment on 2010-04-18 11:49

I was going by what was listed on zoiper's website (link above). Since they don't list the version number with the download I assumed the Linux version was updated too. Sorry about the inconvenience.

ava1ar commented on 2010-04-18 11:41

The latest available zoiper version for linux is 2.15. Please provide link to the never version if you have it.

Anonymous comment on 2010-04-18 11:35

New Version out:

16-03-2010: Zoiper Classic Release (2.28)

ava1ar commented on 2010-04-18 00:59

Updated upto 2.15 and added x86_64 compatibility (at least it launches). Please report if it is working on x86_64.