Package Details: zotero 4.0.29.10-1

Git Clone URL: https://aur.archlinux.org/zotero.git (read-only)
Package Base: zotero
Description: Zotero Standalone. Is a free, easy-to-use tool to help you collect, organize, cite, and share your research sources.
Upstream URL: http://www.zotero.org/download
Licenses: GPL3
Submitter: juanmah
Maintainer: juanmah
Last Packager: juanmah
Votes: 138
Popularity: 2.908388
First Submitted: 2011-02-22 15:55
Last Updated: 2016-05-14 05:20

Latest Comments

juanmah commented on 2015-12-20 16:37

Changing link is not working.

lrwxrwxrwx 1 root root 22 20. Dez 17:33 /usr/bin/zotero -> /usr/lib/zotero/zotero

Running /usr/lib/zotero/zotero does.

Running /usr/bin/zotero gives this error message:

Could not read application.ini

wsha commented on 2015-12-20 10:04

Per the discussion here: https://github.com/zotero/zotero-standalone-build/issues/39, it would be better to link /usr/bin/zotero to /usr/lib/zotero/zotero rather than linking to the run_zotero.sh script (though maybe simonster will add something else to that discussion about the purpose of run_zotero.sh).

rcrath commented on 2015-08-14 23:34

oops...reinstalling, as zotero no longer runs right when I start it from ~/bin, gives glib error

GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

so back to the aur version. odd thing is it tries to update even though the in the aur version is already the current one. I just updated everything yesterday so don't think it was an old package. anyway, the nag screens are, umm, naggy. I looked for setting in zotero, and it looks like the nag settings can be adjusted in the about:config of the advaned settings menu. could that be set to not nag in the pkgbuild?

rcrath commented on 2015-08-14 22:53

uninstalling as zotero pushes updates through the interface and issues nag screen to update, but cannot b/c need sudo permission to write new file to bin. when run from ~/bin, it works fine and updates properly. just borrowing the zotero.desktop file from the aur to make a launcher.

c3kay commented on 2015-08-02 00:39

As below, for 4.0.28 the md5sum is 55f743aa7c08ca16d933e91faf43a2fc

titaniumbones commented on 2015-07-22 17:20

for latest 4.0.27.6, change package version to 4.0.27.6, and first md5sum for x86_64 to '887b3a50611de4478e8c82e954e1629b' in PKGBUILD. Installation then proceeds with no problems.

juanmah commented on 2015-02-11 05:15

@varnion java-environment and java-runtime are already optional dependencies in libreoffice.

varnion commented on 2015-02-05 15:09

please add jre8-openjdk as a optional dependency (for integration with libreoffice). maybe jre7 also works, didnt test.

johanzebin commented on 2014-11-03 11:15

@orschiro: Thanks a lot, I was incredibly dumb :). Everything works now!

orschiro commented on 2014-10-28 20:04

@johanzebin

pacman -U requires a compiled package (pkg.XX...) as an input, not the source code (.tar.bz2)

johanzebin commented on 2014-10-28 18:12

Hey, I would like to install the package, but I encounter the following problem:
sudo pacman -U Zotero-4.0.23_linux-x86_64.tar.bz2
loading packages...
error: missing package metadata in Zotero-4.0.23_linux-x86_64.tar.bz2
error: 'Zotero-4.0.23_linux-x86_64.tar.bz2': invalid or corrupted package

orschiro commented on 2014-09-22 04:09

Does someone encounter the following problem with firefox 32.0.1-1 and zotero 4.0.22-2:

When I activate the Zotero for Firefox add-on (the connector downloaded from here [1]), then I cannot edit any of my bookmarks anymore. For instance, clicking on the star icon of the toolbar does not bring up any popup to edit the bookmark.

In the Zotero forums they suggest [2] that this seems to be an Arch specific issue.

[1] https://www.zotero.org/download/
[2] https://forums.zotero.org/discussion/40275?page=1#Item_8

I would appreciate if someone could give a quick response whether he experiences similar issues. Thanks!

juanmah commented on 2014-09-07 06:49

I put icons into hicolor standard location. And now zotero.desktop looks for a system icon, not a hard-linked one.

orschiro commented on 2014-09-06 16:48

@juanmah

This package seems to use an hard-coded icon. I am referring to the following discussion:

https://github.com/numixproject/numix-icon-theme-circle/issues/190#issuecomment-54719725

Is this helpful to resolve the issue?

Thanks!

juanmah commented on 2014-03-25 06:20

Yes it is. Sorry.

allencch commented on 2014-03-25 03:51

md5sum for i686 is 'acd8a827e2553228c64b24f3d525215c'

panda-z commented on 2014-03-19 09:28

4.0.18 is out.

juanmah commented on 2013-11-28 06:00

You're right muon, multilib is only valid for x86_64. Zotero is compiled for i686 and x86_64, then there's no problem using gcc-libs as dependency instead of multilib one.

juanmah commented on 2013-11-28 05:59

You're right muon, multilib is only valid for x86_64. Zotero is compiled for i686 and x86_64, then there's no problem using gcc-libs as option instead of multilib one.

muon commented on 2013-11-27 23:58

Are you sure about gcc-libs-multilib? I was using it before without this. That said, I did/do have gcc-libs. Is there a reason it's gcc-libs-multilib? Thanks for maintaining.

juanmah commented on 2013-11-27 07:26

I'm removing it

juanmah commented on 2013-11-27 07:24

This says that this zotero.jar file is simply a zip file:

http://www.zotero.org/support/dev/modifying_zotero_files

orschiro commented on 2013-11-27 07:23

@juanmah

I saw namcap's comment on adding dbus-glib. But according to the package description java is not dependency.

https://www.archlinux.org/packages/extra/i686/dbus-glib/

juanmah commented on 2013-11-27 07:18

As namcap says it. Maybe optional?

orschiro commented on 2013-11-27 06:14

Why does Zotero now depend on java?

~ $ sudo aura -A zotero
[sudo] password for orschiro:
aura >>= Determining dependencies...
aura >>= Repository dependencies:
jdk7-openjdk

aura >>= AUR Packages:
zotero

aura >>= Continue? [Y/n]
resolving dependencies...
looking for inter-conflicts...

Packages (1): jdk7-openjdk-7.u45_2.4.3-1

Total Download Size: 15.09 MiB
Total Installed Size: 19.36 MiB

juanmah commented on 2013-11-27 05:15

Added dependencies and showing information only once.

panda-z commented on 2013-11-26 07:55

Please add 'dbus-glib' to dependencies, otherwise:
libdbus-glib-1.so.2: cannot open shared object file: No such file or directory

Xyne commented on 2013-11-21 01:33

Hi,

The post_upgrade function in the install file should only display information about changes in the package thay may require user intervention. The current message is constant and unrelated to the version, so it should only be displayed once in the post_install message. Please remove it from the post_upgrade function. Thanks!

Regards,
Xyne

orschiro commented on 2013-09-26 16:27

Can you reproduce encoding errors when dragging a reference from Zotero to a Google Docs?

I get the following: http://i.imgur.com/KBXdEPW.png

Anonymous comment on 2013-09-16 17:10

The issue of Zotero crashing after throwing

###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /builds/slave/rel-m-rel-xr_l64_bld-000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157

appears to actually be and issue between the latest KDE version and the oxygen-gtk package. Setting the GTK2 theme away from oxygen-gtk resolved the issue for me.

From:
https://forums.zotero.org/discussion/31858/zotero-standalone-408-and-4011-crashes-in-fedora-19-linux-when-any-menu-is-selected/

SMOG commented on 2013-09-08 08:46

I haven't tried also because it hasn't been any recent update that could have caused the problem.
I'm now using the firefox plugin, I think I'm going to wait for next zotero update and then try to reinstall it.

orschiro commented on 2013-09-08 08:43

@SMOG,

So it might be something QT / KDE related. Did you try downgrading QT and KDE and see if that resolves it?

SMOG commented on 2013-09-08 08:34

I'm using KDE 4.11 and I've tried to rename .zotero folder but it didn't solved.

orschiro commented on 2013-09-08 08:26

To all having the crash:

I am not sure why you are having that error but what DE are you using?

I am here on Gnome (so no QT) and it does work. Also, did you try renaming your ~/.zotero folder?

SMOG commented on 2013-09-07 15:14

I've investigated a bit more:
Here the GLib-CRITICAL error is not that critical, other GTK applications do throw it with no problem at all (e.g. firefox)
The application starts and seems to work, but as I click anything the two X_CreatePixmap errors are thrown and the application crashes.
Google doesn't help about that though...

Also, using zotero as firefox extension works with no crash.

SMOG commented on 2013-09-07 15:13

SMOG commented on 2013-09-07 15:12

I've investigated a bit more:
Here the GLib-CRITICAL error is not that critical, other GTK applications do throw it with no problem at all (e.g. firefox)
The application starts and seems to work, but as I click anything the two X_CreatePixmap errors are thrown and the application crashes.
Google doesn't help about that though...

SMOG commented on 2013-09-07 15:11

I've investigated a bit more:
Here the GLib-CRITICAL error is not that critical, other GTK applications do throw it with no problem at all (e.g. firefox)
The application starts and seems to work, but as I click anything the two X_CreatePixmap errors are thrown and the application crashes.
Google doesn't help about that thou...

SMOG commented on 2013-09-07 13:51

I've the same problem as Jarshvor

fra@fra-notebook:~$ zotero

(process:6390): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
unnamed app(6390) KMimeTypePrivate::ensureXmlDataLoaded: Missing <comment> field in "application/x-msdownload.xml"
unnamed app(6390) KMimeTypePrivate::ensureXmlDataLoaded: Missing <comment> field in "text/x-component.xml"
###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /builds/slave/rel-m-rel-xr_l64_bld-000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157
###!!! ABORT: X_CreatePixmap: BadAlloc (insufficient resources for operation); 4 requests ago: file /builds/slave/rel-m-rel-xr_l64_bld-000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157
Errore di segmentazione (core dumped)

juanmah commented on 2013-09-07 13:07

It's not yet out-of-date. Firefox plugin has updated but standalone not yet.

orschiro commented on 2013-08-31 16:36

@Jarshvor,

Nothing like that here. Does that also happen with version 4.0.10?

Jarshvor commented on 2013-08-30 15:50

also get this in a dialog box:

Database upgrade error

[Exception... "Component returned failure code: 0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE) [mozIStorageConnection.executeSimpleSQL]" nsresult: "0x80520010 (NS_ERROR_FILE_NO_DEVICE_SPACE)" location: "JS frame :: chrome://zotero/content/xpcom/db.js :: Zotero.DBConnection.prototype.query :: line 149" data: no] [QUERY: INSERT INTO itemTypesCombined SELECT itemTypeID, typeName, display, 0 AS custom FROM itemTypes UNION SELECT customItemTypeID + 10000 AS itemTypeID, typeName, display, 1 AS custom FROM customItemTypes] [ERROR: database or disk is full]

Jarshvor commented on 2013-08-29 18:30

GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed

I encouter this when starting zotero, and get database error.

Anybody got any experience on this?

juanmah commented on 2013-08-10 10:09

Sorry for the delay, but I saved you from one short-live intermediate version :)

juanmah commented on 2013-07-23 18:19

orschiro: I tried it last year, but I had no success. You can start with this if you want: http://pastebin.com/ARCy48tk

juanmah commented on 2013-07-23 18:14

jrfaller: thx

juanmah commented on 2013-07-23 18:11

orschiro: I use precompiled packages. I suggest you to create a new package like zotero-git and compile it from sources.

orschiro commented on 2013-07-23 13:07

I talked to the devs and the patch below to support drag and drop will not be included before October. Do you know how to compile Zotero with the Xulrunner patch?

Anonymous comment on 2013-07-23 13:04

PKGBUILD for Zotero 4.0.9 : http://pastebin.com/WQdHD0xX

orschiro commented on 2013-07-04 19:39

They pushed the patch into upstream of the Mozilla repo:

https://hg.mozilla.org/integration/mozilla-inbound/rev/357ca015db90

Thus it should find its way into Zotero Standalone soon.

orschiro commented on 2013-07-01 03:57

There is a patch [1] that seem to fix drag&drop from URL to Zotero as it is based on Xulrunner. Does anyone know how to apply it?

[1] https://bug609284.bugzilla.mozilla.org/attachment.cgi?id=768270

juanmah commented on 2013-05-31 19:13

what a pity! Thanks for caring about it.

orschiro commented on 2013-05-31 14:34

I talked with the developers and they told me that drag&drop is a general thing often lacking on Linux. They cannot trace back the issue more precisely to fix the bug.

juanmah commented on 2013-05-28 13:18

I tried with Chromium and Firefox, and they do not drag&drop URL from address bar nor links.

orschiro commented on 2013-05-28 12:45

A quick question: Can you drag and drop a URL from Chrome or any other browser to Zotero Standalone?

This works flawlessly on Windows and is pretty useful for adding PDFs directly to your collections.

Can you please try it and give feedback?

On my Gnome system and Chrome it does not work. After dragging and dropping the document does not appear in the library.

juanmah commented on 2013-04-25 06:51

Orschiro, you are right. It is the DE (Gnome) who is not showing context menu icons.

Changing org.gnome.desktop.interface menus-have-icons to true works both for Standalone and Firefox Extension.

Thank you very much. Now, it is nicer.

orschiro commented on 2013-04-25 04:31

The binary indeed has the icons available but in some DEs showing context menu icons is disabled by default, such as in Gnome.

If you want to show the icons set org.gnome.desktop.interface menus-have-icons to true.

juanmah commented on 2013-04-24 11:29

Hallo orschiro,

Linux Zotero Standalone ist ein vorgebaute Binär, nicht sondern für Arch Linux.

Ich benutze keine Windows Version. Zotero für Firefox in Linux hat auch keinen Ikonen. Sie sehen aber schön aus.

orschiro commented on 2013-04-23 13:20

Is it the Linux Zotero build in general or just the Arch Linux build that does not have these nice context menu icons, which can be found in the Windows version?

http://imgur.com/Ufw8NUH

orschiro commented on 2013-03-12 21:21

FireTray Add-on now supports Zotero to be minimised to tray.

See the thread on Github for more information:

https://github.com/foudfou/FireTray/issues/85

This is the preferred solution for all of you who were looking for a possibility to minimise Zotero to the system tray.

juanmah commented on 2013-02-15 14:14

Thanks. A bit more elegant

Xyne commented on 2013-02-15 13:12

Here's a source tarball with an updated version of the PKGBUILD. It uses a proper package function, adds missing quotation marks around variables that need them, and makes the if/then/else logic clearer. Please use it.

http://xyne.archlinux.ca/tmp/pkgbuilds/zotero-3.0.13-1.src.tar.gz

orschiro commented on 2012-12-23 09:09

@juanmah,

Thank you! My comment was not meant to be a complaint. But you're right. I should have tried to fix it myself first.

Regards

juanmah commented on 2012-12-23 08:44

Fixed.

Orschiro: you should offer better first a fix for the issue, not a complain. If not possible, please, describe it better.

juanmah commented on 2012-12-23 08:31

Do you know how PKGBUILD works?

Look inside, you'll find answers.

Once installed, if you look installed files:

$ yaourt -Ql zotero

it shows:

zotero /usr/share/applications/zotero.desktop

orschiro commented on 2012-12-23 08:11

It seems that during installation with yaourt the .desktop file is not correctly placed in /usr/share/applications:

[orschiro@thinkpad applications]$ ls | grep zotero
lrwxrwxrwx 1 root root 50 22. Dez 23:27 zotero.desktop -> /tmp/yaourt-tmp-orschiro/aur-zotero/zotero.desktop

orschiro commented on 2012-12-23 08:09

To precise the problem. During installation a very strange symlink is created:

lrwxrwxrwx 1 root root 50 22. Dez 23:27 zotero.desktop -> /tmp/yaourt-tmp-orschiro/aur-zotero/zotero.desktop

orschiro commented on 2012-12-22 22:24

Could you please implement the zotero.desktop from here?

https://aur.archlinux.org/packages/zotero-git/

Yours does not appear in the cinnamon menu whilst the other one does.

orschiro commented on 2012-12-08 20:35

Can Zotero somehow be minimised to tray? Through the use of the browser connector I do not see any sense in having a permanent window opened.

I already asked in the Zotero forums [1] where I was told that this has to be done by each distribution package maintainer individually.

[1] http://forums.zotero.org/discussion/16568?page=1#Item_10

orschiro commented on 2012-12-08 11:11

Thank you juanmah!

juanmah commented on 2012-12-08 11:04

Done.

orschiro commented on 2012-12-07 06:25

This version does not have a .desktop file, correct?

So it can only be launched in terminal but not in the start menu.

iosonofabio commented on 2012-12-01 01:41

my fault, the error message was correct. Ouch!

juanmah commented on 2012-11-30 06:41

I can not reproduce that, sorry

iosonofabio commented on 2012-11-29 22:16

3.0.11 is broken for me, I get the following error

Error initializing Zotero database

The same problem from the Firefox extension, on a pristine clean profile.
any clues?

r0b0h0b0 commented on 2012-11-22 23:24

3.0.10 seems to install and work fine.

r0b0h0b0 commented on 2012-11-09 00:57

This version segfaults. zotero-git fails to export references.

Had to install firefox and use zotero as plugin.

r0b0h0b0 commented on 2012-11-09 00:56

This version segmfaults. The git version does not export references.

Anonymous comment on 2012-09-15 12:37

Not working for me, crashes with segfault. I have tried aur::zotero-git instead and works like a charm.

MadCat_X commented on 2012-08-17 20:30

The crash appears to be caused by XULrunner. Version 3.0.8 ships with XULrunner 13. If you build Zotero yourself from git, it downloads XULrunner 14.0.1 (as of today) which seems to work fine.

juanmah commented on 2012-08-02 16:41

I've been doing more tests and downgrading to glibc 2.15 solves the segmentation fault.

It can be found at http://arm.konnichi.com/core/os/x86_64/glibc-2.15-7-x86_64.pkg.tar.xz

juanmah commented on 2012-07-23 18:06

Could be glibc?

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7de68a3 in _dl_relocate_object () from /lib64/ld-linux-x86-64.so.2

/lib64/ld-linux-x86-64.so.2 is owned by glibc 2.16.0-2

[2012-07-06 03:25] upgraded glibc (2.15-12 -> 2.16.0-1)

boina commented on 2012-07-11 23:16

I got the segmentation fault issue as well. I tried downgrading dbus and dbus-core but the problem persisted. Also tried downgrading zotero itself to 3.07 but now it doesn't work. Any one knows how to solve this?
Thanks, jose.

boina commented on 2012-07-11 14:44

I got the segmentation fault issue as well. I tried downgrading dbus and dbus-core but the problem persisted. Any one knows how to solve this or install the previous zotero version?
Thanks, jose.

boina commented on 2012-07-11 14:44

I got the segmentation fault issue as well. I tried downgrading dbus and dbus-core but the problem persisted. Any one knows how to solve this?
Thanks, jose.

boina commented on 2012-07-11 14:41

I got the segmentation fault issue as well. I tried downgrading dbus and dbus-core but the problem persisted. Any one knows how to solve this?
Thanks, jose.

juanmah commented on 2012-07-06 15:44

I can confirm. I think it's a dbus issue

Jul 6 17:42:05 xxx dbus[427]: [system] Activating service name='org.freedesktop.NetworkManager' (using servicehelper)
Jul 6 17:42:05 xxx dbus[427]: [system] Activated service 'org.freedesktop.NetworkManager' failed: Launch helper exited with unknown return code 1

[2012-07-06 09:52] upgraded dbus-core (1.6.0-5 -> 1.6.2-2)
[2012-07-06 09:52] upgraded dbus (1.6.0-1 -> 1.6.2-1)

LWhitson2 commented on 2012-07-06 15:35

Anyone else having trouble with a segmentation fault all of a sudden. Everything was working great until today though.

allencch commented on 2012-07-05 04:05

Can you please change the line sed with this?
sed -i -e 's|MOZ_PROGRAM=""|MOZ_PROGRAM="/usr/lib/zotero/zotero"|g' $pkgdir/usr/lib/zotero/run-zotero.sh

Anonymous comment on 2012-05-09 07:06

I get a "database upgrade error" with 3.0.7-1. When I remove my ~/.zotero folder and start Zotero, I get a "database initialization error". before, everything was working fine. Any ideas?

juanmah commented on 2012-05-06 17:41

Changes in 3.0.7 (May 4, 2012)

* Bibliographic output and word processor integration fixes
* “this.base.givens[this.gnameset] is undefined”
* Don't fail if user cancels document preferences window that appears because a style doesn't exist
* Fixed some issues with corrupted field codes
* Updated citeproc-js to 1.0.329
* Fixed preferences window in Thai locale
* Show data directory properly on Linux
* Show “Search subcollections” instead of “Search subfolders” in Advanced Search
* Made various hard-coded strings localizable

Anonymous comment on 2012-04-30 08:59

There's 3.0.4 out.

juanmah commented on 2011-03-01 11:20

You are right. Bug fixed.

Thanks!

ngoonee commented on 2011-03-01 11:01

Your line 22 is wrong, the resulting link is not to the installed zotero but to the copy in your pkgdir (which is deleted if you makepkg -c)

Please use 'ln -s /usr/lib/zoter/run-zoter.sh $pkgdir/usr/bin/zotero' instead