Package Details: zrythm-git 2:4.13.31.r9.g472e168fc-1

Git Clone URL: https://aur.archlinux.org/zrythm-git.git (read-only, click to copy)
Package Base: zrythm-git
Description: a highly automated and intuitive digital audio workstation
Upstream URL: https://www.zrythm.org
Keywords: audio daw
Licenses: AGPL3
Conflicts: zrythm
Provides: zrythm
Submitter: alexteee
Maintainer: silverhikari
Last Packager: silverhikari
Votes: 6
Popularity: 0.000010
First Submitted: 2018-11-18 02:16 (UTC)
Last Updated: 2023-11-29 00:30 (UTC)

Dependencies (49)

Required by (0)

Sources (1)

Pinned Comments

lovetocode999 commented on 2021-05-07 02:50 (UTC)

Notice: The user manual has been removed from this package due to a build error, however it can still be accessed here: https://manual.zrythm.org/en/index.html

Latest Comments

1 2 3 4 5 6 Next › Last »

muzzle commented on 2023-02-20 03:22 (UTC) (edited on 2023-02-20 03:24 (UTC) by muzzle)

Run-time dependency zix-0 found: NO (tried pkgconfig and cmake)
Not looking for a fallback subproject for the dependency zix-0 because:
Use of fallback dependencies is disabled.

meson.build:1238:0: ERROR: Dependency 'zix-0' is required but not found.

Technetium1 commented on 2022-12-12 03:18 (UTC)

Missing sassc in makedepends to build in clean chroot.

tujir commented on 2022-12-06 17:02 (UTC)

Do I really need gtksourceview3 AND gtksourceview5?

blue commented on 2022-01-02 09:42 (UTC) (edited on 2022-01-03 01:04 (UTC) by blue)

@silverhikari Heads up: libadwaita 1.0.0 and gtk4 4.6.0 were just released on New Year's Eve. Thanks for maintaining this package.

silverhikari commented on 2021-12-13 07:56 (UTC)

@alexteee i have tried your suggestion by adding mv to the end of the package step though it seems to cause the package to fails as it acts if those files do not exist

alexteee commented on 2021-12-10 19:15 (UTC) (edited on 2021-12-10 19:38 (UTC) by alexteee)

@silverhikari also note that the current PKGBUILD will attempt to install any subprojects in /usr/lib so if you have libadwaita or gtk4 installed it will likely conflict with your system libs. in our own packages I will move those libs to /usr/lib/zrythm/. maybe a simple mv ${pkgdir}/usr/lib/*.so ${pkgdir}/usr/lib/zrythm/ will do (because /usr/bin/zrythm_launch prepends it to LD_LIBRARY_PATH) but I haven't tried this yet. this is just a temporary solution until gtk releases v4.6 and libadwaita makes a new release

silverhikari commented on 2021-12-10 18:58 (UTC)

@alexteee thanks for the heads up, added the fallback and remove and replaced gtk3 with gtk4

alexteee commented on 2021-12-09 12:50 (UTC)

we are now using unreleased libadwaita so until they release a new version you'd need to either install its git version or pass -Dforce_fallback_for=libadwaita to meson

Ota-Coder commented on 2021-12-09 06:35 (UTC)

Hi! I am now having this error in the new update:


[723/2043] Compiling C object src/libzrythm-lib.so.p/audio_exporter.c.o
FAILED: src/libzrythm-lib.so.p/audio_exporter.c.o 
cc -Isrc/libzrythm-lib.so.p -Isrc -I../src -I. -I.. -Iinc -I../inc -Iext -I../ext -Iext/midilib -I../ext/midilib -Iext/whereami -I../ext/whereami -Iext/zix -I../ext/zix -Iext/weakjack -I../ext/weakjack -I../inc/plugins/lv2 -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gtk -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gtk -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk/x11 -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk/x11 -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk -I../subprojects/libcyaml/include -Isubprojects/libaudec -I../subprojects/libaudec -Isubprojects/libaudec/inc -I../subprojects/libaudec/inc -I../subprojects/reproc/reproc/include -Isubprojects/reproc/__CMake_build -I../subprojects/reproc/__CMake_build -Isubprojects/reproc -I../subprojects/reproc -Isubprojects/gtksourceview5 -I../subprojects/gtksourceview5 -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gtk/css -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gsk -Isubprojects/gtksourceview5/gtksourceview -I/usr/include/libadwaita-1 -I/usr/include/gtk-4.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/lzo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/graphene-1.0 -I/usr/lib/graphene-1.0/include -I/usr/include/gio-unix-2.0 -I/usr/include/opus -I/usr/include/graphviz -I/usr/include/guile/2.2 -I/usr/include/carla -I/usr/include/carla/includes -I/usr/include/serd-0 -I/usr/include/sord-0 -I/usr/include/sratom-0 -I/usr/include/lilv-0 -I/usr/include/libxml2 -I/usr/include/json-glib-1.0 -flto=2 -fdiagnostics-color=always -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wextra -std=gnu11 -O2 -g -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_66 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_66 -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_4_6 -DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_4_6 -Wno-bad-function-cast -Wno-old-style-declaration -Werror=absolute-value -Wformat=2 -Wno-missing-field-initializers -Wno-unused-parameter -Wno-sequence-point -Wignored-qualifiers -Wno-cast-function-type -Walloca -fno-common -frecord-gcc-switches -ffast-math -fstrength-reduce -fdata-sections -ffunction-sections -freciprocal-math -fsingle-precision-constant -msse -msse2 -mfpmath=sse -mtune=generic -fno-omit-frame-pointer -Wformat -Werror=format-security '-DGETTEXT_PACKAGE="zrythm"' -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -fPIC -pthread -DREAL_BUILD -D_REENTRANT -mfpmath=sse -msse -msse2 -mfpmath=sse -msse -msse2 -Wformat=2 -Wno-missing-field-initializers -Wno-unused-parameter -Wno-sequence-point -Wignored-qualifiers -Wno-cast-function-type -Walloca -fno-common '-DLV2_UI__Gtk4UI="https://lv2plug.in/ns/extensions/ui#Gtk4UI"' -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED '-D__(x)=x' -DG_LOG_USE_STRUCTURED=1 '-DG_LOG_DOMAIN="zrythm"' '-DDEPRECATED_MSG(x)=__attribute__((deprecated(x)))' '-DNONNULL_ARGS(...)=__attribute__((nonnull(__VA_ARGS__)))' '-DACCESS(...)=__attribute__((access(__VA_ARGS__)))' '-DACCESS_READ_ONLY(...)=ACCESS(read_only,__VA_ARGS__)' -frecord-gcc-switches '-DALWAYS_INLINE=__attribute__((always_inline))' '-DCOLD=__attribute__((cold))' '-DHOT=__attribute__((hot))' '-DPURE=__attribute__((pure))' '-DNONNULL=__attribute__((nonnull))' '-DRETURNS_NONNULL=__attribute__((returns_nonnull))' '-DSTACK_PROTECT=__attribute__((stack_protect))' '-DNO_STACK_PROTECTOR=__attribute__((no_stack_protector))' '-DWARN_UNUSED_RESULT=__attribute__((warn_unused_result))' '-DCONST=__attribute__((const))' '-DMALLOC=__attribute__((malloc))' -DREALTIME= -ffast-math -fstrength-reduce -DPIC -fdata-sections -ffunction-sections -freciprocal-math -fsingle-precision-constant -msse -msse2 -mfpmath=sse -mtune=generic -fno-omit-frame-pointer -Wformat -Werror=format-security -MD -MQ src/libzrythm-lib.so.p/audio_exporter.c.o -MF src/libzrythm-lib.so.p/audio_exporter.c.o.d -o src/libzrythm-lib.so.p/audio_exporter.c.o -c ../src/audio/exporter.c
In file included from ../src/audio/exporter.c:38:
../inc/gui/widgets/main_window.h:74:3: error: unknown type name ‘AdwToastOverlay’
   74 |   AdwToastOverlay *        toast_overlay;
      |   ^~~~~~~~~~~~~~~
[728/2043] Compiling C object src/libzrythm-lib.so.p/gui_backend_clip_editor.c.o
FAILED: src/libzrythm-lib.so.p/gui_backend_clip_editor.c.o 
cc -Isrc/libzrythm-lib.so.p -Isrc -I../src -I. -I.. -Iinc -I../inc -Iext -I../ext -Iext/midilib -I../ext/midilib -Iext/whereami -I../ext/whereami -Iext/zix -I../ext/zix -Iext/weakjack -I../ext/weakjack -I../inc/plugins/lv2 -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gtk -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gtk -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk/x11 -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk/x11 -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk -I../subprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gdk -I../subprojects/libcyaml/include -Isubprojects/libaudec -I../subprojects/libaudec -Isubprojects/libaudec/inc -I../subprojects/libaudec/inc -I../subprojects/reproc/reproc/include -Isubprojects/reproc/__CMake_build -I../subprojects/reproc/__CMake_build -Isubprojects/reproc -I../subprojects/reproc -Isubprojects/gtksourceview5 -I../subprojects/gtksourceview5 -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gtk/css -Isubprojects/gtk-12bb700c620c8a9a29947314ab35d0f2a22d795c/gsk -Isubprojects/gtksourceview5/gtksourceview -I/usr/include/libadwaita-1 -I/usr/include/gtk-4.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/lzo -I/usr/include/pixman-1 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/graphene-1.0 -I/usr/lib/graphene-1.0/include -I/usr/include/gio-unix-2.0 -I/usr/include/opus -I/usr/include/graphviz -I/usr/include/guile/2.2 -I/usr/include/carla -I/usr/include/carla/includes -I/usr/include/serd-0 -I/usr/include/sord-0 -I/usr/include/sratom-0 -I/usr/include/lilv-0 -I/usr/include/libxml2 -I/usr/include/json-glib-1.0 -flto=2 -fdiagnostics-color=always -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wextra -std=gnu11 -O2 -g -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_66 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_66 -DGDK_VERSION_MIN_REQUIRED=GDK_VERSION_4_6 -DGDK_VERSION_MAX_ALLOWED=GDK_VERSION_4_6 -Wno-bad-function-cast -Wno-old-style-declaration -Werror=absolute-value -Wformat=2 -Wno-missing-field-initializers -Wno-unused-parameter -Wno-sequence-point -Wignored-qualifiers -Wno-cast-function-type -Walloca -fno-common -frecord-gcc-switches -ffast-math -fstrength-reduce -fdata-sections -ffunction-sections -freciprocal-math -fsingle-precision-constant -msse -msse2 -mfpmath=sse -mtune=generic -fno-omit-frame-pointer -Wformat -Werror=format-security '-DGETTEXT_PACKAGE="zrythm"' -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2 -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -fPIC -pthread -DREAL_BUILD -D_REENTRANT -mfpmath=sse -msse -msse2 -mfpmath=sse -msse -msse2 -Wformat=2 -Wno-missing-field-initializers -Wno-unused-parameter -Wno-sequence-point -Wignored-qualifiers -Wno-cast-function-type -Walloca -fno-common '-DLV2_UI__Gtk4UI="https://lv2plug.in/ns/extensions/ui#Gtk4UI"' -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED '-D__(x)=x' -DG_LOG_USE_STRUCTURED=1 '-DG_LOG_DOMAIN="zrythm"' '-DDEPRECATED_MSG(x)=__attribute__((deprecated(x)))' '-DNONNULL_ARGS(...)=__attribute__((nonnull(__VA_ARGS__)))' '-DACCESS(...)=__attribute__((access(__VA_ARGS__)))' '-DACCESS_READ_ONLY(...)=ACCESS(read_only,__VA_ARGS__)' -frecord-gcc-switches '-DALWAYS_INLINE=__attribute__((always_inline))' '-DCOLD=__attribute__((cold))' '-DHOT=__attribute__((hot))' '-DPURE=__attribute__((pure))' '-DNONNULL=__attribute__((nonnull))' '-DRETURNS_NONNULL=__attribute__((returns_nonnull))' '-DSTACK_PROTECT=__attribute__((stack_protect))' '-DNO_STACK_PROTECTOR=__attribute__((no_stack_protector))' '-DWARN_UNUSED_RESULT=__attribute__((warn_unused_result))' '-DCONST=__attribute__((const))' '-DMALLOC=__attribute__((malloc))' -DREALTIME= -ffast-math -fstrength-reduce -DPIC -fdata-sections -ffunction-sections -freciprocal-math -fsingle-precision-constant -msse -msse2 -mfpmath=sse -mtune=generic -fno-omit-frame-pointer -Wformat -Werror=format-security -MD -MQ src/libzrythm-lib.so.p/gui_backend_clip_editor.c.o -MF src/libzrythm-lib.so.p/gui_backend_clip_editor.c.o.d -o src/libzrythm-lib.so.p/gui_backend_clip_editor.c.o -c ../src/gui/backend/clip_editor.c
In file included from ../src/gui/backend/clip_editor.c:41:
../inc/gui/widgets/main_window.h:74:3: error: unknown type name ‘AdwToastOverlay’
   74 |   AdwToastOverlay *        toast_overlay;
      |   ^~~~~~~~~~~~~~~
[732/2043] Linking target subprojects/libsass/src/libsass.so
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
 -> error making: zrythm-git