Package Details: zsh-git 5.2.r72.ga8a00be-1

Git Clone URL: https://aur.archlinux.org/zsh-git.git (read-only)
Package Base: zsh-git
Description: A very advanced and programmable command interpreter (shell) for UNIX
Upstream URL: http://www.zsh.org/
Licenses: custom
Conflicts: zsh
Provides: zsh=5.2
Submitter: esodax
Maintainer: eworm
Last Packager: eworm
Votes: 10
Popularity: 0.046641
First Submitted: 2010-06-17 02:00
Last Updated: 2016-01-13 08:47

Dependencies (10)

Required by (62)

Sources (2)

Latest Comments

xaocon commented on 2013-11-12 20:40

Versioning doesn't work right now. They added a tag that has dashes in it. I'm switching to:

echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"

https://github.com/xaocon/zsh-git/

xaocon commented on 2013-11-12 20:27

Versioning doesn't work right now. They added a tag that has dashes in it. I'm switching to:

return "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"

https://github.com/xaocon/zsh-git/

xaocon commented on 2013-11-12 20:26

Versioning doesn't work right now. They added a tag that has dashes in it. I'm switching to:

pkgver(){
cd "${pkgname}"
return "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}

xaocon commented on 2013-11-05 19:32

Here's a patch to clean up the build time fpath settings. http://ix.io/8UY

It's probably fine to remove the sed for init.d to rc.d as we don't have either now and in at least one case it's become redundant anyways.

Thanks for keeping up with this great package.

buhman commented on 2013-06-09 19:08

bindir should be /usr/bin

xaocon commented on 2013-05-01 18:46

Hey gtmanfred,
The GIT URL line should be changed to:
"$_pkgname::git://git.code.sf.net/p/$_pkgname/code")
I'll go ahead and mark this out of date as well to grab your attention. It won't build without it (or it won't for me).

esodax commented on 2012-02-19 14:04

Probably not, I fixed that.
Thanks.

quite commented on 2012-02-15 16:20

zsh.install:
/bin/grep -> /usr/bin/grep
But do you need to be that specific anyway?