Package Details: zsh-syntax-highlighting-git 0.4.0.r167.gfdaeec4-1

Git Clone URL: https://aur.archlinux.org/zsh-syntax-highlighting-git.git (read-only)
Package Base: zsh-syntax-highlighting-git
Description: Fish shell like syntax highlighting for Zsh
Upstream URL: https://github.com/zsh-users/zsh-syntax-highlighting
Keywords: shell terminal
Licenses: custom
Conflicts: zsh-syntax-highlighting
Provides: zsh-syntax-highlighting
Submitter: mjheagle8
Maintainer: HalosGhost
Last Packager: HalosGhost
Votes: 47
Popularity: 1.087870
First Submitted: 2011-07-20 21:38
Last Updated: 2016-09-20 12:37

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

HalosGhost commented on 2016-09-20 12:37

ams1,

Good catch! I have updated the .install file!

All the best,

ams1 commented on 2016-09-20 10:08

This just bit me again. The .install message needs to be updated to match the true install location.

HalosGhost commented on 2015-12-17 04:22

ams1,

Actually, it seems that upstream intentionally changed the install location to /usr/share, so that is where I will be leaving it.

All the best,

HalosGhost commented on 2015-12-16 14:44

ams1,

Ahh yes. That would be because upstream's Makefile does not specify the full install path. That is okay though because I just realized the version I have marked currently is quite wrong. So I will update the pkgver() function and the package() function tonight.

ams1 commented on 2015-12-16 11:08

The install location just jumped from /usr/share/zsh/plugins to /usr/share.

Is that deliberate?

HalosGhost commented on 2015-11-22 21:07

OrdinaryMagician,

Thanks for the heads-up! It seems upstream has added a nice-and-simple `make install` rule to make our lives simpler. I have updated the package to utilize it so you should have everything upstream provides officially now.

All the best,

OrdinaryMagician commented on 2015-11-22 21:02

The .version and .revision-hash files are missing.

HalosGhost commented on 2015-08-31 21:52

stef204, nice! I had no idea that had made it into [community]. The PKGBUILD has been updated. Thanks for the note.

stef204 commented on 2015-08-31 18:17

Hi,
can you please add
conflicts=('zsh-syntax-highlighting')
to the PKGBUILD?
there is an official package in Community.
Thanks.

HalosGhost commented on 2014-06-27 04:42

It's funny. I've had that in my local copy for ages. Don't know how I forgot to upload the fix. The package has been updated. Thanks for the note.

All the best,

fanglingsu commented on 2014-06-26 19:09

The path to the plugin file in zsh-syntax-highlighting.install is wrong:
/usr/share/zsh/plugins/zsh-syntax-highlight/zsh-syntax-highlighting.zsh should be replaced by
/usr/share/zsh/plugins/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh

HalosGhost commented on 2013-10-06 23:41

Updated for modern VCS guidelines.

All the best,

HalosGhost commented on 2013-09-22 21:44

This package is rather out of date for VCS guidelines. I have an updated package ready to upload if you do not wish to maintain it anymore. If that is the case, please orphan it, if not, please update the package for the latest practices.

All the best,

msx commented on 2013-01-30 13:50

@mjheagle8
Tnx for packaging this nice extension.
However please check your PKGBUILD, I think the correct GIT url is: https://github.com/zsh-users/zsh-syntax-highlighting.git

mjheagle8 commented on 2011-10-11 16:49

thanks, i did not realize that! the package is now fixed.
that explains why it hasnt been updated in a while :P

nicoulaj commented on 2011-10-02 14:19

Hi, it points to an obsolete fork and not the original repository, which is at https://github.com/zsh-users/zsh-syntax-highlighting.