Package Details: zukitwo-themes 20141022-1

Git Clone URL: https://aur.archlinux.org/zukitwo-themes.git (read-only)
Package Base: zukitwo-themes
Description: A theme for GTK3, GTK2, Metacity, xfwm4, Gnome Shell and Unity.
Upstream URL: http://gnome-look.org/content/show.php/Zukitwo?content=140562
Licenses: GPL3
Submitter: grimi
Maintainer: OmeGa
Last Packager: OmeGa
Votes: 478
Popularity: 6.798111
First Submitted: 2011-05-27 15:24
Last Updated: 2015-07-08 07:33

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

60p0ga commented on 2014-10-22 13:58

Maybe new sha1sums is 6e8896148b185b411be387972f40fda03b60844e ?

Spike29 commented on 2014-10-18 11:11

Also, I think the gnome-shell theme used to be on $srcdir/Zukitwo directory, but it's now on $src/ZukiShell.

Spike29 commented on 2014-10-18 10:18

Hello, a new release with GTK+ 3.14 support is available :)

New sha1sums is 9b9b931fee9e6852541607b7bb24fe2152d760df

Spike29 commented on 2014-10-18 10:15

Hello, a new release with GTK+ 3.14 support is available :)

orschiro commented on 2014-06-03 21:27

@mrueegg

Does that error occur with all GTK applications?

mrueegg commented on 2014-06-03 21:27

Gtk2. Gtk3 is okay. Thanks for your suggestion, but lib32-gtk-engine-murrine forces me to install the whole multilib chain (e.g., gcc-libs-multilib). Do you know any other possibility to get rid of these warnings?

carstene1ns commented on 2014-06-03 18:31

@mrueegg: Gtk2 or gtk3 applications? Murrine is a AFAIK a gtk2 engine. When you use Arch64 you may need 'lib32-gtk-engine-murrine' for 32 bit applications as well.

mrueegg commented on 2014-06-03 14:59

When I use this package, I always get the following annoying GTK warning when starting GTK applications:

Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine"

Note that I have the mentioned murrine GTK engine installed:

$ pacman -Ss murrine
community/gtk-engine-murrine 0.98.2-1 [installed]

Here is my gtkrc file:

gtk-theme-name = "Zukitwo"
gtk-icon-theme-name = "Faenza-Dark"

Any ideas? Thanks.

orschiro commented on 2014-05-10 07:16

@kainonergon

Thanks for the workaround. However, as carstene1ns already reported, with the new gtk3 3.12 version, the issue has gone.

kainonergon commented on 2014-05-09 20:07

@orschiro
I had strange borderline around tabs too. I found a workaround. Open file /usr/share/themes/Zukitwo/gtk-3.0/gtk-widgets.css for editing. Find section "Notebooks and tabs" and add line "engine: none;" into the first entry (after line ".notebook {").

carstene1ns commented on 2014-04-18 15:35

With the new gtk3 version all looks okay now.
http://p.f4ke.de/p6Mv6pyQMH.png

3ED_0 commented on 2014-04-16 16:19

Same as with zukiwi. There is a launchpad repository with this same version. You can download tarball for individual release. eg:

pkgver=20140415_gnome3.12_r28
source=($pkgname-$pkgver.tar.gz::http://bazaar.launchpad.net/~lassekongo83/zukitwo/gnome3.12/tarball/28)

Ps. or revision 27 for 20140413

carstene1ns commented on 2014-04-05 16:49

I guess we should wait until gnome gets updated to 3.12 in the Arch repositories, it is currently in testing/gnome-unstable. The author said it is not supposed to work with older versions (see also comment below). I am using the old version for now.

orschiro commented on 2014-04-05 06:20

@carstene1ns

Is there any way to let the developer know about this so that it can be fixed?

carstene1ns commented on 2014-04-05 02:36

yes, i have the same after updating to latest version.

orschiro commented on 2014-04-04 21:18

Does someone else have a strange borderline around tabs?

Example pavucontrol: http://i.imgur.com/5HJwILo.png

Example spacefm: http://i.imgur.com/G8WMtRU.png

Regulus commented on 2014-04-01 14:09

2014.03.29
- Updated to work with Gnome 3.12.
Note: Don't upgrade if you're still using an earlier version of Gnome.
You can grab earlier versions here: https://launchpad.net/zukitwo/+series

Chazza commented on 2013-12-10 15:27

as of 10 Dec 2013 the sha1 is:

abc5f8ff9ec654fa804f11528291a2982881bdab

Chazza commented on 2013-12-10 15:26

as of 12 Dec 2013 the sha1 is:

abc5f8ff9ec654fa804f11528291a2982881bdab

x33a commented on 2013-12-02 09:44

Can anyone tell me the best way to edit a theme. I need to make the following small change in the theme:

base[ACTIVE]= shade (0.80, @selected_bg_color)

Now, is there a way to make this change in $HOME/.gtkrc-2.0, or do I need to make the change in /usr/share/themes/Zukitwo/gtk-2.0/gtkrc itself.

yuryrodrigues commented on 2013-10-13 13:23

the sha1sum of the package is wrong.
As of today 12/10/2013 12:34 password that works is this:

7b7ff37c5f611ba367579f835b9bfcfbd10d11bd

orschiro commented on 2013-08-22 21:52

Quick question to Chrome/Chromium users.

Do your buttons look the same way: http://i.imgur.com/4uGES67.png

I perceive them to look a bit odd as compared to the overall theme.

Jristz commented on 2013-04-08 15:40

actually gtk 3.8 is in staging because many rebuilds is needed and many drops to aur too

OmeGa commented on 2013-03-29 20:48

@frosth: yes, that's true, but Zack commented about this problem almost a month ago, that means he was using a version designed for Gnome 3.6. But I agree, Gnome users _might_ now experience issues, and should wait for 3.8.

frosth commented on 2013-03-29 20:26

Author this theme wrote:
"Important note: This theme is designed for Gnome 3.8. May or may not work with other versions of Gnome-shell and GTK."

It's not a bug. You must wait for upgrade gnome to 3.8 in extra repository.

frosth commented on 2013-03-29 20:25

Author this theme wrote:
"Important note: This theme is designed for Gnome 3.8. May or may not work with other versions of Gnome-shell and GTK."

so you must wait for upgrade gnome to 3.8 in extra repository.

OmeGa commented on 2013-03-29 19:54

@Zack: that's odd. I don't use Gnome, however, so I can't reproduce it. Could you try updating to the latest version? And if the bug persists, would you mind reporting it upstream?

Anonymous comment on 2013-03-01 08:30

This theme breaks gnome notifications. Messages are not displaying at all, only icons and notification bar at bottom suffers distortions.
Gnome 3.6.

defking commented on 2013-02-07 17:00

@scorici thank you! That worked!

scorici commented on 2013-02-07 16:51

sha1sums=('808a1313f5b1d7e51d6c5ebdfab78cb1798c1bec')

grimi commented on 2013-01-02 19:28

@SanskritFritz: done, thanks.

SanskritFritz commented on 2013-01-02 19:15

Changelog says
"2012.12.11 - Shell theme: Some fixes and default font changed from Liberation to Droid. (Make sure to include ttf-droid to the depends if you're maintaining a package of this.)"
Please include ttf-droid as optional dependency.

alucryd commented on 2012-12-11 13:22

Zip file seems to have changed, failed to pass check.

grimi commented on 2012-12-09 14:24

Theme author, leave out support for zukitwo-dark (changelog on a gnome-look from 01.12.2012).

Ragnis commented on 2012-12-08 22:19

Zukitwo-Dark seems to have disappeared. Was this intentional?

epinephrine commented on 2012-12-04 18:52

awesome, notify notifications work again :)

Anonymous comment on 2012-12-04 16:19

md5sum of zukitwo-themes-20121202.zip is wrong

TrialnError commented on 2012-12-03 22:05

Must have overlooked this. Hm, well. I had no issues without gnome-themes-standard so far, but I will look what changes if I install this package

grimi commented on 2012-12-03 18:22

gtk3: gtk-widgets.css uses adwaita engine (provided by gnome-themes-standard).

TrialnError commented on 2012-12-03 18:14

Why the need for gnome-themes-standard?
The requirements only mention gtk-engines and gtk-engine-murrine

Anonymous comment on 2012-12-02 21:52

in gnome-shell can't see switch icon. nothing in wireless or bluetooth... anything.... before this update all works correctly....

grimi commented on 2012-12-01 22:03

Please use this package (this one will be deleted):
https://aur.archlinux.org/packages/gtk-theme-zukitwo/

grimi commented on 2012-11-13 21:13

Hi, theme is compatible with gtk3/gnome 3.4, hence error message.
Until theme it is not updated, I suggest use some others themes.
Maybe this (they are 3.6 compatible):
https://aur.archlinux.org/packages/gtk-theme-clearbird/
https://aur.archlinux.org/packages/mediterraneannight-theme/

rata commented on 2012-11-13 17:29

Hi, I'm getting a lot of these warnings when starting a Gtk+3 app
Gtk-WARNING **: Theme parsing error: gtk-widgets.css:85:17: Not using units is deprecated. Assuming 'px'.
Do you know any workaround to get rid of them?

JohnnyDeacon commented on 2012-11-05 04:25

this package was updated.

Changelog:
01. Nov 2012 - v0.5.1
added compatibility for GNOME Shell 3.6

TrialnError commented on 2012-11-01 18:20

Ignore my previous post.
I missed, that the repo engine-unico provides the bzr version

TrialnError commented on 2012-11-01 18:03

Just as a note.
If someone had issues with the theme after gnome3.6 got into [extra] you can try gtk-engine-unico-bzr.
With this engine-unico version it seems to be working again
Using it you need to remove the explicit version number

grimi commented on 2012-10-09 04:53

Hi, you building wrong version current is 20120817...

robvelor commented on 2012-10-08 21:09

==> Validating source files with md5sums...
zukitwo-themes-20120702.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
The build failed.

abraxas commented on 2012-09-07 09:49

android_808: i had the same problem, xfce4-panel looked like a mess. deleting that line in the PKGBUILD solved the issue.

grimi commented on 2012-09-07 04:35

I didn't notice any mess. Sed only changes Xfce panel display profiles (from default to more simple),
to get more readable view (at least for me). If you don't like this, or you using panel-bg.png from theme,
please comment the line with sed...

android_808 commented on 2012-09-06 20:31

In the latest build, what bug is supposed to be fixed with the sed command? It has messed up the rendering of the window buttons, font colours and applet backgrounds during hover.

Please see:
http://customizemania.com/daily-mania-zukitwo-xfce/#comment-30

grimi commented on 2012-08-24 08:19

Done. I, think now xfce panel is more readable.

scjet commented on 2012-07-09 05:17

Thankyou, ..."zukitwo-themes-20120708.zip" installs fine now.
:)

scjet commented on 2012-07-09 04:42

-> Found zukitwo-themes-20120702.zip
==> Validating source files with md5sums...
zukitwo-themes-20120702.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
The build failed.
Also,
zukitwo-colors FAILS as well ?

grimi commented on 2012-06-13 06:15

Yep. Just check on home site changelog...

Anonymous comment on 2012-06-13 05:46

This theme seems to get an update several times a week. Is development really that active on it?

grimi commented on 2012-05-29 05:30

Nothing is missing. To build packages from AUR, 'base-devel' group is needed as minimum.
Just type: sudo pacman -S --needed base-devel .

cemsbr commented on 2012-05-28 19:10

Maybe there is a missing dependency:
ERROR: Cannot find the strip binary required for object file stripping.

Anonymous comment on 2012-05-23 12:22

Zukitwo 2012.05.23 Updated

grimi commented on 2012-05-12 16:15

Good idea. I'll do the changes in PKGBUILD at next release. Thanks...

Anonymous comment on 2012-05-12 13:06

The downloaded zipfile is un-versioned. If you have a set sources directory, the downloaded zipfile remains and so new versions do not get downloaded and there are md5sum mismatches etc.

If you change the sources file to the one below, each version will be saved with as ${pkgname}-${pkgver}.zip, ie a unique name.

source=(${pkgname}-${pkgver}.zip::http://gnome-look.org/CONTENT/content-files/140562-Zukitwo.zip)

Mr Green commented on 2012-05-11 15:38

Checksum error

I have 7af465905843ae60b80d1057bb6383ac for md5sum someone confirm?

Wompatti commented on 2012-05-09 18:55

Could you edit the dependencies so it would pass also with gtk-engine-murrine-git? Now I always have to edit the PKGBUILD before upgrading.

Nobus commented on 2012-05-03 15:20

I wish that theme was GNOME3's default!

dvzrv commented on 2012-04-26 13:42

"22af26eb326f25c15dc88f3ca2403df5" <- new md5sum

Speed commented on 2012-04-24 13:02

An update, I couldn't wait for the maintainer to do it. Updated the version to 20122024, the md5sum and set the version of the gtk-engine-unico dependency to 1.0.2 (as the official release says). It works, however the official release states to update only if you use Gnome 3.4 and NOT Gnome 3.2. (http://pastebin.com/0nAsKG4w)

proft commented on 2012-04-24 11:17

Theme is updated, please update package.

Ulukai commented on 2012-04-24 09:20

@ hadrons123: indeed, I have the same issue with GNome 3.4 and Unico 1.0.2, but this theme is designed for Gnome 3.2 and Unico 1.0.1. The theme will need to be updated, there is nothing wrong with the package. Please contact the creator of the theme.

hadrons123 commented on 2012-04-24 04:07

Gtk + theme is whitened out for gnome 3.4

grimi commented on 2012-03-30 14:16

No problem here. That could be problem of your isp, .curlc, or maybe is aur wrapper.

Synthead commented on 2012-03-30 12:48

curl: (6) Could not resolve host: gnome-look.org; Unknown error

dvzrv commented on 2012-01-04 18:03

Alrite... I think I solved the issue. It was indeed yaourt related: https://bbs.archlinux.org/viewtopic.php?pid=1036308#p1036308

grimi commented on 2012-01-03 15:33

Again I've checked m5sum of 140562-Zukitwo.zip,
and it's correct ('fa60f411c47e87b796ede6ec999cc325').
I suggest don't use yaourt ,just download tarball,
extract and do makepkg cmd.
Regards.
P.S. zip file size is : 563616 bytes.

dvzrv commented on 2012-01-03 14:18

Very strange... yaourt seems to be downloading another source file or manipulating the original one (and by that changing its hash).
I'm having the same issue with cacheclean (https://aur.archlinux.org/packages.php?ID=37572)
Maybe yaourt related?

hadrons123 commented on 2012-01-03 06:36

grimi,your md5sums is wrong.

the package builds sucessfully by editing the md5sum

'fa60f411c47e87b796ede6ec999cc325'

in the PKGBUILD as sugeested by others.

hadrons123 commented on 2012-01-03 06:31

its failing to build.see the terminal output below:

==> Making package: zukitwo-themes 20111229-1 (Tue Jan 3 11:58:05 IST 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found 140562-Zukitwo.zip
==> Validating source files with md5sums...
140562-Zukitwo.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build zukitwo-themes.
==> Restart building zukitwo-themes ? [y/N]
==> ---------------------------------------
==>
i tried for 10 times in the last 7 days.it doesnt work.

grimi commented on 2012-01-02 19:35

No, it's : fa60f411c47e87b796ede6ec999cc325 (like in PKGBUILD).
Please, check your download.

dvzrv commented on 2012-01-02 18:31

9c311a180617d7058bbf4b5befc39de4 -> 140562-Zukitwo.zip

Shark commented on 2011-12-08 20:33

Hi

Thanks, worked like a charm :)

grimi commented on 2011-12-08 20:13

Hi, the key is the "murrine-statusbar" in Zukitwo*/gtk-2.0/gtkrc.
Just change it or comment. Regards.

Shark commented on 2011-12-08 19:11

Why is in thunar file manager so small text in a bottom left corner where info about files/folders is?

Anonymous comment on 2011-12-05 16:30

[coirius@barracuda]$ md5sum 140562-Zukitwo.zip
9c311a180617d7058bbf4b5befc39de4 140562-Zukitwo.zip

Anonymous comment on 2011-12-05 16:18

==> Validating source files with md5sums...
140562-Zukitwo.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!

android_808 commented on 2011-11-12 22:08

Doesn't seem to include the emerald theme.

Anonymous comment on 2011-10-10 21:55

@grimi: Wow, I didn't expect a theme would get refreshed that often. Thanks for your work.

Anonymous comment on 2011-10-10 17:11

@grimi: Thank you for updating the package so often! People sometimes forget that you sacrifice your spare time to update packages. And by the way: I think everyone should be able to fix small "problems" like wrong MD5 checksums themselves.

grimi commented on 2011-10-10 16:14

I have couple words to impatient aur users:
1. Please check the home url of zukitwo, and you will see: updating of package is every day (hence md5sum problems)
2. I always do deletion old binary file (4x. *.zip), before makepkg --source
3. And updates my packages in aur I do it about 6pm (gmt+1).
So ... Be patient.

Malaheenee commented on 2011-10-10 14:47

MD5: 4870c2d175aac7817918ff48dce7fbf2 http://gnome-look.org/CONTENT/content-files/140562-Zukitwo.zip. Simply replace this in the .PKGBUILD and continue.

Anonymous comment on 2011-10-10 12:47

@lolwtf: If you use packer, you can also append the option --skipinteg to skip the md5sum check.
@grimi: the md5sum still isn't correct. Try to clear all files in your abs directory (except for the PKGBUILD) before you create the md5sum.

Lynx commented on 2011-10-09 09:08

2011.10.09
- Shell theme: A couple of aesthetic improvements and some bug fixes.
- GTK3: A couple of aesthetic improvements and some bug fixes.
- Metacity: Reduced the bottom border size to 1px.

Anonymous comment on 2011-10-09 08:01

press "y" to edit PKGBUILD.
Find the line with the MD5SUM and replace with this:
34673574fff96affc34b18d89fe2bd63
ctrl-x and save then continue installing.

xyproto commented on 2011-10-07 14:13

Hi, the md5 sum check fails.

grimi commented on 2011-10-01 16:32

Hi,
1. in unico PKGBUILD it's forced revision 69 (needed revision I think 120)
2. higher than 69 unico revision depends on gtk 3.1.6 or higher (needed gtk3 from testing).

eldermarco commented on 2011-10-01 16:24

Hi,

There's a problem with this theme. I don't know why, but Arch can't load Zukitwo after the update.

* gtk-engine-unico - 122-1 (from bzr)
* zukitwo-themes - 20111101
* gtk-engine-murrine - 0.98.1.1

eldermarco commented on 2011-10-01 16:18

Hi,

There's a problem with this theme. I don't know why, but Arch can't load Zukitwo after the update.

* gtk-engine-unico - 122-1
* zukitwo-themes - 20111101
* gtk-engine-murrine - 0.98.1.1

Anonymous comment on 2011-09-12 14:53

wanderful theme thanks grimi!!!

grimi commented on 2011-08-05 18:12

Hi, check this:
grep -r unico /usr/share/themes/Zukitwo*

lxyd commented on 2011-08-05 15:59

Hi, grimi!
What is gtk-engine-unico required for?
I built this without unico and gtk3 looks just fine with murrine only, so I would consider moving unico to optional depends.
Sorry if I'm wrong

Anonymous comment on 2011-07-22 13:24

2011.07.22
- GTK3: Some minor fixes and cleanup.
- GTK3: Reduced the treeview expander size to 4 from 8.
- INSTALL file: Added instructions for Ubuntu Unity users and their special case panel.

tommis commented on 2011-07-21 09:10

Validating packages fails... I guess you haven't updated the md5sum.

==> Making package: zukitwo-themes 20110719-1 (Thu Jul 21 12:06:53 EEST 2011)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found 140562-Zukitwo.zip
==> Validating source files with md5sums...
140562-Zukitwo.zip ... FAILED

grimi commented on 2011-07-19 17:41

This release is compatible with unico revision 70 and higher...

Anonymous comment on 2011-06-23 20:01

Thanks. That works fine.

grimi commented on 2011-06-23 15:28

It's only has occured, if You install unico revision 70 with gtk 3.0.* (trick metod with sed).
Simply install revision 69 (as I posted below), and background be looked as is should.

grimi commented on 2011-06-23 15:24

It's only has occured, if You install unico revision 70 with gtk 3.0.* (trick metod with sed).
Simply install revision 69 (as I posted below), and background be looked as is should.

Anonymous comment on 2011-06-23 14:49

In the Jun23 version, pink background shows up in gtk-3 applications like nautilus, which is a little bit strange.

Anonymous comment on 2011-06-23 10:22

MD5SUM-check fails on the latest zip-archive from gnome-look.org. Maybe the package has been updated?

Anonymous comment on 2011-06-22 19:03

Thanks
It's ok

grimi commented on 2011-06-22 18:45

At revision 70 unico require gtk 3.1.6...
Solution: setup cmdline of bzr to force pick up revision 69 (only gtk 3.0.* needed).
How? Modify line 21 of unico PKGBUILD to: bzr co ${_bzrtrunk} -r 69

Anonymous comment on 2011-06-22 16:58

Compilation de gtk-engine-unico :

configure: error: Package requirements (glib-2.0 >= 2.26.0 gtk+-3.0 >= 3.1.6 cairo >= 1.10) were not met:

Requested 'gtk+-3.0 >= 3.1.6' but version of GTK+ is 3.0.11

???

rickdesantis commented on 2011-06-22 13:06

The author has just updated the theme.
Changes to make the PKGBUILD work with this last update:

pkgver=2011.06.22
...
depends=('gtk-engine-unico')
...
md5sums=('1df4dd200863bb1b5ac7888e6b5ec417')

it worked for me :)
(btw, gtk-engine-murrine and gtk-engines should be dependencies and not optional dependencies: no gtk2 application will look good without those two packages :\ )

nDray commented on 2011-06-10 14:46

You should add, like the author suggests, the ('gtk-engine-murrine' 'gtk-engines') depends!

grimi commented on 2011-06-02 05:01

The author of this theme, update it quite often, sometimes three times a day.
Hence, discrepancies in md5sum.

arriagga commented on 2011-06-01 11:49

please check the md5sum:

Validando el archivo fuente con md5sums...
140562-Zukitwo.zip ... FALLÓ

valr commented on 2011-05-29 06:17

Strange, don't know what happenned, it's ok indeed. Sorry for that.

valr commented on 2011-05-29 06:16

Strange, don't know what happenned, it's ok indeeded. Sorry for that.

grimi commented on 2011-05-28 18:30

That's not true. Check the downloaded archive.

valr commented on 2011-05-28 15:06

Invalid md5sum on 140562-Zukitwo.zip