Package Details: zwave-js-ui 1:9.10.2-1

Git Clone URL: https://aur.archlinux.org/zwave-js-ui.git (read-only, click to copy)
Package Base: zwave-js-ui
Description: Full featured Z-Wave Control Panel UI and MQTT gateway
Upstream URL: https://github.com/zwave-js/zwave-js-ui
Keywords: mqtt ui zwave zwavejs
Licenses: MIT
Replaces: zwavejs2mqtt
Submitter: anonfunc
Maintainer: billyburly
Last Packager: billyburly
Votes: 1
Popularity: 0.000474
First Submitted: 2022-10-01 08:12 (UTC)
Last Updated: 2024-04-06 04:26 (UTC)

Latest Comments

1 2 Next › Last »

zynex commented on 2024-05-03 12:16 (UTC)

Found a fix that included --ignore-engines to yarn install. Worked :)

kzd commented on 2024-05-02 01:41 (UTC)

@zynex You'll want to install "nodejs-lts-iron - For 20.X version" from the arch repos and replace the normal nodejs install. This package should probably be modified to depend on nodejs-lts-iron or nodejs-lts-hydrogen rather than nodejs. Both lts packages provide nodejs so they should properly satisfy the package as it currently exists though.

zynex commented on 2024-04-14 12:51 (UTC)

Can't update the package to latest version, keep getting error @homebridge/ciao@1.2.0: The engine "node" is incompatible with this module. Expected version "^18 || ^20". Got "21.7.2".

anonfunc commented on 2023-12-01 16:44 (UTC) (edited on 2023-12-01 16:46 (UTC) by anonfunc)

I'll be dropping this package, since >=9.4 requires some significant changes and I'll be dropping my Z-Wave setup soon, so I'll have no way of testing this sufficiently.

I reverted to 9.3.1 for now, just to leave this package in a somewhat working state. Feel free to adopt.

miffe commented on 2023-12-01 16:33 (UTC) (edited on 2023-12-01 16:34 (UTC) by miffe)

9.5.1-1 fails to build with:

removed 'node_modules/material-design-icons-iconfont/.github/workflows/build-and-deploy.yml'
removed directory 'node_modules/material-design-icons-iconfont/.github/workflows'
removed directory 'node_modules/material-design-icons-iconfont/.github'
removed 'node_modules/has-bigints/.github/FUNDING.yml'
removed directory 'node_modules/has-bigints/.github'
removed 'node_modules/proxyquire/.github/FUNDING.yml'
removed directory 'node_modules/proxyquire/.github'
removed directory 'node_modules/prettier-linter-helpers/.github'
removed 'node_modules/typed-array-byte-offset/.github/FUNDING.yml'
removed directory 'node_modules/typed-array-byte-offset/.github'
cp: cannot stat 'bin': No such file or directory
cp: cannot stat 'lib': No such file or directory
cp: cannot stat 'app.ts': No such file or directory
==> ERROR: A failure occurred in package().

anonfunc commented on 2023-09-08 15:16 (UTC)

@arniec Sorry about that, should be fixed with -3.

arniec commented on 2023-09-08 01:44 (UTC) (edited on 2023-09-08 01:45 (UTC) by arniec)

Hello, when I run makepkg, the error message "cp: cannot stat 'dist/static/*': No such file or directory" appears and aborts the installation. Can anyone help me? I'm not sure if this is the right place to say this. I read the PKGBUILD but I'm not sure how to fix it myself

billyburly commented on 2022-10-03 18:14 (UTC)

The PKGBUILD should probably also have replaces=(zwavejs2mqtt) it is as well

anonfunc commented on 2022-10-01 08:17 (UTC) (edited on 2022-10-11 11:30 (UTC) by anonfunc)

zwavejs2mqtt was renamed by upstream to zwave-js-ui. Please switch to this package if you want to continue getting updates.

Be aware that there are some manual steps involved by switching packages. They are explained when you first install zwave-js-ui.

anonfunc commented on 2021-11-22 21:56 (UTC) (edited on 2022-08-10 16:35 (UTC) by anonfunc)

It is neither building nor running on nodejs v17 currently. I recommend using nodejs-lts-gallium.

EDIT: Working again with nodejs>=18.