Package Details: zwavejs2mqtt 1:6.15.2-1

Git Clone URL: https://aur.archlinux.org/zwavejs2mqtt.git (read-only, click to copy)
Package Base: zwavejs2mqtt
Description: Zwave to Mqtt gateway and Control Panel Web UI.
Upstream URL: https://github.com/zwave-js/zwavejs2mqtt
Keywords: hass mqtt zwave zwavejs
Licenses: MIT
Submitter: anonfunc
Maintainer: anonfunc
Last Packager: anonfunc
Votes: 1
Popularity: 0.000232
First Submitted: 2021-05-30 00:05 (UTC)
Last Updated: 2022-08-10 16:13 (UTC)

Latest Comments

anonfunc commented on 2021-11-22 21:56 (UTC) (edited on 2022-08-10 16:35 (UTC) by anonfunc)

It is neither building nor running on nodejs v17 currently. I recommend using nodejs-lts-gallium.

EDIT: Working again with nodejs>=18.

wizonesolutions commented on 2021-11-22 09:23 (UTC) (edited on 2021-11-22 09:23 (UTC) by wizonesolutions)

Node v17 is in community now, so I presume this isn't building for anyone at the moment.

fiatguy85 commented on 2021-11-16 04:11 (UTC) (edited on 2021-11-16 06:01 (UTC) by fiatguy85)

It seems like this would not build or run on node v17.1. That appears to be in community-testing, so this may be an archlinux-arm specific issue. Downgrading to LTS fixed the problem for me.

anonfunc commented on 2021-10-25 05:12 (UTC)

@coolgoose54 I switched this pkg to arch 'any', that is more appropriate for nodejs packages anyway.

coolgoose54 commented on 2021-10-23 15:55 (UTC)

Can I please request ? -arch=(x86_64) +arch=(x86_64 armv7h) I am trying to install it on ArchLinuxARM on a Raspberry Pi and it builds fine on it.

anonfunc commented on 2021-06-29 21:34 (UTC)

@Frans-Willem Should be working now.

anonfunc commented on 2021-06-29 14:57 (UTC)

@frans-willem there are some patches missing. I'll try fixing this today, if free time permits it.

Frans-Willem commented on 2021-06-29 14:41 (UTC) (edited on 2021-06-29 14:41 (UTC) by Frans-Willem)

I was unable to get this package working:

  • /usr/bin/zwavejs2mqtt does not have execute permission set, starting manually or through systemd will not work.
  • When chmodding +x manually, it throw that it is unable to find ../lib/utils.

Has anyone else got this to work ?