Package Details: zwcad-bin 1:23.0.3.4-1

Git Clone URL: https://aur.archlinux.org/zwcad-bin.git (read-only, click to copy)
Package Base: zwcad-bin
Description: ZWSOFT研发的二维CAD软件,可满足看图、审图、打印工作需要
Upstream URL: https://www.zwcad.com
Keywords: 中望CAD
Licenses: unknown
Provides: zwcad
Submitter: sukanka
Maintainer: sukanka
Last Packager: sukanka
Votes: 2
Popularity: 0.78
First Submitted: 2020-07-03 11:21 (UTC)
Last Updated: 2022-06-08 06:08 (UTC)

Pinned Comments

sukanka commented on 2022-02-12 15:26 (UTC)

新版本发布了,但是无法运行。左上角工具栏点击闪退,菜单栏点击无反应。其他正常。忽略22.2.2.3 版本

Latest Comments

sukanka commented on 2022-02-12 15:26 (UTC)

新版本发布了,但是无法运行。左上角工具栏点击闪退,菜单栏点击无反应。其他正常。忽略22.2.2.3 版本

sukanka commented on 2021-06-01 13:12 (UTC)

@bpanthi977 Actually, there is no english user interface, I found no options in the settings to change language. Thus, only Simplified Chinese is supported.

bpanthi977 commented on 2021-06-01 05:28 (UTC)

How can I change the language to english?

WhiredPlanck commented on 2021-05-01 13:09 (UTC)

2021.1.4523 版本出来了~

jouhisaishi commented on 2020-12-02 04:30 (UTC)

manjaro-kde应该使ArchLinux-kde的qt环境配置不一样,manjaro-kde无法运行,换成archlinux-kde,就可与运行了。

SunMoonStar2000 commented on 2020-10-23 13:54 (UTC)

4.0.106这个版本虽然还会闪退,但起码能够启动起来了

SunMoonStar2000 commented on 2020-10-23 13:10 (UTC)

@sukanka 谢谢!

sukanka commented on 2020-10-11 02:28 (UTC) (edited on 2020-10-11 02:29 (UTC) by sukanka)

@SunMoonStar2000 4.0版本可以从这里下载,记得使用上一版的PKGBUILD, 可能还要改一下校验和

http://download.zwcad.com/zwcad/cad_linux/preinst/deb/x64/kylin/zwcad-linuxpreinst_4.0.106-1_amd64.deb

SunMoonStar2000 commented on 2020-10-11 01:14 (UTC)

5.0 闪退: QFSFileEngine::open: No file name specified libpng warning: Application jmp_buf size changed Segmentation fault (core dumped) 请问哪里能下到4.0那个版本?

stormman2k commented on 2020-09-27 04:49 (UTC)

我的Manjaro 5.8.6-1 KDE运行不了

sukanka commented on 2020-09-25 13:30 (UTC) (edited on 2020-09-25 13:31 (UTC) by sukanka)

@stormman2k @SamLukeYes, 我又试了一下,在我的系统(ArchLinux 5.8.10 KDE)上是可以运行的。现在的 PKGBUILD 里面直接使用的它自带的库

stormman2k commented on 2020-09-25 07:58 (UTC)

/usr/bin/zwcad:行 3: 62182 段错误 (核心已转储)/opt/zwcad/ZWCAD -platformpluginpath /opt/zwcad/plugins -platform xcb "$1"

无法使用,闪退

SamLukeYes commented on 2020-09-21 11:32 (UTC) (edited on 2020-09-21 14:54 (UTC) by SamLukeYes)

5.0 在 GNOME Wayland 上无法启动

/usr/bin/zwcad:行 3: 62182 段错误 (核心已转储)/opt/zwcad/ZWCAD -platformpluginpath /opt/zwcad/plugins -platform xcb "$1"

之前 4.0 是可以运行的

huyz commented on 2020-09-15 09:43 (UTC)

@sukanka 你用它的那个 sh 就能正常启动了(记得把 sh 里的路径改一下)。5.0 版得用它自带的那一套 qt 库才能启动,用系统库是启动不了。

或者这样启动也行:

LD_LIBRARY_PATH=.:./lib ./ZWCAD -platformpluginpath ./plugins -platform xcb

sukanka commented on 2020-09-15 06:17 (UTC)

@huyizheng 5.0版本一直无法正常运行(无法启动),所以我和还没有更新

huyz commented on 2020-09-14 08:40 (UTC)

5.0 版已出: https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.zwsoft.zwcad/com.zwsoft.zwcad_5.0.1446-1_amd64.deb

这个版本我试了下,好像没法用系统的 qt5.15 跑了,一跑就 core dump,只能用它内置的 qt5.4。

sukanka commented on 2020-07-03 13:03 (UTC)

打印功能无法使用,会报

Cannot mix incompatible Qt library (5.11.3) with this library (5.15.0)