Package Base Details: alacritty-git

Git Clone URL: https://aur.archlinux.org/alacritty-git.git (read-only)
Keywords: GPU rust terminal
Submitter: quininer
Maintainer: quininer
Last Packager: quininer
Votes: 81
Popularity: 2.181120
First Submitted: 2016-11-01 13:53
Last Updated: 2019-06-11 15:04

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8

antouank commented on 2017-01-07 11:08

@quininer installing rustup and doing `rustup default nightly` worked.
Thanks!

quininer commented on 2017-01-07 10:28

@antouank use rustup.

antouank commented on 2017-01-07 10:26

@quininer
Unfortunately rust-nightly also fails.

==> Validating source files with sha256sums...
rustc-nightly-src.tar.gz ... FAILED
docs.patch ... Passed
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build rust-nightly.

Any idea when it will go on stable?
Thanks.

quininer commented on 2017-01-07 09:12

@antouank
Now you need to install rust-nightly or rustup.wait until proc_macro is stable before you can compile with stable channel.

@wbthomason @aabmass @jonathanio thanks!

antouank commented on 2017-01-07 08:59

does anyone else get this error?
error[E0554]: #[feature] may not be used on the stable release channel

wbthomason commented on 2017-01-07 02:38

@quininer: I believe you may also be missing a few other dependencies - specifically, cmake, freetype2, and fontconfig. Admittedly, I haven't tried building without these installed, but the instructions on the alacritty repo for Arch specify that they are build requirements (https://github.com/jwilm/alacritty#arch-linux).

I'll also note that the infinality versions of freetype2 and fontconfig are acceptable substitutes; the manual build works on my system with these packages installed.

Thanks!

aabmass commented on 2017-01-07 02:35

Thanks for the package! Would you mind adding the desktop entry to this package? It's $srcdir/Alacritty.desktop

jonathanio commented on 2017-01-05 21:04

@quininer: The current version of rush (i.e. via makedepend) will not build alacritty - you need the latest nightly version - so I have not been able to build it.

I've created a patch for you which will use rustup instead of rust for the install and set the appropriate override. I've followed the documentation as it gives a fixed version specification defined by the repository as a requirement, but potentially rust-nightly might be a better choice even if it's slightly ahead of the pinned version given in rustc-version.

The patch also saves a copy of the configuration file into /usr/share/alacritty with an install message to tell users to install it before they first run it.

https://gist.github.com/jonathanio/b9dcf05ef9e5ec5fc8763713ebe95187

Hope this helps.