Package Base Details: backintime

Git Clone URL: https://aur.archlinux.org/backintime.git (read-only)
Submitter: None
Maintainer: graysky
Last Packager: graysky
Votes: 268
Popularity: 0.769970
First Submitted: 2009-01-09 20:46
Last Updated: 2019-01-06 15:58

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

coderkun commented on 2017-01-08 19:13

@geo909: I do have this issue, too, for some applications. But it is releated to using an unofficial freetype2 and not related to backintime.

There are some bug reports like https://bugs.archlinux.org/task/52424

geo909 commented on 2017-01-08 19:09

After the last update, I'm having problems running the gui. Is it just me?

> backintime-qt4
Traceback (most recent call last):
File "/usr/share/backintime/qt4/app.py", line 30, in <module>
import qt4tools
File "/usr/share/backintime/qt4/qt4tools.py", line 21, in <module>
from PyQt4.QtGui import QFont, QFileDialog, QListView, QAbstractItemView, \
ImportError: /usr/lib/libharfbuzz.so.0: undefined symbol: FT_Get_Var_Blend_Coordinates

graysky commented on 2016-08-04 16:38

No need for the dependency, see: https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

alejandro.perez commented on 2016-08-04 16:02

Hi,

binutils should be included into the makedepends, as strip is required (otherwise it fails).

Thanks for maintaining this!

graysky commented on 2016-08-01 22:23

@willemw - At the moment, the build will file if you do that...

willemw commented on 2016-08-01 15:17

test() in PKGBUILD should be check().

graysky commented on 2016-06-24 18:45

Use reflector, adjust to your locale:

% which upp
upp () {
for i in 1 2 4 8
do
reflector -c US -a $i -f 5 -p http -p https -p ftp --sort rate --save /etc/pacman.d/mirrorlist.reflector
if [ $? -eq 0 ]
then
cat /etc/pacman.d/mirrorlist.reflector
sudo pacman -Syu
return 0
else
echo "something is fucked up."
fi
done
}

Maxiride commented on 2016-06-24 16:17

EDIT 2: my bad.. dammit still have to learn to run a -Syy regularly. Everything went fine.. I was just not in sync ahah.


EDIT: that's weird, clicking "Download from Mirror" in the package page downloads it without problems.


Sadly one of the mirrors for python-keyring-9.0-1 has been offline for days if anyone else is unable to download it. I'll try to contact his maintainer in the community repo here.

errore: impossibile scaricare il pacchetto 'python-keyring-9.0-1-any.pkg.tar.xz' da archlinux.students.cs.unibo.it : The requested URL returned error: 404
attenzione: impossibile scaricare alcuni file
errore: impossibile eseguire l'operazione richiesta (errore inaspettato)
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.
==> ATTENZIONE: I pacchetti sono stati salvati in /tmp/yaourt-tmp-federico

cp: sovrascrivere '/tmp/yaourt-tmp-federico/backintime-cli-1.1.12-4-any.pkg.tar.xz'? y
[federico@arch-anywhere-federico]: ~>$

graysky commented on 2016-03-28 12:01

@MS and @Tids - Not the fault of this PKGBUILD; makepkg has not supported this feature for some months now: https://lists.archlinux.org/pipermail/pacman-dev/2015-September/020347.html

MaycneSonahoz commented on 2016-03-28 08:49

I also got the "makepkg: invalid option '--pkg'" error.

I got the message when i tried to update backintime and backintime-cli, with both Pamac and yaourt, with the following answers (French language, but the order of questions should be the same):
==> Éditer PKGBUILD ? [O/n] -> n (No)
==> Lancer la compilation de backintime ? [O/n] -> o (Yes)
==> Installer seulement backintime ? [O/n] -> o (Yes)
makepkg: option invalide '--pkg'

For the update to work, you need to say 'No (n)' when asked if you want to install only backintime (3rd question), and likewise for backintime-cli.