Package Base Details: caffe2

Git Clone URL: https://aur.archlinux.org/caffe2.git (read-only)
Keywords: ai artificial cuda intelligence nvidia
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 0
Popularity: 0.000000
First Submitted: 2017-04-29 16:21
Last Updated: 2019-05-02 02:22

Packages (2)

Pinned Comments

dbermond commented on 2018-08-22 18:15

Important notice:

This package now provides the non-cuda version (as known as the 'cpu only' build).

If you want caffe2 with cuda support, use package caffe2-cuda. This new package naming schema will better reflect the package contents. This conforms to tensorflow package naming from the official repositories.

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

petronny commented on 2017-09-08 14:58

I get
-- Found OpenMP_C: -fopenmp (found version "4.0")
-- Found OpenMP_CXX: -fopenmp (found version "4.0")
-- Adding -fopenmp
-- CUDA detected: 8.0
-- Automatic GPU detection failed. Building for all known architectures.
-- Added CUDA NVCC flags for: sm_20 sm_21 sm_30 sm_35 sm_50 sm_52 sm_60 sm_61
-- Found libcuda: /opt/cuda/lib64/stubs/libcuda.so
-- Found libnvrtc: /opt/cuda/lib64/libnvrtc.so
-- Found CUDNN: /opt/cuda/include
-- Found cuDNN: v7.0.1 (include: /opt/cuda/include, library: /opt/cuda/lib64/libcudnn.so)
-- Could NOT find CUB (missing: CUB_INCLUDE_DIR)
-- Could NOT find Gloo (missing: Gloo_INCLUDE_DIR Gloo_LIBRARY)
-- Found hiredis: /usr/include/hiredis
-- Found hiredis (include: /usr/include/hiredis, library: /lib/libhiredis.so)
-- MPI include path: /usr/include
-- MPI libraries: /usr/lib/openmpi/libmpi_cxx.so/usr/lib/openmpi/libmpi.so
-- Found CUDA: /opt/cuda (found suitable version "8.0", minimum required is "7.0")
-- CUDA detected: 8.0
-- Found libcuda: /opt/cuda/lib64/stubs/libcuda.so
-- Found libnvrtc: /opt/cuda/lib64/libnvrtc.so
CMake Error at /usr/share/cmake-3.9/Modules/ExternalProject.cmake:2010 (message):
No download info given for 'nccl_external' and its source directory:

/build/caffe2/src/caffe2-0.8.1/third_party/gloo/third-party/nccl

is not an existing non-empty directory. Please specify one of:

* SOURCE_DIR with an existing non-empty directory
* URL
* GIT_REPOSITORY
* HG_REPOSITORY
* CVS_REPOSITORY and CVS_MODULE
* SVN_REVISION
* DOWNLOAD_COMMAND
Call Stack (most recent call first):
/usr/share/cmake-3.9/Modules/ExternalProject.cmake:2565 (_ep_add_download_command)
third_party/gloo/cmake/External/nccl.cmake:16 (ExternalProject_Add)
third_party/gloo/cmake/Dependencies.cmake:53 (include)
third_party/gloo/CMakeLists.txt:44 (include)

without nccl installed.

Adding nccl back to depends works.

dbermond commented on 2017-08-22 20:20

@wangqr
Thank you for reporting this. I can reproduce the issue.
It seems that the caffe2 python dependencies have slightly changed from when I firstly checked it.
I will be updating this package and the other caffe2 packages on the AUR to fix this issue.

wangqr commented on 2017-08-22 08:34

After installed this package I tried to import it, but get the following error:

Python 2.7.13 (default, Jul 21 2017, 03:24:34)
[GCC 7.1.1 20170630] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from caffe2.python import workspace, model_helper
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/lib/python2.7/site-packages/caffe2/python/workspace.py", line 14, i n <module>
from past.builtins import basestring
ImportError: No module named past.builtins
>>>

Installing python2-future resolves the issue.

dbermond commented on 2017-08-09 17:25

caffe2 0.8.1 adds support for the newly released cudnn 7.0.

dbermond commented on 2017-08-08 10:31

@petronny
I have already "done something":
https://aur.archlinux.org/cgit/aur.git/commit/?h=caffe2&id=894fb0890375500b0629e13ff2ad457244eaf68f

That's the workaround that I could manage to do while a proper patch cannot be applied. This will require downgrade of cudnn to 6.0.21.
In the meanwhile you can use caffe2-cpu, which does not have cudnn dependency.

petronny commented on 2017-08-08 07:09

Hi, the cudnn in [community] has been updated to 7.0.1
Please do something. The package won't be built now.

pdrocaldeira commented on 2017-07-24 22:05

@dbermond

Thank YOU!

Worked just fine. :)

dbermond commented on 2017-07-21 01:57

@pdrocaldeira
Thank you for reporting it. This should be fixed as of version 0.7.0-13.
All other caffe2 packages were fixed too.

pdrocaldeira commented on 2017-07-19 02:05

Can't install. Trying -git also.

Getting this error:

g++-5: error: unrecognized command line option ‘-fno-plt’

dbermond commented on 2017-04-30 16:50

@dydokamil

"Currently, Caffe2 is supporting 2.7 only and python3 support is coming."
https://github.com/caffe2/caffe2/issues/315

If you need python3 right now please use caffe (previous generation).