Package Base Details: catalyst-utils

Git Clone URL: https://aur.archlinux.org/catalyst-utils.git (read-only)
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 61
Popularity: 0.085882
First Submitted: 2013-04-29 09:04
Last Updated: 2018-04-29 16:46

Pinned Comments

Vi0L0 commented on 2017-03-14 19:40

about 4.9 and 4.10 kernel support - looks like to make it work correctly with fglrx you have to blacklist amdgpu ie.:

# cat /etc/modprobe.d/blacklist.conf
blacklist amdgpu

Vi0L0 commented on 2017-03-14 19:32

catalyst is old and it supports only up to xorg-server 1.17, you can get it from repo:

[xorg117]
Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch

add it to pacman.conf above other repositories and perform downgrade:
pacman -Syuu

catalyst will not support newer versions of xorg-server, like ever.
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

Vi0L0 commented on 2017-03-11 18:30

If you see this conflict:

looking for conflicting packages...
:: mesa and catalyst-libgl are in conflict (mesa-libgl). Remove catalyst-libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: mesa and catalyst-libgl are in conflict

for now I've added mesa packages of 17.0.1-1 version to [catalyst]* and [catalyst-stable] - simply copied from archive: https://archive.archlinux.org/packages/

Please downgrade if you updated mesa to -2 version.
After new version of mesa came out, I will build new mesa packages without glvnd support. Then I will most probably add new mesa package to aur. Will let know when it will happen

*
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Vi0L0 commented on 2015-06-04 13:22

updated to 15.5-1 - AKA "nothing interesting":
- it doesn't support xserver 1.17
- looks older than ubuntu vivid driver which we are using ie in catalyst-test@AUR
- rel notes: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-5LINReleaseNotes.aspx

Vi0L0 commented on 2015-02-15 12:04

xserver 1.17 renders nasty segfault.
For now you can use [xorg116] repo:

[xorg116]
# uncomment one server from the list below:
#Server = http://catalyst.wirephire.com/repo/xorg116/$arch
#Server = http://mirror.rts-informatique.fr/archlinux-catalyst/repo/xorg116/$arch
#Server = http://mirror.hactar.bz/Vi0L0/xorg116/$arch

ashwin.vbs commented on 2015-02-15 11:32

Xorg was updated to 1.17 today - this breaks automated dependencies..

Vi0L0 commented on 2014-12-20 19:41

quote from bar and grill:
I can see that git version already have this patch included (as well as other fixes). Can some pxp user check if xf86-video-intel-git works fine on their systems with xserver 1.16 installed? You can get this pkg from AUR or from the [mesa-git] repo or you can use mine if you want[1], i built it minutes ago for x86_64.

[1]http://mirror.rts-informatique.fr/archlinux-catalyst/files/xf86-video-intel-git/

Vi0L0 commented on 2014-12-18 08:12

Thanks Toost_Inc, I will add it to provides array after getting back home

MagicAndWires commented on 2014-12-18 00:07

Just ran into a dependency problem building libva-xvba-drivers which needs catalyst-libgl.

If I'm right in assuming the catalyst-libgl files are all provided with catalyst-total, could you add it to the provides variable?

Vi0L0 commented on 2014-12-11 21:23

what else... xserver 1.16 support, and kernel up to 3.18 (thanks to my noobish patch for 3.17 ;P)

Vi0L0 commented on 2014-12-11 21:22

updated to 14.12-1, "famous" catalyst omega
http://support.amd.com/en-us/kb-articles/Pages/AMDCatalystOmegaLINReleaseNotes.aspx

quick tests showed that this driver is pretty good.
2d rendering was never that fast on 290X (its almost as fluid as on oss radeon)
cs:go works like a charm now ;P.

vaapi does work (but it has problems with osd, including subtitles) here without additional xvba-video packages
if you want to check it just add
export LIBVA_DRIVER_NAME=fglrx
into ~/.bashrc, and if that won't work for all your players you can create something like /etc/profile.d/fglrx-vaapi.sh with lets say:
LIBVA_DRIVER_NAME=fglrx
export LIBVA_DRIVER_NAME
LIBVA_DRIVERS_PATH=/usr/lib/dri/
export LIBVA_DRIVERS_PATH


IMPORTANT
thing is that from now on theres this new symlink:
ln -snf /usr/lib/libXvBAW.so.1.0 ${pkgdir}/usr/lib/dri/fglrx_drv_video.so
which will conflict with xvba-video packages. Thats amd's will, maybe they will do something with it. Feel free to remove this file(symlink) from your system before updating (if you will be touched by a conflict).

averagejoey2000 commented on 2014-12-08 20:35

pacaur and yaourt cannot satisfy the following dependency:
xorg-server (less than)<1.16
that is simultaneously >=(greater than or equal to) 1.7
Do I need to install a specific xorg, modify the PKGBUILD for this(catalystutils), or what?

ShyPixie commented on 2014-10-23 11:54

This package need a patch for amdxdg-su work with xfce.

The script check if environments match with xfce4 (see line 323), but not in final "case" (on lines 566 ~ 587).

Need to edit script on the last case/esac with:

xfce4)
su_gnome
;;