Package Base Details: catalyst-utils

Git Clone URL: https://aur.archlinux.org/catalyst-utils.git (read-only)
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 61
Popularity: 0.084591
First Submitted: 2013-04-29 09:04
Last Updated: 2018-04-29 16:46

Pinned Comments

Vi0L0 commented on 2017-03-14 19:40

about 4.9 and 4.10 kernel support - looks like to make it work correctly with fglrx you have to blacklist amdgpu ie.:

# cat /etc/modprobe.d/blacklist.conf
blacklist amdgpu

Vi0L0 commented on 2017-03-14 19:32

catalyst is old and it supports only up to xorg-server 1.17, you can get it from repo:

[xorg117]
Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch

add it to pacman.conf above other repositories and perform downgrade:
pacman -Syuu

catalyst will not support newer versions of xorg-server, like ever.
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

Vi0L0 commented on 2017-03-11 18:30

If you see this conflict:

looking for conflicting packages...
:: mesa and catalyst-libgl are in conflict (mesa-libgl). Remove catalyst-libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: mesa and catalyst-libgl are in conflict

for now I've added mesa packages of 17.0.1-1 version to [catalyst]* and [catalyst-stable] - simply copied from archive: https://archive.archlinux.org/packages/

Please downgrade if you updated mesa to -2 version.
After new version of mesa came out, I will build new mesa packages without glvnd support. Then I will most probably add new mesa package to aur. Will let know when it will happen

*
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

NoSuck commented on 2014-07-23 23:34

Thanks for putting this together. Without Catalyst, Arch would not be a viable OS choice for me.

Does anyone else get errors when catalyst-libgl compiles?

cp: `aur/catalyst-utils/catalyst-libgl.install' を stat できません: そのようなファイルやディレクトリはありませ
chmod: `.INSTALL' にアクセスできません: そのようなファイルやディレクトリはありません
bsdtar: .INSTALL: Cannot stat: そのようなファイルやディレクトリはありません
bsdtar: .INSTALL: Cannot stat: そのようなファイルやディレクトリはありません

... It's complaining that "catalyst-libgl.install" and ".INSTALL" don't exist. Otherwise, the build process seems to finish without problems.

Vi0L0 commented on 2014-05-25 11:34

updated to 14.4-20 (catalyst 14.4 rev2):
- which brings some fixes for Witcher 2

Vi0L0 commented on 2014-05-07 17:19

yes, bug with gdm is still present

marmotta commented on 2014-05-07 15:16

Ok, i see -11 un aur but not in pacman...

The bug with gdm is still present?

Vi0L0 commented on 2014-05-07 13:06

you mean that its in -10, not -11 version?:
# pacman -Sl catalyst | grep utils
catalyst catalyst-utils 14.4-10
catalyst catalyst-utils-pxp 14.4-10
catalyst lib32-catalyst-utils 14.4-11
catalyst lib32-catalyst-utils-pxp 14.4-10

in -11 only sub-package catalyst-libgl was updated, and so is in the repo:
# pacman -Sl catalyst | grep libgl
catalyst catalyst-libgl 14.4-11
catalyst lib32-catalyst-libgl 14.4-11

marmotta commented on 2014-05-07 11:54

Please update catalyst-utils in your repo http://catalyst.wirephire.com/

Vi0L0 commented on 2014-04-28 20:31

updated to 14.4-11, catalyst 14.4 stable:
- xserver 1.15 support
(gotjazz wrote: little warning though - if you use xbmc, get sdl-nobackingstore from the AUR or you'll have tearing during video playback with xorg 1.15)
- many fixes here and there

catalyst-utils is now splitted into:
catalyst-utils
catalyst-libgl
opencl-catalyst

catalyst-libgl comes with experimental powerXpress support which is not messing with the system like old -pxp packages are, please test and let me know if its working well

olive commented on 2014-04-28 04:32

@willsiddall The latest stable driver is now 14.4 which should support Xorg 1.15. Probably Vi0l0 will update it soon.

olive commented on 2014-04-28 04:31

The latest stable driver is now 14.4 which should support Xorg 1.15. Probably Vi0l0 will update it soon.

willsiddall commented on 2014-04-27 22:21

current version of xorg-server is now >1.15. Any chance this build will work with the newer versions of xorg-server?