Package Base Details: citra-git

Git Clone URL: https://aur.archlinux.org/citra-git.git (read-only, click to copy)
Submitter: ceri
Maintainer: timschumi
Last Packager: timschumi
Votes: 47
Popularity: 0.43
First Submitted: 2014-05-01 08:32
Last Updated: 2020-04-14 15:12

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

timschumi commented on 2018-09-27 22:18

@hcorion Discord integration should now be enabled

@oddworld That issue is fixed now, the build paths have changed

@gourdcaptain I didn't experience such issues. What makepkg command or AUR wrapper did you use to compile the package?

gourdcaptain commented on 2018-09-27 21:41

This is giving me the error: "error: failed to commit transaction (conflicting files) citra-qt-git: /usr/lib64 exists in filesystem (owned by filesystem)" on install attempt.

oddworld commented on 2018-09-27 01:52

I am unable to build. Below is the error:

=> Starting check()...
Running tests...
Test project /tmp/yaourt-tmp-USERNAME/aur-citra-qt-git/src/citra/build
Start 1: tests
1/1 Test #1: tests ............................   Passed    0.27 sec

100% tests passed, 0 tests failed out of 1

Total Test time (real) =   0.27 sec
==> Entering fakeroot environment...
==> Starting package_citra-git()...
install: cannot stat '/tmp/yaourt-tmp-USERNAME/aur-citra-qt-git/src/citra/build/src/citra/citra': No such file or directory
==> ERROR: A failure occurred in package_citra-git().
Aborting...
==> ERROR: Makepkg was unable to build citra-git.
==> Restart building citra-qt-git ? [y/N]
==> -------------------------------------

hcorion commented on 2018-09-09 21:29

Hey, just wondering if we could enable discord rich presence for this package, via -DUSE_DISCORD_PRESENCE=ON ?

timschumi commented on 2018-06-26 19:06

@linkmauve

This package needs at least a build-time dependency on "qt5-multimedia" to provide the Qt5MultimediaConfig.cmake configuration file.

Also, please change the "git submodule update" calls to "git submodule update --init --recursive" as already recommended by others (since the package is not buildable in its current state).

BrainwreckedTech commented on 2018-06-07 12:09

As noted by turtlewit in citra-canary-git:

Had to change "git submodule update" to "git submodule update --init --recursive" in PKGBUILD to fix.

Enverex commented on 2018-06-06 17:31

Looks like a dependency is missing now. Configure fails with:

CMake Error at externals/cubeb/CMakeLists.txt:27 (message): Could not find sanitizers-cmake: run

allencch commented on 2017-12-15 03:22

If using pacaur and cached the build, and see some message like

xxxx/inih is not a clone of https://github.com/benhoyt/inih

then one needs to remove the inih/ folder and re-build it.

linkmauve commented on 2017-12-06 09:57

Fixed.

hcorion commented on 2017-12-05 21:54

This package no longer builds due to https://github.com/citra-emu/citra/pull/3178

You need to change inih repos.