Package Base Details: dotnet-core-5.0-bin

Git Clone URL: https://aur.archlinux.org/dotnet-core-5.0-bin.git (read-only, click to copy)
Submitter: Gr3q
Maintainer: Gr3q
Last Packager: Gr3q
Votes: 4
Popularity: 0.39
First Submitted: 2021-11-08 22:06 (UTC)
Last Updated: 2022-05-12 20:20 (UTC)

Latest Comments

Gr3q commented on 2022-05-12 20:07 (UTC)

@ShroudedNight I used to have it like that, then I changed it. I agree, even that my change made sense for the latest version, not so much for the older versions.

I will revert back to accept any netstandard-targeting-pack.

ShroudedNight commented on 2022-04-23 02:17 (UTC)

For interested parties, I have this integrating with the dotnet-core packages in extra with the following changes:

diff --git a/PKGBUILD b/PKGBUILD
index bcb720d..bf9063a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,6 @@ package_dotnet-runtime-5.0-bin() {
            'glibc'
            'icu' 
            'krb5'
-           'libcurl.so'
            'libunwind'
            'openssl'
            'zlib'
@@ -60,7 +59,7 @@ package_dotnet-sdk-5.0-bin() {
     'dotnet-runtime-5.0-bin'
     'glibc'
     'dotnet-targeting-pack-5.0-bin'
-    'netstandard-targeting-pack-bin')
+    "netstandard-targeting-pack>=${_runtimever}")
   optdepends=('aspnet-targeting-pack-5.0-bin: Build ASP.NET Core applications')
   provides=("dotnet-sdk-5.0-bin" "dotnet-sdk=${pkgver}" "dotnet-sdk-5.0")
   conflicts=("dotnet-sdk-5.0-bin" "dotnet-sdk=${pkgver}" "dotnet-sdk-5.0")
@@ -72,7 +71,7 @@ package_dotnet-sdk-5.0-bin() {

 package_dotnet-targeting-pack-5.0-bin() {
   pkgdesc='The .NET Core targeting pack version 5.0 (binary)'
-  depends=(netstandard-targeting-pack-bin)
+  depends=("netstandard-targeting-pack>=${_runtimever}")
   provides=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-5.0)
   conflicts=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-5.0)

HunabKu commented on 2022-04-12 03:58 (UTC)

==> ATTENTION : Cette bibliothèque listée dans 'depends' n’est requise par aucun fichier : libcurl.so

Gr3q commented on 2021-11-21 18:59 (UTC)

@winicius if you install with AUR helper that does not support split packages properly (like trizen) or you make the package manually, you will have to install dependencies from AUR yourself.

netstandard-targeting-pack-bin is part of the dotnet-core-bin package group, if you install that you should be fine.

winicius commented on 2021-11-20 00:26 (UTC)

Getting error:

==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Sources are ready.
-> dotnet-core-5.0-bin-5.0.12.sdk403-1 already made -- skipping build
[sudo] password for winicius: 
loading packages...
resolving dependencies...
warning: cannot resolve "netstandard-targeting-pack-bin", a dependency of "dotnet-targeting-pack-5.0-bin"
warning: cannot resolve "netstandard-targeting-pack-bin", a dependency of "dotnet-targeting-pack-5.0-bin"
warning: cannot resolve "dotnet-targeting-pack-5.0-bin", a dependency of "dotnet-sdk-5.0-bin"
warning: cannot resolve "netstandard-targeting-pack-bin", a dependency of "dotnet-sdk-5.0-bin"
:: The following packages cannot be upgraded due to unresolvable dependencies:
    dotnet-targeting-pack-5.0-bin  dotnet-sdk-5.0-bin

:: Do you want to skip the above packages for this upgrade? [y/N] 
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'netstandard-targeting-pack-bin' required by dotnet-targeting-pack-5.0-bin
:: unable to satisfy dependency 'netstandard-targeting-pack-bin' required by dotnet-targeting-pack-5.0-bin
:: unable to satisfy dependency 'dotnet-targeting-pack-5.0-bin' required by dotnet-sdk-5.0-bin
:: unable to satisfy dependency 'netstandard-targeting-pack-bin' required by dotnet-sdk-5.0-bin
-> exit status 1

Any ideas on how to fix this?