Package Base Details: eiskaltdcpp-git

Git Clone URL: https://aur.archlinux.org/eiskaltdcpp-git.git (read-only)
Submitter: dhampire
Maintainer: sl1pkn07
Last Packager: sl1pkn07
Votes: 30
Popularity: 0.000001
First Submitted: 2010-10-26 18:01
Last Updated: 2019-04-17 20:01

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

CyberGhost commented on 2015-12-28 20:51

This package needs Qt5LinguistTools to compile, so I believe qt5-tools should at least be a build dependency for this program.

freddie commented on 2015-11-26 13:42

Ah ok i vill try that instead.
Thanks again.
freddie

sl1pkn07 commented on 2015-11-25 22:57

if only use a eiskaltdcpp-qt5, you can remove eiskaltdcpp-cli, eiskaltdcpp-web and eiskaltdcpp-daemon. because cli, web and daemon is a different frontend for eiskaltdcpp-core (like a eiskaltdcpp-gtk{2,3}/qt4)

freddie commented on 2015-11-25 21:17

Hello again sl1pkn07.

I thought i should clean up all programs that i not longer use. And got really suprised that i have 94 packages from eiskaltdcpp-qt5 installation. A quiet nasty dependencies hell you got there :)). I think it was very much programs to install under the installation for eiskaltdcpp-qt5 because i never install that much before. I assume this is because of eiskalt-web and cli package??. And this not gone be so fun to update ;-). I dont know if anybody use those programs,web and cli. But maby should remove those. Just a thought.

Here you have my list.

Packages (94) perl-algorithm-diff-1.1903-1
perl-apache-logformat-compiler-0.32-1 perl-asa-1.03-1
perl-authen-simple-0.5-3 perl-cgi-4.22-1
perl-class-accessor-0.34-4 perl-class-accessor-lite-0.05-1
perl-class-data-inheritable-0.08-6 perl-class-inspector-1.28-2
perl-cookie-baker-0.05-1 perl-crypt-passwdmd5-1.40-1
perl-data-optlist-0.109-2 perl-devel-globaldestruction-0.13-1
perl-devel-stacktrace-2.00-1 perl-devel-stacktrace-ashtml-0.14-1
perl-devel-symdump-2.14-1 perl-dist-checkconflicts-0.11-1
perl-encode-locale-1.05-1 perl-exporter-tiny-0.042-1
perl-file-listing-6.04-2 perl-file-sharedir-1.102-1
perl-file-slurp-9999.19-3 perl-filesys-notify-simple-0.12-1
perl-hash-multivalue-0.15-1 perl-html-parser-3.71-4
perl-html-tagset-3.20-4 perl-http-body-1.22-1
perl-http-cookies-6.01-2 perl-http-daemon-6.01-2
perl-http-date-6.02-2 perl-http-headers-fast-0.19-1
perl-http-message-6.11-1 perl-http-negotiate-6.01-2
perl-http-server-simple-0.44-2 perl-inc-latest-0.500-1
perl-io-string-1.08-9 perl-json-2.90-1 perl-libwww-6.08-1
perl-list-moreutils-0.413-1 perl-log-dispatch-2.44-1
perl-lwp-mediatypes-6.02-2 perl-module-implementation-0.09-1
perl-module-runtime-0.014-1 perl-net-http-6.09-1
perl-net-server-2.008-1 perl-params-classify-0.013-6
perl-params-util-1.07-4 perl-params-validate-1.18-2
perl-plack-1.0037-1 perl-pod-coverage-0.23-1
perl-posix-strftime-compiler-0.41-1 perl-router-simple-0.15-1
perl-stream-buffered-0.03-1 perl-sub-exporter-0.987-1
perl-sub-exporter-progressive-0.001011-1
perl-sub-install-0.928-1 perl-test-differences-0.62-1
perl-test-fatal-0.014-1 perl-test-name-fromline-0.11-1
perl-test-nowarnings-1.04-2 perl-test-requires-0.10-1
perl-test-sharedfork-0.34-1 perl-test-tester-0.109-1
perl-text-diff-1.41-3 perl-try-tiny-0.22-1
perl-www-robotrules-6.02-2 perl-xml-libxml-2.0122-1
perl-xml-namespacesupport-1.11-3 perl-xml-sax-0.99-4
perl-xml-sax-base-1.08-3 perl-authen-simple-passwd-0.6-3
perl-fcgi-0.77-2 perl-fcgi-procmanager-0.24-2
perl-file-sharedir-install-0.10-1 perl-http-request-ascgi-1.2-1
perl-http-server-simple-psgi-0.16-1 perl-io-handle-util-0.01-1
perl-json-rpc-1.06-2 perl-log-dispatch-array-1.003-1
perl-log-log4perl-1.46-1 perl-lwp-protocol-http10-6.03-1
perl-mime-types-2.12-1 perl-module-build-0.4214-1
perl-module-refresh-0.17-1 perl-path-class-0.35-1
perl-rpc-xml-0.78-2 perl-term-shellui-0.92-4
perl-test-deep-0.115-1 perl-test-mocktime-0.15-1
perl-test-pod-1.51-1 perl-test-pod-coverage-1.10-1
perl-test-tcp-2.11-1 perl-test-time-0.04-1
perl-test-use-ok-0.11-2
Thanks
freddie

freddie commented on 2015-11-13 20:31

I just compiled eiskaltdcpp-core-git fine and installed with no problem.
I try to install the rest now.

Thanks for the help.
freddie

sl1pkn07 commented on 2015-11-13 20:02

try now

freddie commented on 2015-11-13 19:46

perl-json install fine now,but i got a new failure with boost instead.

-- Building with free space bar (realisation on C, POSIX 1003.1-2001 (and later) with XSI)
CMake Error at /usr/share/cmake-3.4/Modules/FindBoost.cmake:1247 (message):
Unable to find the requested Boost libraries.

Unable to find the Boost header files. Please set BOOST_ROOT to the root
directory containing Boost or BOOST_INCLUDEDIR to the directory containing
Boost's headers.
Call Stack (most recent call first):
CMakeLists.txt:174 (find_package)


-- Library directory: /usr/lib
-- Data directory: /usr/share/eiskaltdcpp
-- Build Git commit ID: v2.2.10-82-g31355fd
-- Translations: be;bg;cs;de;el;en;es;eu;fr;hu;it;pl;pt_BR;ru;sr;sr@latin;sk;uk;vi;zh_CN;sv_SE
-- CMAKE_SYSTEM: Linux-4.3.0-1-ARCH
-- CMAKE_SYSTEM_PROCESSOR: x86_64
-- CMAKE_CXX_COMPILER_ID: GNU
-- CMAKE_C_COMPILER_ID: GNU
-- CMAKE will use this libs (and headers) during build:

miniupnpc (headers):miniupnpc (/tmp/yaourt-tmp-croutch/aur-eiskaltdcpp-qt5-git/src/eiskaltdcpp/upnp)
lua (headers): /usr/lib64/liblua.so;/usr/lib64/libm.so (/usr/include)
boost (headers): (Boost_INCLUDE_DIR-NOTFOUND)
bzip2 (headers): /usr/lib64/libbz2.so (/usr/include)
zlib (headers): /usr/lib64/libz.so (/usr/include)
openssl (headers): /usr/lib64/libssl.so;/usr/lib64/libcrypto.so (/usr/include)
iconv (headers): /usr/lib64/libc.so (/usr/include)
aspell (headers): ()
gettext (headers): (/usr/include)
pcre(cpp) (headers): /usr/lib64/libpcrecpp.so;/usr/lib64/libpcre.so (/usr/include)
idna (headers): /usr/lib64/libidn.so (/usr/include)

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Boost_INCLUDE_DIR (ADVANCED)
used as include directory in directory /tmp/yaourt-tmp-croutch/aur-eiskaltdcpp-qt5-git/src/eiskaltdcpp/extra
used as include directory in directory /tmp/yaourt-tmp-croutch/aur-eiskaltdcpp-qt5-git/src/eiskaltdcpp/extra

sl1pkn07 commented on 2015-11-13 19:15

try now (this bugreport is on perl-json-rpc package, not in here)

freddie commented on 2015-11-13 18:35

Hello sl1pkn07.
I got this error when i try to upgrade eiskalt git.

Validating source files with sha1sums...
JSON-RPC-1.06.tar.gz ... Passed
==> Extracting sources...
-> Extracting JSON-RPC-1.06.tar.gz with bsdtar
==> Starting build()...
Created MYMETA.yml and MYMETA.json
Creating new 'Build' script for 'JSON-RPC' version '1.06'
Merging cpanfile prereqs to MYMETA.yml
Merging cpanfile prereqs to MYMETA.json
Building JSON-RPC
==> Starting check()...
t/001_compile.t ....... ok
t/002_basic.t ......... ok
t/003_parser.t ........ ok
t/legacy/00_pod.t ..... ok
t/legacy/01_use.t ..... Can't locate CGI.pm in @INC (you may need to install the CGI module) (@INC contains: /tmp/yaourt-tmp-croutch/aur-perl-json-rpc/src/JSON-RPC-1.06/blib/lib /tmp/yaourt-tmp-croutch/aur-perl-json-rpc/src/JSON-RPC-1.06/blib/arch /tmp/yaourt-tmp-croutch/aur-perl-json-rpc/src/JSON-RPC-1.06/_build/lib /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at t/legacy/01_use.t line 5.
BEGIN failed--compilation aborted at t/legacy/01_use.t line 5.
# Looks like your test exited with 2 before it could output anything.
t/legacy/01_use.t ..... Dubious, test returned 2 (wstat 512, 0x200)
Failed 1/1 subtests
t/legacy/02_server.t .. ok

Test Summary Report
-------------------
t/legacy/01_use.t (Wstat: 512 Tests: 0 Failed: 0)
Non-zero exit status: 2
Parse errors: Bad plan. You planned 1 tests but ran 0.
Files=6, Tests=30, 1 wallclock secs ( 0.04 usr 0.00 sys + 0.35 cusr 0.01 csys = 0.40 CPU)
Result: FAIL
Failed 1/6 test programs. 0/30 subtests failed.
==> ERROR: A failure occurred in check().
Aborting...
==> ERROR: Makepkg was unable to build perl-json-rpc.

dbedrenko commented on 2015-10-04 07:36

I get compilation error, is there a problem with the package or is it just me?

CMake Error at eiskaltdcpp-qt/CMakeLists.txt:14 (find_package):
By not providing "FindQt5Widgets.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"Qt5Widgets", but CMake did not find one.

Could not find a package configuration file provided by "Qt5Widgets"
(requested version 5.0.2) with any of the following names:

Qt5WidgetsConfig.cmake
qt5widgets-config.cmake

Add the installation prefix of "Qt5Widgets" to CMAKE_PREFIX_PATH or set
"Qt5Widgets_DIR" to a directory containing one of the above files. If
"Qt5Widgets" provides a separate development package or SDK, be sure it has
been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/yaourt-tmp-ks/aur-eiskaltdcpp-qt-git/src/eiskaltdcpp/build/CMakeFiles/CMakeOutput.log".
See also "/tmp/yaourt-tmp-ks/aur-eiskaltdcpp-qt-git/src/eiskaltdcpp/build/CMakeFiles/CMakeError.log".