Package Base Details: freetype2-infinality

Git Clone URL: https://aur.archlinux.org/freetype2-infinality.git (read-only)
Submitter: None
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 470
Popularity: 0.151338
First Submitted: 2010-07-14 15:27
Last Updated: 2019-05-28 15:57

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

Ralf_Mardorf commented on 2017-01-15 14:23

freetype from official repositories and freetype2-infinality are in sync. What version do you expect?
The error message you get informs you about what you need to do. Doesn't it?
However, installing freetype2 could be done on my install, without such an issue.
The comments aren't the right place to request the kind of help you need.


[rocketmouse@archlinux ~]$ pacman -Si freetype2 | grep Ver
Version : 2.7.1-1
[rocketmouse@archlinux ~]$ grep freetype2-infinality /var/log/pacman.log | tail -1
[2017-01-14 12:22] [ALPM] upgraded freetype2-infinality (2.7-1 -> 2.7.1-1)
[rocketmouse@archlinux ~]$ sudo pacman -S freetype2
resolving dependencies...
looking for conflicting packages...
:: freetype2 and freetype2-infinality are in conflict. Remove freetype2-infinality? [y/N] y

Packages (2) freetype2-infinality-2.7.1-1 [removal] freetype2-2.7.1-1

Total Download Size: 2.56 MiB
Total Installed Size: 5.74 MiB
Net Upgrade Size: -0.60 MiB

:: Proceed with installation? [Y/n] n


Take a look at

https://aur.archlinux.org/packages/fontconfig-infinality/

replace it with

https://www.archlinux.org/packages/extra/x86_64/fontconfig/

ebrilo commented on 2017-01-15 13:53

>Hi I read that Dobo wanted to update the package january 13 but there is still no update on 15

You gotta be kidding..

Last Updated: 2017-01-13 23:54

fausterjames commented on 2017-01-15 13:15

Hi I read that Dobo wanted to update the package january 13 but there is still no update on 15. Do you guys know if this package is going to be uptaded ? If not could you point me to how to uninstall it in order to install freetype2 as when I try to do so I get :

`:: freetype2 and freetype2-infinality are in conflict. Remove freetype2-infinality? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: fontconfig-infinality: removing freetype2-infinality breaks dependency 'freetype2-infinality'
:: grip-git: removing freetype2-infinality breaks dependency 'freetype2-infinality'`

Ralf_Mardorf commented on 2017-01-14 19:52

Read the comments!

This was several times explained by the comments.

Read the Wiki!

validpgpkeys is basic PKGBUILD knowledge, let alone that this topic was part of the latest checksum discussion.

Aco commented on 2017-01-14 18:30

what is wrong..

Wats Verifying source file signatures with gpg...
freetype-2.7.1.tar.bz2 ... FAILED (unknown public key C1A60EACE707FDA5)
freetype-doc-2.7.1.tar.bz2 ... FAILED (unknown public key C1A60EACE707FDA5)
ft2demos-2.7.1.tar.bz2 ... FAILED (unknown public key C1A60EACE707FDA5)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build freetype2-infinality.

dobo commented on 2017-01-13 14:00

I will update tonight. I was quite busy last days.

ebrilo commented on 2017-01-12 18:25

>I don't know what you are discussing

We're discussing newely released freetype2 v. 2.7.1, wich is needed by updated harfbuzz.

Freetype2 v. 2.7.1 haven't yet been patched with infinality by it's maintainer (and looks like it will never be), plus original infinality site is long dead.

So some good guys yesterday did the maintainer's job here: https://github.com/archfan/infinality_bundle/

And we're currently talking about how to get this patched freetype2 to AUR in order to make the world perfect again.

Ralf_Mardorf commented on 2017-01-12 17:41

I don't know what you are discussing. Assuming it should be the harfbuzz issue, consider just to rebuild harfbuzz

$ sudo abs
$ sudo pacman -Syu
$ cp -ai /var/abs/extra/harfbuzz/ /tmp/
$ cd /tmp/harfbuzz/
$ nano PKGBUILD
$ makepkg -si

does the trick.

With nano I edited the pkgrel, but even this isn't required.

[rocketmouse@archlinux ~]$ pacman -Si harfbuzz{,-icu} | grep Ver
Version : 1.4.1-1
Version : 1.4.1-1
[rocketmouse@archlinux ~]$ pacman -Q harfbuzz{,-icu}
harfbuzz 1.4.1-2
harfbuzz-icu 1.4.1-2

Ok, now I see, official repositories provide 2.7.1 instead of 2.7, so it's not in sync anymore with the package from extra.

ebrilo commented on 2017-01-12 17:23

>Ask dobo :)

Looks like he's not going to do anything with it since 2016-11-29.. Orphan mb?

kokoko3k commented on 2017-01-12 11:51

> Will it be presented in aur?
Ask dobo :)