Package Base Details: gdc-git

Git Clone URL: https://aur.archlinux.org/gdc-git.git (read-only, click to copy)
Submitter: demizer
Maintainer: FFY00 (kozzi)
Last Packager: kozzi
Votes: 17
Popularity: 0.000000
First Submitted: 2012-03-23 03:09
Last Updated: 2019-08-23 10:42

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

soltanmm commented on 2013-10-29 03:25

I'm having trouble running gdc from this package; the linker reports that gphobos2 cannot be found. Running 'locate gphobos2' reveals only a static library in the AUR build directory. I cannot sync with libgphobos-devel from the Arch official packages, as this package supposedly conflicts with it according to pacman.

Halp meh~! (plzthxbai, etc.)

Anonymous comment on 2013-08-26 01:05

Added Arch integration changes done for the "gdc" package back into this package.

Anonymous comment on 2013-07-24 11:04

Updated to gcc snapshot 4.9-20130721.

Also, pkgver format from now on is {GCC_MAJOR_VERSION}.{GCC_SNAPSHOT_DATE}.{GDC_COMMIT_COUNT}.{GDC_COMMIT_HASH} to express both which gcc snapshot is used and which gdc commit was used.

Anonymous comment on 2013-04-04 11:27

Updated to gcc snapshot 4.9-20130331, had some problems compiling with the (new) current gcc 4.8 release beforehand.

Anonymous comment on 2013-03-26 11:21

Updated now: This will keep being compiled with GDC git master branch + GCC trunk snapshot, thus moving to GCC version 4.9.

Anonymous comment on 2013-03-24 01:06

I'll update this once I'm relatively sure whether continuing to use the master branch (and thus implicitly switch from gcc 4.8 which was released a few days ago to the new trunk version 4.9) or switching to gdc'c new gdc-4.8 branch and thus explicitly use the gcc 4.8.x releases is the best call. For now, I'm flagging this out-of-date as it probably won't work anymore (the master branch expects gcc 4.9 not 4.8).

Anonymous comment on 2013-03-11 18:15

Fixed now by using the latest gcc snapshot (4.8-20130310)

LeonidasXIV commented on 2013-03-11 09:58

Fails somewhere in package():

/tmp/yaourt-tmp-leonidas/aur-gdc-git/src/gcc-4.8-20130106/gcc/doc/service.texi:6: warning: node up `Service' in menu `Bugs' and in sectioning `Top' differ
make[2]: *** [doc/gcc.info] Error 1
rm gdc.pod cpp.pod gfdl.pod fsf-funding.pod gcc.pod gcov.pod
make[2]: Leaving directory `/tmp/yaourt-tmp-leonidas/aur-gdc-git/src/gcc-build/gcc'
make[1]: *** [install-gcc] Error 2
make[1]: Leaving directory `/tmp/yaourt-tmp-leonidas/aur-gdc-git/src/gcc-build'
make: *** [install] Error 2

I could't find the actual cause because that looks like warnings and shouldn't trigger an error.

Anonymous comment on 2013-01-12 19:41

Sorry for the delay, update brings:

- (Currently) newest gcc snapshot (20130106), fixes issue reported by beatgammit
- Updated gcc_pure64 patch (because a few lines were removed from t-linux64 in trunk)
- Added sha256 checksums

Anonymous comment on 2013-01-12 19:40

Sorry for the delay, update brings:

- (Currently) newest gcc snapshot (20130106), fixes your issue beatgammit
- Updated gcc_pure64 patch (because a few lines were removed from t-linux64 in trunk)
- Added sha256 checksums