Package Base Details: gdm-plymouth

Git Clone URL: https://aur.archlinux.org/gdm-plymouth.git (read-only, click to copy)
Submitter: damian01w
Maintainer: Taijian
Last Packager: Taijian
Votes: 67
Popularity: 2.01
First Submitted: 2015-03-18 02:35
Last Updated: 2020-05-05 15:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

justin8 commented on 2016-10-18 09:45

I'm getting the following when trying to build this in a clean chroot:

19:41:54 checking for XLIB... yes
19:41:54 checking for GTK... no
19:41:54 configure: error: Package requirements (gtk+-3.0 >= 2.91.1
19:41:54 ) were not met:
19:41:54
19:41:54 Package 'gdk-3.0' requires 'gio-unix-2.0 >= 2.49.4' but version of gio-unix-2.0 is 2.48.2
19:41:54

frosticecold commented on 2016-10-12 10:53

Was failing to upgrade to gnome 3.22

Currently reinstalled and edited the pkg build,
Replaced this string 'gnome-shell<3.21.0'
TO 'gnome-shell'

Upgrading atm, will post if everything works fine.

EDIT:

Everything works fine.
Edited the pkg build with previous line and everything 100%

Vistaus commented on 2016-09-25 08:08

Please update to 3.22, I miss this so much on 3.22 :-(

lazydays79 commented on 2016-04-18 14:00

@nullptr_t Thanks!

mcComBat commented on 2016-04-17 20:57

@nullptr_t Thanks!

nullptr_t commented on 2016-04-17 14:58

Sorry for the inconvenience. I updated the dependency to work for a full release version like 3.20.*

lazydays79 commented on 2016-04-17 08:42

@shihjay2, worked great, thanks!

shihjay2 commented on 2016-04-16 18:08

In the meantime while we wait for the maintainer to fix the package, reinstall gdm-plymouth and edit PKGBUILD at the line
depends=('plymouth' 'gnome-shell=3.20.0' 'gnome-session' 'upower' 'xorg-xrdb' 'xorg-server' 'xorg-server-xwayland' 'xorg-xhost')
and change to
depends=('plymouth' 'gnome-shell>=3.20.0' 'gnome-session' 'upower' 'xorg-xrdb' 'xorg-server' 'xorg-server-xwayland' 'xorg-xhost')

Once it is reinstalled, then you can update gnome-shell.

lazydays79 commented on 2016-04-16 17:31

So anything new about the dependency to gnome-shell?

I can't do an update since a couple of days:

:: Synchronizing package databases...
core 121.0 KiB 1247K/s 00:00 [##############################] 100%
extra 1749.6 KiB 6.65M/s 00:00 [##############################] 100%
community 3.4 MiB 9.39M/s 00:00 [##############################] 100%
multilib 161.7 KiB 11.3M/s 00:00 [##############################] 100%
archlinuxfr 11.3 KiB 1891K/s 00:00 [##############################] 100%
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: gdm-plymouth: installing gnome-shell (3.20.1-1) breaks dependency 'gnome-shell=3.20.0'

justin8 commented on 2016-04-15 23:58

Probably add a <= as well so that it will block gnome shell 3.22 updates until it's ready; but get rid of the exact version match on 3.20.0