Package Base Details: gtk3-classic

Git Clone URL: https://aur.archlinux.org/gtk3-classic.git (read-only, click to copy)
Keywords: gtk3
Submitter: jonathon
Maintainer: jonathon (lah7)
Last Packager: jonathon
Votes: 39
Popularity: 1.63
First Submitted: 2019-11-26 10:28
Last Updated: 2021-04-23 15:06

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

jonathon commented on 2020-08-17 14:14

I can't replicate if I install audacious then replace gtk3 with gtk3-classic. Given it's a warning you can very likely just ignore it - or it's your AUR helper being "helpful".

D.Dave commented on 2020-08-17 14:06

Nope: If I try to install gtk3 I don't get these warnings: to be more precise: I only get the warnings to remove gtk3-classic and lib32-gtk3-classic.

jonathon commented on 2020-08-17 14:04

Do you get any warning if you try to install gtk3 ?

D.Dave commented on 2020-08-17 13:53

So I attempted with 3.24.22-1 and unfortunately I got the same warnings: light-locker and audacity needs to be removed. The strange things is that I also have a lot of other packages which needs libgdk-3.so=0-64 and libgtk-3.so=0-64, which doesn't give these warnings.

D.Dave commented on 2020-08-17 03:22

Hi, is an upgrade from 3.24.14; No warnings if I attempt to install the official gtk3. I see that you pushed a new commit: tomorrow I will try again and I'll report back. Thank you.

jonathon commented on 2020-08-17 01:05

Is that an installation or an upgrade? gtk3-classic provides libgdk-3.so=0-64.

D.Dave commented on 2020-08-17 00:35

With this new release (3.24.21-1), I've found the same warnings as reported by osch: https://aur.archlinux.org/packages/gtk3-classic/#comment-731690


Warning: installing gtk3-classic (3.24.21-1) breaks dependency 'libgdk-3.so=0-64' required by audacity
Add audacity to remove
Warning: installing gtk3-classic (3.24.21-1) breaks dependency 'libgtk-3.so=0-64' required by audacity
Add audacity to remove
Warning: installing gtk3-classic (3.24.21-1) breaks dependency 'libgdk-3.so=0-64' required by light-locker
Add light-locker to remove
Warning: installing gtk3-classic (3.24.21-1) breaks dependency 'libgtk-3.so=0-64' required by light-locker
Add light-locker to remove

glitsj16 commented on 2020-05-24 11:28

@Rynak The reason why audacity is conflicting is because the repo gtk3 package now provides libgailutil-3.so, libgdk-3.so and libgtk-3.so too. If you add those to the provides array in this PKGBUILD it should fix things.

Rynak commented on 2020-05-24 09:16

Audacity seems to conflict with this (although I can't see why) and installs gtk3 instead. One "solution" is to install audacity-dependencies manually and then install audacity without dependencies.

But if someone figures out what the actual problem that would be great :)

TomaszGasior commented on 2020-05-08 05:30

@loto Do you want to be maintainer of this package? If yes please contact with current maintainer for this: https://github.com/krumelmonster/gtk3-mushrooms/issues/30 . It may be better to continue my original project instead creating new one. :)