Package Base Details: iup

Git Clone URL: https://aur.archlinux.org/iup.git (read-only, click to copy)
Submitter: None
Maintainer: daurnimator (blueowl)
Last Packager: blueowl
Votes: 11
Popularity: 0.163672
First Submitted: 2009-09-13 15:00 (UTC)
Last Updated: 2020-08-07 11:49 (UTC)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

ktamp commented on 2017-05-14 13:39 (UTC)

Please move iupgl above iup_plot.

lgg2 commented on 2016-04-12 16:39 (UTC)

Can be used downloading the files from their SourceForge place and then install first the "runtimes" (/.install) and later "development" (/.install_dev) both with root permissions. In my case works OK.

SneakySnake commented on 2015-11-23 07:43 (UTC)

Okay, I'm disowning this, because it's not very maintainable, and I have lost interest in it.

neo_ar commented on 2015-07-10 00:36 (UTC)

This package fails to build due to compilation errors. ../tecmake.mak:1583: recipe for target '../obj/Linux319_64/iupgtk_dialog.o' failed make[2]: *** [../obj/Linux319_64/iupgtk_dialog.o] Error 1 Makefile:11: recipe for target 'iup' failed make[1]: *** [iup] Error 2 Makefile:9: recipe for target 'iup' failed make: *** [iup] Error 2 ==> ERROR: A failure occurred in build(). Aborting...

mihaim commented on 2014-09-13 08:44 (UTC)

TrialnError, the other package uses the GTK+ frontent UI toolkit like this one. Basically they are duplicate packages. I found iup-gtk to be the proper name since there exists (at least it used to) another official FE for IUP, namely Motif. Have a look at Webkit, the QT FE is named "qtwebkit", while the GTK+ FE is named "webkitgtk". There is no generic "webkit" package, because it requires one GUI tollkit to be built against in order to be useful. :P

TrialnError commented on 2014-09-11 09:27 (UTC)

AUR/iup isn't maintained anymore. If that name is more appropiate. Just one particular try to update that PKGBuild to the latest version. But as this is maintained, the -gtk maybe (just maybe) isn't necessary both could be merged. Edit: Oh, and I marked this out of date because 3.11.1 is released

TrialnError commented on 2014-09-11 09:20 (UTC)

Updated PKGBuild in case of Guidelines. Could not test if it builds.

mihaim commented on 2014-02-02 18:16 (UTC)

I dropped its maintainance because of the poor quality of its release tarballs. I do not have the time to debug it, I hope someone will help you, mgushee.

mgushee commented on 2014-02-02 13:15 (UTC)

I'm getting a build failure on x86_64: Tecmake: linking iupview ... g++ -o ../bin/Linux312_64/iupview ../obj/iupview/Linux312_64/iup_view.o ../lib/Linux312_64/libiupim.a ../lib/Linux312_64/libiupimglib.a ../lib/Linux312_64/libiupcontrols.a /usr/lib/liblua.a ../lib/Linux312_64/libiupcd.a ../lib/Linux312_64/libiupgl.a ../lib/Linux312_64/libiup.a /usr/lib/libcd.a /usr/lib/libim.a /usr/lib/libz.a -L/usr/X11R6/lib64 -lGLU -lGL -lXmu -lXt -lXext -lX11 -lm -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lfontconfig -lfreetype -lgdk-x11-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgdk_pixbuf-2.0 -lgobject-2.0 -lglib-2.0 g++: error: /usr/lib/libcd.a: No such file or directory g++: error: /usr/lib/libim.a: No such file or directory ../tecmake.mak:1374: recipe for target '../bin/Linux312_64/iupview' failed make[2]: *** [../bin/Linux312_64/iupview] Error 1 Makefile:11: recipe for target 'iupview' failed make[1]: *** [iupview] Error 2 Makefile:41: recipe for target 'iupview' failed make: *** [iupview] Error 2 ==> ERROR: A failure occurred in build(). Aborting... (I installed the latest AUR pkgs of im & cd immediately before attempting to build this one)