Package Base Details: jdk

Git Clone URL: https://aur.archlinux.org/jdk.git (read-only, click to copy)
Submitter: td123
Maintainer: dbermond
Last Packager: dbermond
Votes: 1096
Popularity: 0.76
First Submitted: 2011-08-27 17:56
Last Updated: 2022-01-20 15:19

Packages (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

dbermond commented on 2019-03-29 01:05

@archer_linux Build jre normally with makepkg, then build jdk with makepkg -d, and then install both with pacman -U. Or you can build each one in a chroot and then install both with pacman -U.

archer_linux commented on 2019-03-28 16:09

Hello, I can't update my Java Packages. I guess the fault is that both jre and jdk are linked to the exact same source. Can anybody confirm this?

Regards, Thorsten

lordchaos commented on 2019-03-26 14:11

I'm trying to use this version with the latest SQLDeveloper, but it doesn't seem to work?

Error: /usr/lib/jvm/default/bin/java not found or not a valid JDK

x1carbon6 :: /opt/sqldeveloper » /usr/lib/jvm/default/bin/java -version java version "11.0.2" 2019-01-15 LTS Java(TM) SE Runtime Environment 18.9 (build 11.0.2+9-LTS) Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.2+9-LTS, mixed mode)

Det commented on 2019-03-18 09:32

Nice homepage.

gonciarz commented on 2019-03-18 08:39

Just a reminder, tomorrow JDK 12 will be released. Thanks for your effort.

semenoveg commented on 2019-03-01 06:51

https://aur.archlinux.org/cgit/aur.git/commit/?h=jdk&id=a19ae6a2f602
This change added depends of jre. I get file conflicts when yaourt try to install jre as depend:

....
jre: /usr/lib/jvm/java-11-jdk/lib/server/libjvm.so exists in filesystem (owned by jdk)
jre: /usr/lib/jvm/java-11-jdk/lib/tzdb.dat exists in filesystem (owned by jdk)
jre: /usr/lib/jvm/java-11-jdk/release exists in filesystem (owned by jdk)
....
and many other files

UPD: problem was fixed by reinstalling jdk.

onizuka_79 commented on 2019-01-21 16:54

Hello PFM. You can edit the PKGBUILD and change the download URL by yourself with the following link : https://download.oracle.com/otn-pub/java/jdk/11.0.2+9/f51449fcd52f4d52b93a989c5c56ed3c/jdk-11.0.2_solaris-sparcv9_bin.tar.gz

don't forget to change to change sha256sums also 52b7f4298af04bc3079b73c071b85db87a4509ea6110b752e941b5cb360ef181 :)

AND change pkgver=11.0.1 to 11.0.2

StuckUpCreations commented on 2019-01-19 19:10

would be great to have the updated package of jdk, as its flagged out of date now..

pfm commented on 2019-01-16 09:22

Download from Oracle server fails:

curl: (22) The requested URL returned error: 404 Not Found ==> ERROR: Failure while downloading https://download.oracle.com/otn-pub/java/jdk/11.0.1+13/90cf5d8f270a4347a95050320eef3fb7/jdk-11.0.1_linux-x64_bin.tar.gz Aborting... ==> ERROR: Could not download sources.

Please adjust the download link.

rellieberman commented on 2019-01-08 19:02

Java web start has been deprecated since JDK 11

https://www.oracle.com/technetwork/java/javase/11-relnote-issues-5012449.html

you can try to use icedtea-web package from the office repo: https://www.archlinux.org/packages/extra/x86_64/icedtea-web/

or alternatively install an older version of jre.