Package Base Details: kodi-git

Git Clone URL: https://aur.archlinux.org/kodi-git.git (read-only)
Submitter: BlackIkeEagle
Maintainer: graysky
Last Packager: graysky
Votes: 82
Popularity: 0.026681
First Submitted: 2014-10-23 06:38
Last Updated: 2019-05-17 19:02

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

beojan commented on 2018-01-14 18:01

Doesn't build:

/home/beojan/.cache/pacaur/kodi-git/src/xbmc/xbmc/dbwrappers/sqlitedataset.cpp:295: error: undefined reference to 'sqlite3_backup_init'

/home/beojan/.cache/pacaur/kodi-git/src/xbmc/xbmc/dbwrappers/sqlitedataset.cpp:299: error: undefined reference to 'sqlite3_backup_step'

/home/beojan/.cache/pacaur/kodi-git/src/xbmc/xbmc/dbwrappers/sqlitedataset.cpp:300: error: undefined reference to 'sqlite3_backup_finish'

collect2: error: ld returned 1 exit status

make[2]: *** [CMakeFiles/kodi.dir/build.make:486: kodi-x11] Error 1

make[2]: Leaving directory '/home/beojan/.cache/pacaur/kodi-git/src/xbmc'

make[1]: *** [CMakeFiles/Makefile2:1552: CMakeFiles/kodi.dir/all] Error 2

make[1]: Leaving directory '/home/beojan/.cache/pacaur/kodi-git/src/xbmc'

make: *** [Makefile:141: all] Error 2

chuck123 commented on 2018-01-06 13:34

Thank you very much for your help. Everything installed succesfully. Inputstream also installed without any errors. Problem solved. :)

Niklas commented on 2018-01-06 00:19

No you didn't. If you don't install kodi-dev-git when you install kodi-git, it won't be installed. You explicately need to install BOTH at the same time. So just reinstall kodi-git while also installing kodi-git-dev.

A helper like Yaourt would probably take care of this.

chuck123 commented on 2018-01-05 22:59

so this means that i already had installed kodi-dev-git. But when i type pacman Qqm only kodi-git is listed as installed kodi-dev-git isn't listed. So kodi-dev-git is installed right? But i still can't install inputstream adaptive. Same error.

Niklas commented on 2018-01-05 22:47

You must build both kodi-git and kodi-dev-git at once and install both resulting packages. They do not just depend on each other, you can't even build the one packages without the other when using this PKGBUILD. That's why reinstalling kodi-git is necessary.

chuck123 commented on 2018-01-05 22:39

when i try to install kodi-dev-git pacman always installs kodi-git (reinstalls kodi-git) And kodi-dev-git stays uninstalled.

Niklas commented on 2018-01-05 21:51

kodi-dev-git contains the files needed to build some Kodi addons. It is a subpackage of kodi-git.

chuck123 commented on 2018-01-05 21:11

kodi-git yes. But not kodi-dev-git. I am installing kodi-dev-git now. Arent kodi-git and kodi-dev-git the same?

Niklas commented on 2018-01-05 20:42

kodi-git and kodi-dev-git as well? They're dependencies so I think you should have them though.

chuck123 commented on 2018-01-05 19:40

i installed kodi-platform-git. but unfortunatly the same error occurs.

/home/****/.cache/pacaur/kodi-addon-inputstream-adaptive-git/src/kodi-addon-inputstream-adaptive-git/src/main.h:22:10: schwerwiegender Fehler: kodi/addon-instance/Inputstream.h: Datei oder Verzeichnis nicht gefunden #include <kodi addon-instance="" inputstream.h=""></kodi>