Package Base Details: kodi-git

Git Clone URL: https://aur.archlinux.org/kodi-git.git (read-only, click to copy)
Submitter: BlackIkeEagle
Maintainer: graysky
Last Packager: graysky
Votes: 82
Popularity: 0.000023
First Submitted: 2014-10-23 06:38
Last Updated: 2021-03-01 12:01

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

chuck123 commented on 2018-01-05 19:40

i installed kodi-platform-git. but unfortunatly the same error occurs.

/home/****/.cache/pacaur/kodi-addon-inputstream-adaptive-git/src/kodi-addon-inputstream-adaptive-git/src/main.h:22:10: schwerwiegender Fehler: kodi/addon-instance/Inputstream.h: Datei oder Verzeichnis nicht gefunden #include <kodi addon-instance="" inputstream.h=""></kodi>

Niklas commented on 2018-01-05 19:31

You need kodi-platform-git, a dependency which is apparently not included in the PKGBUILD.

chuck123 commented on 2018-01-05 18:53

thanks for your help. I did what you advised me to do. but at the end i get following error: /home/****/.cache/pacaur/kodi-addon-inputstream-adaptive-git/src/kodi-addon-inputstream-adaptive-git/src/main.h:22:10: schwerwiegender Fehler: kodi/addon-instance/Inputstream.h: Datei oder Verzeichnis nicht gefunden #include <kodi addon-instance="" inputstream.h=""></kodi>

Translation of the error: schwerwiegender Fehler = fatal error Datei oder Verzeichnis nicht gefunden = file or directory not found

What went wrong?

Niklas commented on 2018-01-05 18:26

Just comment that source line and uncomment the one two lines below.

chuck123 commented on 2018-01-05 18:20

So I should change this line: source=('kodi-addon-inputstream-adaptive-git::git+https://github.com/peak3d/inputstream.adaptive.git#branch=Krypton')

to

source=('kodi-addon-inputstream-adaptive-git::git+https://github.com/peak3d/inputstream.adaptive.git#branch=Leia') ?

Niklas commented on 2018-01-05 18:16

@chuck123 Look at the PKGBUILD of the AUR package you linked - you have to modify the source link to build it for Kodi 18.

chuck123 commented on 2018-01-05 18:07

Why isn't inputsream-adaptive included? On Windows and for example Ubuntu inputsream-adaptive is always included in the latest Kodi 18 builds. How can I add it? The one which is available in the aur is only for Kodi 17+ https://aur.archlinux.org/packages/kodi-addon-inputstream-adaptive-git/. Could soneone help me out here. I need it for addons like DAZN and Eurosport Player. Thanks.

klusark commented on 2017-11-19 21:01

libfmt-git doesn't build for me, however fmt does and it seems to fill the dependency. Also, rapidjson in the repos has a high enough version number.

Lenovsky commented on 2017-11-16 12:59

@Throne3d I thought about it, but I don't really like this solution. The way how I understand it, to prevent a warning of downgrading, now and in the future, I would have to maintain the "epoch" (removal will restore the value to 0) - what I'm not really up to ;)

BlackIkeEagle commented on 2017-11-16 11:55

You should not use epoch for AUR packages, the mention of the maintainer is sufficient, you should read the comments anyway when using packages from AUR