Package Base Details: kodi-standalone-service

Git Clone URL: https://aur.archlinux.org/kodi-standalone-service.git (read-only, click to copy)
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 61
Popularity: 0.001627
First Submitted: 2014-11-05 20:25
Last Updated: 2020-02-02 19:47

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 Next › Last »

graysky commented on 2015-09-20 17:43

@bananabrain - Do you have the needed drivers for video? On my intel system I needed to install xf86-video-intel to get it to work.

graysky commented on 2015-09-20 17:07

@bananabrain - I just spun up a new VM and can confirm your findings... I can't explain it though. Anyone else?

bananabrain commented on 2015-09-15 22:22

For no reason I can work out, I can't get this to autostart without the presence of /etc/X11/Xwrapper.config containing "needs_root_rights = yes".

Error grep from /var/lib/kodi/.local/share/xorg/Xorg.0.log shows:

(EE) Error systemd-logind returned paused fd for drm node
(EE)
(EE) AddScreen/ScreenInit failed for driver 0
(EE)
(EE)
(EE) Please also check the log file at "/var/lib/kodi/.local/share xorg/Xorg.0.log" for additional information.
(EE)
(EE) Server terminated with error (1). Closing log file.

I can live with this, but it concerns me that it's clearly stated here that since 1.8-1 the Xwrapper.config file should no longer be needed, which makes me think I've done something wrong.

Does anyone have any idea what that might be? Is there any other helpful information I can provide?

graysky commented on 2015-06-04 17:38

It was setup for any but that lead to confusion by ArchARM users since they provide this functionality in their package. The post install scriptlet here will run into problem when the kodi user is on the system already so I gate that by defining the arch as I have.

bjo commented on 2015-06-04 10:01

Please change arch to 'any', because it's only a service file.

gonciarz commented on 2015-04-25 08:54

(1/1) installing kodi-standalone-service [################################################################] 100%
groupadd: GID '420' already exists
useradd: group 'kodi' does not exist
passwd: user 'kodi' does not exist
chown: invalid user: ‘kodi:kodi’
error: command failed to execute correctly

That may help:
usermod -l kodi xbmc
groupmod -n kodi xbmc

maggie commented on 2015-04-01 19:31

Works for me.

jolan commented on 2015-04-01 15:14

Once again -- can you confirm that it's broken for you as well?

graysky commented on 2015-04-01 08:45

There is nothing to patch in the package. I think you are confused over what that link means.

jolan commented on 2015-04-01 02:13

Was hoping you knew -- haven't had time to look at it yet.

Can you confirm that it's broken for you?